Yoshimi does not show up

All your LV2 and LADSPA goodness and more.

Moderators: khz, MattKingUSA

zoco
Established Member
Posts: 177
Joined: Fri Jan 25, 2019 4:04 pm

Re: Yoshimi does not show up

Postby zoco » Wed Apr 17, 2019 6:24 pm

folderol wrote:
zoco wrote:It did work on the vk. Not on the real one.
I checked all the settings and could not get it working. Tried this in the settings of Yoshoma itself and Jack connections without result.
With the repository version this all also worked so no benefit here. Did not try the keyboard on that version so i can not tell if that did work then. Keyboard corresponds as could be expected with computer and works perfectly with all other software.

How are you trying to connect the keyboard. By default, Yoshimi will look for a Jack MIDI port. I usually, have ALSA MIDI set, then use qjackctl to actually make the link. Once you know the name the keyboard presents you can write it in the ALSA MIDI Source field, and Yoshimi wil automatically look for that when it starts.


Like i said i already tried that all. Including as you now explain with all possible Yoshima settings, over Alsa, over Jack, trying several Jack connections.
Problem is that i know go into inconvenient shifts and not have time in short therms to try this again extensively.

tavasti
Established Member
Posts: 763
Joined: Tue Feb 16, 2016 6:56 am
Location: Kangasala, Finland
Contact:

Re: Yoshimi does not show up

Postby tavasti » Wed Apr 17, 2019 7:19 pm

Have you tried if ZynAddSubFX packes would serve you better? I am sure about differences, but they are pretty close each other?
Linux veteran & Novice musician

Hear my music at https://audiu.net/users/tawaste

folderol
Established Member
Posts: 889
Joined: Mon Sep 28, 2015 8:06 pm
Location: Here, of course!
Contact:

Re: Yoshimi does not show up

Postby folderol » Wed Apr 17, 2019 8:24 pm

zoco wrote:
folderol wrote:
zoco wrote:It did work on the vk. Not on the real one.
I checked all the settings and could not get it working. Tried this in the settings of Yoshoma itself and Jack connections without result.
With the repository version this all also worked so no benefit here. Did not try the keyboard on that version so i can not tell if that did work then. Keyboard corresponds as could be expected with computer and works perfectly with all other software.

How are you trying to connect the keyboard. By default, Yoshimi will look for a Jack MIDI port. I usually, have ALSA MIDI set, then use qjackctl to actually make the link. Once you know the name the keyboard presents you can write it in the ALSA MIDI Source field, and Yoshimi wil automatically look for that when it starts.


Like i said i already tried that all. Including as you now explain with all possible Yoshima settings, over Alsa, over Jack, trying several Jack connections.
Problem is that i know go into inconvenient shifts and not have time in short therms to try this again extensively.


Sorry to hear you're on difficult work shifts :(

When you have time please try the following:

With no other audio or midi applications running, start up qjackctl.
Run Yoshimi and in the ALSA tab make sure 'Set as preferred MIDI' has been checked. If not, set it, save and restart Yoshimi.

Open 'Connect' in qjackctl and select the ALSA tab. On the left hand side you should see your keyboard and on the right hand side you should see Yoshimi. select these and connect them. Playing the keyboard should now give sound from Yoshimi.

As for LV2 I'm waiting to hear back from the guy who produced the ppa, but can assure you that my builds here have all worked without problems on Ardour, Muse, and qtractor for years!

zoco
Established Member
Posts: 177
Joined: Fri Jan 25, 2019 4:04 pm

Re: Yoshimi does not show up

Postby zoco » Thu Apr 18, 2019 11:20 am

folderol wrote:When you have time please try the following:

With no other audio or midi applications running, start up qjackctl.
Run Yoshimi and in the ALSA tab make sure 'Set as preferred MIDI' has been checked. If not, set it, save and restart Yoshimi.

Open 'Connect' in qjackctl and select the ALSA tab. On the left hand side you should see your keyboard and on the right hand side you should see Yoshimi. select these and connect them. Playing the keyboard should now give sound from Yoshimi.


I must look back as i am not totally sure, but these kind of settings i have tried. What you now mentioned sounds very familiar to me and i am almost shure i tried this too. I am not a totally newb with these kind of settings.
But i will try it when i get to it, and then follow your words step by step again. I seems i must do something wrong somewhere.


Return to “Plugins, Effects and Instruments”

Who is online

Users browsing this forum: No registered users and 1 guest