Plugins exported by Carla as a standalone LV2 plugin

All your LV2 and LADSPA goodness and more.

Moderators: MattKingUSA, khz

RockVice77
Established Member
Posts: 4
Joined: Sat Feb 24, 2018 5:37 pm

Plugins exported by Carla as a standalone LV2 plugin

Postby RockVice77 » Tue Jan 08, 2019 8:47 pm

Hello,
I am experimenting with Carla 2.0-RC2 to export some Windows VST as standalone LV2 plugins.
The procedure to export the plugins is pretty straightforward and I am saving the *.lv2 files in my /home/user/.lv2
All the plugins saved by Carla are properly identified by Ardour when searching new plugins at the start-up, but then I am able to load only a single plugin during each Ardour session: as soon as I ask Ardour to load a second LV2 plugin generated by Carla it fails providing the following output:

Code: Select all

lilv_plugin_instantiate(): error: No plugin <file:///home/rocco/.lv2/Rough_Rider.lv2/Rough_Rider.ttl> in <file:///home/rocco/.lv2/Rough_Rider.lv2/Rough_Rider.so>


If I delete from the track all the plugins and then I try again Ardour is able to load the plugin that failed previously returning this output:

Code: Select all

lv2ui_descriptor(0) has URI 'file:///home/rocco/.lv2/Rough_Rider.lv2/ext-ui'
Carla assertion failure: "index < pData->param.count" in file ../backend/plugin/CarlaPluginBridge.cpp, line 1698


I know that falkTx probably will not read this post, but I wold like to understand if anyone else is experiencing the same issue or if I am just missing a silly step to have all the exported plugins working in Ardour

Return to “Plugins, Effects and Instruments”

Who is online

Users browsing this forum: No registered users and 3 guests