Calf Limiter is crashing Carla

All your LV2 and LADSPA goodness and more.

Moderators: khz, MattKingUSA

zettberlin
Established Member
Posts: 116
Joined: Sun Apr 13, 2008 7:21 pm
Location: Celle
Contact:

Calf Limiter is crashing Carla

Postby zettberlin » Wed Jan 21, 2015 10:23 pm

I have a strange behaviour of some Calf-plugins in Carla. They work perfectly OK but whenever I adjust something in Calf Limiter or Multiband Limiter Carla crashes with core dumped as I close the native UI of the plugin.

Strange enough, that this happens in all combinations of Carla-git from Ubuntu 14.04 repos as well as in Carla built from git today and so with the repo-binaries of Calf as well as Calf built from git.

The terminal tells me this:

Code: Select all

Plugin DSP wants UI feature 'http://lv2plug.in/ns/ext/data-access', ignoring this
Plugin DSP wants UI feature 'http://lv2plug.in/ns/ext/instance-access', ignoring this
Will use LV2 Gtk2 UI, NOT!
Plugin DSP wants UI feature 'http://lv2plug.in/ns/ext/instance-access', ignoring this
Plugin DSP wants UI feature 'http://lv2plug.in/ns/ext/data-access', ignoring this
Will use LV2 Gtk2 UI, NOT!
using block size: 256
mlock 446078 bytes
Will use UI-Bridge, binary: "/usr/local/lib/carla/carla-bridge-lv2-gtk2"
CALF DEBUG: instance 0x3c60070 data 0x3c6e5f0
CALF DEBUG: calf 0x7f59d19a1df0 cpi 0x7f59d0fa2930
Send configures...
Trying to get window...
Match found using UTF-8 name
Match found using simple name
Speicherzugriffsfehler (Speicherabzug geschrieben)


The last line says: segfault.
Most strange, that it used to work perfectly well last week, no trouble like this at all, as long as I used Carla from Ubuntus Repos and still no trouble with the one build from source.
Now this happens always, including with Ubuntus Carla and Calf, that used to work OK and that have not changed. I also deleted the settings in .config/FalkTX several times, made new patches etc....
Any version of Carla dies when closing the native GUI of any version of Calf Limiter, Calf Multiband Limiter and Calf Gate. The plugins have to be connected in the patchbay, opening/closing them when unconnected does not trigger the crash(nor does it anything useful ;-) )

What can this be?
nostrum fungitur

Return to “Plugins, Effects and Instruments”

Who is online

Users browsing this forum: No registered users and 13 guests