Rave Generator 2 plugin needs Qt4 for the UI, but it's unsupported

All your LV2 and LADSPA goodness and more.

Moderators: khz, MattKingUSA

Post Reply
Toejam76
Established Member
Posts: 45
Joined: Sat Jun 20, 2020 10:41 am
Has thanked: 4 times
Been thanked: 2 times

Rave Generator 2 plugin needs Qt4 for the UI, but it's unsupported

Post by Toejam76 »

https://blog.wavosaur.com/category/vst-plugins/

I'd like to replace the bridged plugin with the native version, which needs QT4 for the UI according to the manual.
But libqt4 isn't avaible anymore for Ubuntu 20.04 and later.

There was a inofficial PPA (http://ppa.launchpad.net/rock-core/qt4/ubuntu), which can't be added because:
"Updating from such a repository can't be done securely, and is therefore disabled by default"

I read that QT5 is backwards compatible and tried to install some other Qt4 software like qjackrcd and that one works surprisingly with UI, but not the plugin.

The bridged plugin works, but I noticed that some plugins cause a lot of DSP load, don't accept the sustain foot controller or sometimes hang during recording for some reason. Native plugins don't seem to have that problem.

Anyone got a idea how to get a QT4 UI in Ubuntu 20.04+ based distros ?
Kott
Established Member
Posts: 439
Joined: Thu Mar 21, 2013 12:55 am
Location: Vladivostok
Has thanked: 2 times
Been thanked: 5 times

Re: Rave Generator 2 plugin needs Qt4 for the UI, but it's unsupported

Post by Kott »

where did you get about Qt4?

Code: Select all

ldd ./RaveGenerator2VST-x64.so 
        linux-vdso.so.1 (0x00007ffefb5fd000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f06cdaba000)
        libsndfile.so.1 => /usr/lib64/libsndfile.so.1 (0x00007f06cda3c000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f06cd823000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f06cd6de000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f06cd6c3000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f06cd4f4000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f06cd4d1000)
        libFLAC.so.8 => /usr/lib64/libFLAC.so.8 (0x00007f06cd494000)
        libogg.so.0 => /usr/lib64/libogg.so.0 (0x00007f06cd489000)
        libvorbis.so.0 => /usr/lib64/libvorbis.so.0 (0x00007f06cd45b000)
        libvorbisenc.so.2 => /usr/lib64/libvorbisenc.so.2 (0x00007f06cd3b0000)
        libspeex.so.1 => /usr/lib64/libspeex.so.1 (0x00007f06cd392000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f06ced59000)
Toejam76
Established Member
Posts: 45
Joined: Sat Jun 20, 2020 10:41 am
Has thanked: 4 times
Been thanked: 2 times

Re: Rave Generator 2 plugin needs Qt4 for the UI, but it's unsupported

Post by Toejam76 »

It says so in the manual:
2.3 Linux installation
copy RaveGenerator2-x64.so or RaveGenerator-x86.so to your LinuxVST folder.
Note :
RaveGenerator2 UI use QT4 under LGPL license : your system must have the QT4 lib
installed in order to have the custom interface.
Kott
Established Member
Posts: 439
Joined: Thu Mar 21, 2013 12:55 am
Location: Vladivostok
Has thanked: 2 times
Been thanked: 5 times

Re: Rave Generator 2 plugin needs Qt4 for the UI, but it's unsupported

Post by Kott »

True. It requires actually.
thebutant
Established Member
Posts: 142
Joined: Sun Nov 18, 2012 12:59 pm
Has thanked: 9 times
Been thanked: 1 time

Re: Rave Generator 2 plugin needs Qt4 for the UI, but it's unsupported

Post by thebutant »

Does anyone know how to make it work with newer systems?
I love Rave Generator 2, but currently the GUI isn't working anymore (the qt4/qt5 issue described in this thread).
I can still use presets, but it'd be a shame if this gem of a plugin was to be abandonded because of qt issues.
User avatar
LAM
Established Member
Posts: 236
Joined: Thu Oct 08, 2020 3:16 pm
Has thanked: 16 times
Been thanked: 25 times

Re: Rave Generator 2 plugin needs Qt4 for the UI, but it's unsupported

Post by LAM »

It works on my system: tested in Carla 2.3 and Ardour 6.5 (Debian/sid with KXstudio repo). :?:
tripomatic
Established Member
Posts: 133
Joined: Mon May 21, 2012 4:42 pm
Been thanked: 2 times

Re: Rave Generator 2 plugin needs Qt4 for the UI, but it's unsupported

Post by tripomatic »

thebutant wrote: Tue May 04, 2021 12:42 pm Does anyone know how to make it work with newer systems?
I love Rave Generator 2, but currently the GUI isn't working anymore (the qt4/qt5 issue described in this thread).
I can still use presets, but it'd be a shame if this gem of a plugin was to be abandonded because of qt issues.
I had same with another plugin that needed qt4 on debian testing/unstable. I just downloaded the deb packagess of debian stable(i think) of the library files that the plugin needed.
Extracted them and copied the required files to /usr/local/lib . Dirty hack but it worked. When not needing the anymore i safely can remove them.
Post Reply