No Jack in timecode sync for Ardour

Unofficial support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: MattKingUSA, khz

Post Reply
CraigPid
Established Member
Posts: 131
Joined: Fri Mar 13, 2015 10:52 pm

No Jack in timecode sync for Ardour

Post by CraigPid »

Using Mint with the Kx studio repos there is no option for Jack sync on the button under the midi panic button. Just internal and MTC.

User avatar
lilith
Established Member
Posts: 1298
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: No Jack in timecode sync for Ardour

Post by lilith »

I don't have Ardour installed at the moment, but did you read this?

https://manual.ardour.org/synchronizati ... nd-slaves/

Possibly you have to change some settings.

CraigPid
Established Member
Posts: 131
Joined: Fri Mar 13, 2015 10:52 pm

Re: No Jack in timecode sync for Ardour

Post by CraigPid »

I did look at that stuff in the prefs. Also in session properties it's already set to use jack as timecode master. Maybe it's something in the build. I don't really want to ask on the Ardour forums as they don't like to give support for unofficial builds. I usually use Arch and it works fine but they kids always boot into Mint so I have that as a convenience so I don't have to reboot if I want to quickly pull up a project.

CraigPid
Established Member
Posts: 131
Joined: Fri Mar 13, 2015 10:52 pm

Re: No Jack in timecode sync for Ardour

Post by CraigPid »

I found it now. In preferences under sync I needed to set the external timecode source to Jack. It was set to midi timecode.

User avatar
lilith
Established Member
Posts: 1298
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: No Jack in timecode sync for Ardour

Post by lilith »

CraigPid wrote:
Mon Mar 16, 2020 4:27 pm
I found it now. In preferences under sync I needed to set the external timecode source to Jack. It was set to midi timecode.
Perfect 8)

b4rney
Established Member
Posts: 31
Joined: Sat May 26, 2012 10:32 am

Re: No Jack in timecode sync for Ardour

Post by b4rney »

Sorry to jump in but my friend has the same issue but JACK is not an option in:
EDIT -> PREFERENCES -> SYNC

The three other options are there (MIDI timecode, MIDI clock and MTC).

This is on Ubuntu Mate with full KXStudio repos with Ardour installed today.

We are both running the same kxstudio ardour version. Mine works as expected but his has the above problem.

Code: Select all

apt search ardour
ardour/gcc5,now 2:5.12.0-1kxstudio2v5 amd64 [installed,automatic]

b4rney
Established Member
Posts: 31
Joined: Sat May 26, 2012 10:32 am

Re: No Jack in timecode sync for Ardour

Post by b4rney »

Solved this by re-running the "Audio Midi Setup" in the Window Menu and selecting "Jack" for the Audio System.

Hope this helps someone else.
:)

Post Reply