can't hear audio with Cadence

Official support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: falkTX, khz, MattKingUSA

ovitus
Established Member
Posts: 7
Joined: Fri Feb 15, 2019 8:34 pm

can't hear audio with Cadence

Postby ovitus » Wed May 08, 2019 7:49 pm

I was using qjackctl previously to route audio and MIDI (I'm using Reaper and SuperCollider and have midi being sent from the latter into Reaper). I was having issues with a2jmidi_bridge crashing so I wanted to give Cadence a try because it's supposed to have this feature built in. When using Cadence, I can see audio meters moving, but I don't hear any audio playing. I'm using a FiiO E10K USB DAC, but as I said before, things were working with qjackctl. Pulse audio is disabled:

[awright@gns333 /]$ systemctl --user status pulseaudio.service
● pulseaudio.service - Sound Service
Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; enabled; vendor preset: enabled)
Active: inactive (dead) since Wed 2019-05-08 15:30:38 EDT; 17min ago
Process: 27776 ExecStart=/usr/bin/pulseaudio --daemonize=no (code=exited, status=0/SUCCESS)
Main PID: 27776 (code=exited, status=0/SUCCESS)

May 08 15:29:59 gns333 systemd[1397]: Starting Sound Service...
May 08 15:29:59 gns333 pulseaudio[27776]: W: [pulseaudio] pid.c: Stale PID file, overwriting.
May 08 15:29:59 gns333 systemd[1397]: Started Sound Service.
May 08 15:30:24 gns333 pulseaudio[27776]: E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.No>
May 08 15:30:38 gns333 systemd[1397]: Stopping Sound Service...
May 08 15:30:38 gns333 systemd[1397]: Stopped Sound Service.
[awright@gns333 /]$ systemctl --user status pulseaudio.socket
● pulseaudio.socket - Sound System
Loaded: loaded (/usr/lib/systemd/user/pulseaudio.socket; enabled; vendor preset: enabled)
Active: inactive (dead) since Wed 2019-05-08 15:30:38 EDT; 17min ago
Listen: /run/user/1006/pulse/native (Stream)

May 08 15:29:02 gns333 systemd[1397]: Listening on Sound System.
May 08 15:30:38 gns333 systemd[1397]: Closed Sound System.

User avatar
lilith
Established Member
Posts: 892
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: can't hear audio with Cadence

Postby lilith » Wed May 08, 2019 8:27 pm

Can you post a screenshot of your cadence settings? Did you choose the right interface? Any message when starting Cadence in a terminal?
https://soundcloud.com/lilith_93

_____________________________
Debian 9 (XFCE) & KXStudio repos

User avatar
sysrqer
Established Member
Posts: 1749
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: can't hear audio with Cadence

Postby sysrqer » Wed May 08, 2019 9:50 pm

You shouldn't post multiple threads for one issue, especially if they both contain different information about the same issue. I responded to your other thread.

ovitus
Established Member
Posts: 7
Joined: Fri Feb 15, 2019 8:34 pm

Re: can't hear audio with Cadence

Postby ovitus » Wed May 08, 2019 10:42 pm

Sorry didn't know my post was waiting approval, hence double post.

Image

There are only 2 devices related to the USB DAC I have, 'hw:Audio,0 [USB Audio]' and 'hw:Audio,1 [USB Audio]' I've tried both and it is the same result.
I see nothing logged in the terminal when I run Cadence.
Jack log:
Wed May 8 18:41:37 2019: Starting jack server...
Wed May 8 18:41:37 2019: JACK server starting in realtime mode with priority 99
Wed May 8 18:41:37 2019: self-connect-mode is "Don't restrict self connect requests"
Wed May 8 18:41:37 2019: Acquired audio card Audio1
Wed May 8 18:41:37 2019: creating alsa driver ... hw:Audio,1|hw:Audio,1|1024|2|48000|0|0|nomon|swmeter|-|32bit
Wed May 8 18:41:37 2019: ERROR: ALSA: Cannot open PCM device alsa_pcm for capture. Falling back to playback-only mode
Wed May 8 18:41:37 2019: configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
Wed May 8 18:41:37 2019: ALSA: final selected sample format for playback: 16bit little-endian
Wed May 8 18:41:37 2019: ALSA: use 2 periods for playback
Wed May 8 18:41:37 2019: graph reorder: new port 'system:playback_1'
Wed May 8 18:41:37 2019: New client 'system' with PID 0
Wed May 8 18:41:37 2019: graph reorder: new port 'system:playback_2'

Tried unmuting:
[awright@t460 ~]$ amixer -c 0 set Master playback 100% unmute
Simple mixer control 'Master',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 87
Mono: Playback 87 [100%] [0.00dB] [on]


Can't access mixer because pulse is disabled?
[awright@t460 ~]$ alsamixer
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

cannot open mixer: Connection refused


Maybe it's the DAC? But it works find in qjackctl. Let me know any other info I could provide that might help solve this..

ovitus
Established Member
Posts: 7
Joined: Fri Feb 15, 2019 8:34 pm

Re: can't hear audio with Cadence

Postby ovitus » Wed May 08, 2019 10:56 pm

So I just tried switching the interface to my laptop speakers, and I hear audio.. So it must be something to do with the DAC. But it works fine with qjackctl.. aren't these both just Jack frontends?

User avatar
sysrqer
Established Member
Posts: 1749
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: can't hear audio with Cadence

Postby sysrqer » Thu May 09, 2019 8:29 am

They are but they can have different settings. Jack looks fine but you have set the bit rate higher than the card can use but it falls back to a compatible value so doesn't look to be a problem.

I think your problem is that either something in alsamixer was muted or or alsa got the channels mixed up. Your command to unmute alsamixer (I think) only unmuted the Master channel but if you open it up you'll see there are usually two channels that feed the master which switch depending if you have headphones plugged in or not. Sometime alsa doesn't map these correctly and you need to go in to turn up the volume and/or unmute the headphone channel. I'm fairly certain it's not a problem with jack at all.

Not sure why you can't open alsamixer though. Install pulseaudio-module-jack and set up bridging in cadence and try again.

User avatar
Linuxmusician01
Established Member
Posts: 411
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: can't hear audio with Cadence

Postby Linuxmusician01 » Thu May 09, 2019 11:01 am

ovitus wrote:

Code: Select all

awright@t460 ~$ alsamixer
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

cannot open mixer: Connection refused


I don't get why PulseAudio gives an error message when one tries to start the ALSA utility alsamixer?? It doesn't on my PC and I use PulseAudio too. :?

User avatar
sysrqer
Established Member
Posts: 1749
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: can't hear audio with Cadence

Postby sysrqer » Thu May 09, 2019 11:50 am

Linuxmusician01 wrote:I don't get why PulseAudio gives an error message when one tries to start the ALSA utility alsamixer?? It doesn't on my PC and I use PulseAudio too. :?

It is puzzling. After a look around it seems this is related to a permissions problem, either user not being in the audio group or pulseaudio started by root.

https://unix.stackexchange.com/question ... an-stretch

User avatar
sysrqer
Established Member
Posts: 1749
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: can't hear audio with Cadence

Postby sysrqer » Thu May 09, 2019 11:59 am

ovitus wrote: Playback channels: Mono

This is also odd, I assume it is not a mono soundcard?
Which distro are you running? There appear to be a number of things potentially misconfigured.

merlyn
Established Member
Posts: 327
Joined: Thu Oct 11, 2018 4:13 pm

Re: can't hear audio with Cadence

Postby merlyn » Thu May 09, 2019 12:00 pm

ovitus wrote:aren't these both just Jack frontends?

They are, but they work differently. QjackCtl uses jackd by default and Cadence uses jackdbus. Having both on the same system causes problems as you've discovered.

ovitus
Established Member
Posts: 7
Joined: Fri Feb 15, 2019 8:34 pm

Re: can't hear audio with Cadence

Postby ovitus » Thu May 09, 2019 3:11 pm

Quick response to some of the suggestions here:

pulseaudio-module-jack was installed. I'd look in alsamixer, but there is an issue with Pulse?

I am apart of the audio group:
audio:x:63:awright

I have pulseaudio disabled if you look at my OP, but I see this:
awright 23422 2241 0 10:19 ? 00:00:12 /usr/lib64/xfce4/panel/wrapper-2.0 /usr/lib64/xfce4/panel/plugins/libpulseaudio-plugin.so 16 14680074 pulseaudio PulseAudio Plugin Adjust the audio volume of the PulseAudio sound system

I think the audio is stereo, not sure why it shows 'Playback channels: Mono'

So is there a way to disable jackd so it doesn't cause issue with jackdbus?


As of right now, I got a2jmidid working with multiple MIDI Through Ports in qjackctl. I was having stability issues with a2jmidi_bridge crashing. I would still try out Cadence because it has allot of neat features.

merlyn
Established Member
Posts: 327
Joined: Thu Oct 11, 2018 4:13 pm

Re: can't hear audio with Cadence

Postby merlyn » Thu May 09, 2019 3:49 pm

I use Arch Linux and it's impossible to install jack2 and jack2dbus at the same time. They're 'conflicting packages'.

So in your case what distro are you using and how have you installed JACK?

If you want to use Cadence it would be a start to delete ~/.config/rncbc.org/QjackCtl.conf and use htop to see what JACK processes are running.

ovitus
Established Member
Posts: 7
Joined: Fri Feb 15, 2019 8:34 pm

Re: can't hear audio with Cadence

Postby ovitus » Fri May 10, 2019 1:16 am

I'm on Fedora 29: 4.20.5-200.fc29.x86_64

Everything seems to be working okay with qjackctl now. I'll probably stick with it unless I have trouble again.

merlyn
Established Member
Posts: 327
Joined: Thu Oct 11, 2018 4:13 pm

Re: can't hear audio with Cadence

Postby merlyn » Sat May 11, 2019 12:12 pm

ovitus wrote:I'm on Fedora 29: 4.20.5-200.fc29.x86_64

Everything seems to be working okay with qjackctl now. I'll probably stick with it unless I have trouble again.

Seems sensible.

As far as I know the standard version of JACK (jack2) that you'd get from your repo includes jackd and jackdbus code. To get jackdbus working you have to make sure jackd isn't running. This includes disabling all 'autostart at login' options related to QjackCtl.

If, in the future, you want to try Cadence a way that is likely to work is to start from scratch. Uninstall QjackCtl and JACK. Use the dnf equivalent of --purge i.e. uninstall and remove all configuration files. Manually delete ~/.config/rncbc.org/QjackCtl.conf.

Now install Cadence. You would think Cadence would pull JACK in, but it might not, so install JACK if necessary.

It seems a bit drastic. It's the sort of thing that could be tried out on another experimental installation, keeping a working system with QjackCtl.


Return to “KXStudio Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest