full update .. no hardware midi devices in carla

Unofficial support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: khz, MattKingUSA

Post Reply
lilakmonoke
Established Member
Posts: 57
Joined: Sun Feb 10, 2013 9:47 am

full update .. no hardware midi devices in carla

Post by lilakmonoke »

i just did a full update on my kxstudio (12.04) and since then none of my hardware midi devices show up in carla so my studio is basically dead. i dont know if thats carla related or came with the system update.

im thinking about doing a complete new install of xubuntu 16.04 as i use xfce and then installing kxstudio on top of it. is that a good idea and a likely fix?

User avatar
noedig
Established Member
Posts: 161
Joined: Wed Feb 12, 2014 4:39 am
Location: South Africa

Re: full update .. no hardware midi devices in carla

Post by noedig »

You could try installing a2jmidid if it's not installed already, then run it as

a2jmidid -e

See if the hardware MIDI ports pop up in Carla.
(-u is also a useful option)

Alternatively, while you're waiting for KXStudio 18, you could try out the new AVLinux that was just released. It uses Xfce by default if I recall correctly and should have everything set up and configured correctly.

lilakmonoke
Established Member
Posts: 57
Joined: Sun Feb 10, 2013 9:47 am

Re: full update .. no hardware midi devices in carla

Post by lilakmonoke »

falkTX wrote:If you're going to install something new, if waiting a few days is possible, then consider 18.04 LTS that is coming very soon.
good idea, thanks falk! i will do that ...
You could try installing a2jmidid if it's not installed already, then run it as
ill try that too, thanks. i tried installing avlinux 6 months ago and that was a desaster, my nvidia graphics card wouldnt run on the realtime kernel and i was stuck in dependency hell etc. debian might be more stable but ubuntu is a lot more hassle free, or at least thats what it seemed to me.

lilakmonoke
Established Member
Posts: 57
Joined: Sun Feb 10, 2013 9:47 am

Re: full update .. no hardware midi devices in carla

Post by lilakmonoke »

a2jmidid -e
that worked. i had to shut down the midi bridge in cadence and then restart it in the shell with "a2jmidid -e" and then the hardware devices show up. thanks again!

Post Reply