No sound in notebook, Cadence freezes

Official support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: falkTX, khz, MattKingUSA

Luc
Established Member
Posts: 741
Joined: Fri Mar 27, 2015 1:04 pm

No sound in notebook, Cadence freezes

Postby Luc » Sun Dec 10, 2017 10:03 pm

I've been very quiet here because I am traveling on business and just have a notebook with me, not really configured for any music making joy. In fact, I have no sound at all.

I tried to replicate my desktop as much as I could and for the most part everything works, but sound doesn't. Whenever I launch Cadence, it freezes for a while then tells me to read the logs. Here it is:

Code: Select all

Sun Dec 10 19:56:25 2017: Saving settings to "/luc/.config/jack/conf.xml" ...
Sun Dec 10 19:56:40 2017: Starting jack server...
Sun Dec 10 19:56:40 2017: JACK server starting in realtime mode with priority 10
Sun Dec 10 19:56:40 2017: self-connect-mode is "Don't restrict self connect requests"
Sun Dec 10 19:56:40 2017: Acquired audio card Audio0
Sun Dec 10 19:56:40 2017: creating alsa driver ... hw:PCH,0|hw:PCH,0|2048|2|44100|0|0|hwmon|hwmeter|soft-mode|32bit
Sun Dec 10 19:56:40 2017: Using ALSA driver HDA-Intel running on card 0 - HDA Intel PCH at 0xd4730000 irq 34
Sun Dec 10 19:56:40 2017: configuring for 44100Hz, period = 2048 frames (46.4 ms), buffer = 2 periods
Sun Dec 10 19:56:40 2017: ALSA: final selected sample format for capture: 32bit integer little-endian
Sun Dec 10 19:56:40 2017: ALSA: use 2 periods for capture
Sun Dec 10 19:56:40 2017: ALSA: final selected sample format for playback: 32bit integer little-endian
Sun Dec 10 19:56:40 2017: ALSA: use 2 periods for playback
Sun Dec 10 19:56:45 2017: ERROR: JackPosixProcessSync::LockedTimedWait error usec = 5000000 err = Connection timed out
Sun Dec 10 19:56:45 2017: ERROR: Driver is not running
Sun Dec 10 19:56:45 2017: ERROR: Cannot open client name = dbusapi
Sun Dec 10 19:56:45 2017: ERROR: failed to create dbusapi jack client


Everything looks pretty good in alsamixer and I have completely removed pulseaudio, like I always do. It just seems that JACK - or Cadence? - is not running, so there is no sound.

Any help, please?

User avatar
falkTX
Established Member
Posts: 6646
Joined: Sat Jan 09, 2010 3:04 pm

Re: No sound in notebook, Cadence freezes

Postby falkTX » Sun Dec 10, 2017 10:27 pm

what exact distro version are you using? do you have all software updates installed?
seeing "JackPosixProcessSync::LockedTimedWait" makes me wonder if jack2 packages need an update...

Luc
Established Member
Posts: 741
Joined: Fri Mar 27, 2015 1:04 pm

Re: No sound in notebook, Cadence freezes

Postby Luc » Sun Dec 10, 2017 11:36 pm

falkTX wrote:what exact distro version are you using? do you have all software updates installed?
seeing "JackPosixProcessSync::LockedTimedWait" makes me wonder if jack2 packages need an update...

It's Debian 9 - Stretch.

#> uname -a
Linux lucnote 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u5 (2017-09-19) x86_64 GNU/Linux

jackd2 version 2:1.9.11+git20170722-1~kxstudio2v5

I ran 'apt-get update' and the only packages that were due to an upgrade and seemed relevant were carla and dbus. I updated both, rebooted (dbus requires it) and Cadence still doesn't work. I mean, it works, but it can't start JACK. It's JACK that won't work. Sorry I blamed Cadence. Cadence is just exposing the problem.

Please let me know if you need any kind of debugging.

User avatar
falkTX
Established Member
Posts: 6646
Joined: Sat Jan 09, 2010 3:04 pm

Re: No sound in notebook, Cadence freezes

Postby falkTX » Mon Dec 11, 2017 8:19 am

You can try to reset the audio configuration, using this:

Code: Select all

cadence-session-start --reset

Then opening cadence again and configuring things.

If it still does not work, then it's likely a alsa/driver issue.
See if you can find an alternative kernel on this case.

Luc
Established Member
Posts: 741
Joined: Fri Mar 27, 2015 1:04 pm

Re: No sound in notebook, Cadence freezes

Postby Luc » Mon Dec 11, 2017 10:49 am

Made some progress. Now Cadence doesn't freeze, it seems to run JACK correctly, and the needle moves when I play audio files in Audacious or mhWaveEdit.

There is just no sound though. I've checked sound config in all applications, volumes, alsamixer, Cadence bridges, and still have no sound at all.

If you still have any idea, please share. Or else I will have to troubleshoot this some other way. :-\

Thanks again.

Janez
Established Member
Posts: 20
Joined: Tue Nov 04, 2014 9:18 pm

Re: No sound in notebook, Cadence freezes

Postby Janez » Thu Dec 21, 2017 3:54 am

Is there a hardware control wheel or something on you laptop to control the volume that might be turned down? (Stuff like that happens)
Did you pick the right device in cadence before you started the Jack server?
Maybe check the Alsa Settings again using QasMixer. There are not only volumes but also some mute buttons.
Check again what device the application is using. (Is Audacious really using Jack?)

Maybe you already thought of all of the above.
At that point I would consider using the auto configuration in kxstudio-welcome.


Return to “KXStudio Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests