Page 2 of 2

Re: catia & vlc default connections

Posted: Sat Jan 11, 2020 7:32 pm
by bluebell
lilith wrote:
bluebell wrote:
lilith wrote: I tested this currently, but it does not work. I saved the jack-plumping file under /home/marco/.jack-plumbing with this content

Code: Select all

(disconnect "PulseAudio JACK Sink:front-left"  "system:playback_1")
(disconnect "PulseAudio JACK Sink:front-right" "system:playback_2")
(connect "PulseAudio JACK Sink:front-left" "Parametric Equalizer x16 Stereo:Input_1")
(connect "PulseAudio JACK Sink:front-right" "Parametric Equalizer x16 Stereo:Input_1")
(connect "Parametric Equalizer x16 Stereo:output_1"  "system:playback_1")
(connect "Parametric Equalizer x16 Stereo:output_2"  "system:playback_2")
But the connection from pulse to system out is still always established. jack-plumping is running too.
My rule ist a bit different:

Code: Select all

(connect    "PulseAudio.*:front-left"  "main:input_1")
(connect    "PulseAudio.*:front-right" "main:input_2")
(disconnect "PulseAudio.*:.*" "system:playback_.*")
So you might try:

Code: Select all

(connect  "PulseAudio.*:front-left"  "Parametric Equalizer x16 Stereo:Input_1")
(connect  "PulseAudio.*:front-right" "Parametric Equalizer x16 Stereo:Input_2")
(connect "Parametric Equalizer x16 Stereo:output_1"  "system:playback_1")
(connect "Parametric Equalizer x16 Stereo:output_2"  "system:playback_2")
(disconnect "PulseAudio.*:.*" "system:playback_.*")
Still not working :( Should the pulse - system connection always gets disconnected when I start the Parametric EQ? It's not clear to me to what this rules are coupled.
That's your choice. I thought everything should run through the EQ.

What is not working? Is Pulse not disconnected or is the EQ not connected or both?

Re: catia & vlc default connections

Posted: Sat Jan 11, 2020 7:38 pm
by lilith
bluebell wrote:
lilith wrote:
bluebell wrote:
My rule ist a bit different:

Code: Select all

(connect    "PulseAudio.*:front-left"  "main:input_1")
(connect    "PulseAudio.*:front-right" "main:input_2")
(disconnect "PulseAudio.*:.*" "system:playback_.*")
So you might try:

Code: Select all

(connect  "PulseAudio.*:front-left"  "Parametric Equalizer x16 Stereo:Input_1")
(connect  "PulseAudio.*:front-right" "Parametric Equalizer x16 Stereo:Input_2")
(connect "Parametric Equalizer x16 Stereo:output_1"  "system:playback_1")
(connect "Parametric Equalizer x16 Stereo:output_2"  "system:playback_2")
(disconnect "PulseAudio.*:.*" "system:playback_.*")
Still not working :( Should the pulse - system connection always gets disconnected when I start the Parametric EQ? It's not clear to me to what this rules are coupled.
That's your choice. I thought everything should run through the EQ.

What is not working? Is Pulse not disconnected or is the EQ not connected or both?
The EQ is connected, but that's also the case without jack plumbing. Pulse is not disconnected from system out though. Do I have to change some setting in Cadence maybe? Connections are established automatically by Cadence.

Re: catia & vlc default connections

Posted: Sat Jan 11, 2020 11:04 pm
by lilith
I think it's working. Will see when I reboot the next time. Thanks again!

Re: catia & vlc default connections

Posted: Sun Jan 19, 2020 2:00 pm
by lilith
bluebell wrote:
lilith wrote: I tested this currently, but it does not work. I saved the jack-plumping file under /home/marco/.jack-plumbing with this content

Code: Select all

(disconnect "PulseAudio JACK Sink:front-left"  "system:playback_1")
(disconnect "PulseAudio JACK Sink:front-right" "system:playback_2")
(connect "PulseAudio JACK Sink:front-left" "Parametric Equalizer x16 Stereo:Input_1")
(connect "PulseAudio JACK Sink:front-right" "Parametric Equalizer x16 Stereo:Input_1")
(connect "Parametric Equalizer x16 Stereo:output_1"  "system:playback_1")
(connect "Parametric Equalizer x16 Stereo:output_2"  "system:playback_2")
But the connection from pulse to system out is still always established. jack-plumping is running too.
My rule ist a bit different:

Code: Select all

(connect    "PulseAudio.*:front-left"  "main:input_1")
(connect    "PulseAudio.*:front-right" "main:input_2")
(disconnect "PulseAudio.*:.*" "system:playback_.*")
So you might try:

Code: Select all

(connect  "PulseAudio.*:front-left"  "Parametric Equalizer x16 Stereo:Input_1")
(connect  "PulseAudio.*:front-right" "Parametric Equalizer x16 Stereo:Input_2")
(connect "Parametric Equalizer x16 Stereo:output_1"  "system:playback_1")
(connect "Parametric Equalizer x16 Stereo:output_2"  "system:playback_2")
(disconnect "PulseAudio.*:.*" "system:playback_.*")
I think it's not working. What for instance does

Code: Select all

disconnect "PulseAudio.*:.*" "system:playback_.*"
mean and how should it work? If I make the connection by hand will it be unconnected immediately again or is there any trigger for changes to take place?

Re: catia & vlc default connections

Posted: Sun Jan 19, 2020 2:15 pm
by lilith
bluebell wrote:
lilith wrote: I tested this currently, but it does not work. I saved the jack-plumping file under /home/marco/.jack-plumbing with this content

Code: Select all

(disconnect "PulseAudio JACK Sink:front-left"  "system:playback_1")
(disconnect "PulseAudio JACK Sink:front-right" "system:playback_2")
(connect "PulseAudio JACK Sink:front-left" "Parametric Equalizer x16 Stereo:Input_1")
(connect "PulseAudio JACK Sink:front-right" "Parametric Equalizer x16 Stereo:Input_1")
(connect "Parametric Equalizer x16 Stereo:output_1"  "system:playback_1")
(connect "Parametric Equalizer x16 Stereo:output_2"  "system:playback_2")
But the connection from pulse to system out is still always established. jack-plumping is running too.
My rule ist a bit different:

Code: Select all

(connect    "PulseAudio.*:front-left"  "main:input_1")
(connect    "PulseAudio.*:front-right" "main:input_2")
(disconnect "PulseAudio.*:.*" "system:playback_.*")
So you might try:

Code: Select all

(connect  "PulseAudio.*:front-left"  "Parametric Equalizer x16 Stereo:Input_1")
(connect  "PulseAudio.*:front-right" "Parametric Equalizer x16 Stereo:Input_2")
(connect "Parametric Equalizer x16 Stereo:output_1"  "system:playback_1")
(connect "Parametric Equalizer x16 Stereo:output_2"  "system:playback_2")
(disconnect "PulseAudio.*:.*" "system:playback_.*")
I think it's not working. What for instance does

Code: Select all

disconnect "PulseAudio.*:.*" "system:playback_.*"
mean and how should it work? If I make the connection by hand will it be unconnected immediately again or is there any trigger for changes to take place?

Re: catia & vlc default connections

Posted: Sun Jan 19, 2020 3:27 pm
by bluebell
lilith wrote: I think it's not working. What for instance does

Code: Select all

disconnect "PulseAudio.*:.*" "system:playback_.*"
mean and how should it work? If I make the connection by hand will it be unconnected immediately again or is there any trigger for changes to take place?
It disconnects PulseAudio from system:playback since it should be routed via your EQ.

Re: catia & vlc default connections

Posted: Sun Jan 19, 2020 5:37 pm
by lilith
bluebell wrote:
lilith wrote: I think it's not working. What for instance does

Code: Select all

disconnect "PulseAudio.*:.*" "system:playback_.*"
mean and how should it work? If I make the connection by hand will it be unconnected immediately again or is there any trigger for changes to take place?
It disconnects PulseAudio from system:playback since it should be routed via your EQ.
Thanks, but does that happen all the time or whenever connections are changed, or just once when jackplumbing is executed? I can make the Pulse -> System connection by hand and it stays.

Re: catia & vlc default connections

Posted: Sun Jan 19, 2020 5:40 pm
by bluebell
lilith wrote:
bluebell wrote:
lilith wrote: I think it's not working. What for instance does

Code: Select all

disconnect "PulseAudio.*:.*" "system:playback_.*"
mean and how should it work? If I make the connection by hand will it be unconnected immediately again or is there any trigger for changes to take place?
It disconnects PulseAudio from system:playback since it should be routed via your EQ.
Thanks, but does that happen all the time or whenever connections are changed, or just once when jackplumbing is executed? I can make the Pulse -> System connection by hand and it stays.
Jack-plumbing has to be active permanently. As long as it's running it will cut those connections that are defined to be disconnected when you try to connect them. That's how it works.

Re: catia & vlc default connections

Posted: Sun Jan 19, 2020 6:03 pm
by lilith
bluebell wrote:
lilith wrote:
bluebell wrote:
It disconnects PulseAudio from system:playback since it should be routed via your EQ.
Thanks, but does that happen all the time or whenever connections are changed, or just once when jackplumbing is executed? I can make the Pulse -> System connection by hand and it stays.
Jack-plumbing has to be active permanently. As long as it's running it will cut those connections that are defined to be disconnected when you try to connect them. That's how it works.
Ok, then it's not working correctly as I can make the connections by hand.
When I start it it shows me
Rule accepted: 'connect', 'PulseAudio.*:front-left' - 'Parametric Equalizer x16 Stereo:Input_1'.
Add rule: '2', 'PulseAudio.*:front-left' - 'Parametric Equalizer x16 Stereo:Input_1'.
Rule accepted: 'connect', 'PulseAudio.*:front-right' - 'Parametric Equalizer x16 Stereo:Input_2'.
Add rule: '2', 'PulseAudio.*:front-right' - 'Parametric Equalizer x16 Stereo:Input_2'.
Rule accepted: 'connect', 'Parametric Equalizer x16 Stereo:output_1' - 'system:playback_1'.
Add rule: '2', 'Parametric Equalizer x16 Stereo:output_1' - 'system:playback_1'.
Rule accepted: 'connect', 'Parametric Equalizer x16 Stereo:output_2' - 'system:playback_2'.
Add rule: '2', 'Parametric Equalizer x16 Stereo:output_2' - 'system:playback_2'.
Rule accepted: 'disconnect', 'PulseAudio*:.*' - 'system:playback_*'.
Add rule: '1', 'PulseAudio*:.*' - 'system:playback_*'.
sem_waiting -1

Re: catia & vlc default connections

Posted: Sun Jan 19, 2020 7:26 pm
by bluebell
Maybe Catia has a similar function and they are fighting against each other.

Re: catia & vlc default connections

Posted: Sun Jan 19, 2020 7:30 pm
by lilith
bluebell wrote:Maybe Catia has a similar function and they are fighting against each other.
I'm asking FalkTX then.