Cadence not running at all after fresh KXStudio install

Official support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: falkTX, khz, MattKingUSA

racoon_22
Posts: 1
Joined: Wed Apr 19, 2017 6:42 pm

Cadence not running at all after fresh KXStudio install

Postby racoon_22 » Wed Apr 19, 2017 7:36 pm

Hey y'all, so I just installed KXstudo on my laptop because I am looking for software I can use for recording as well as live audio-signal processing. I am pretty new to linux but done some general research already. Unfortunately a lot of things are just not working and I can't find out the reason why.

To start with, Cadence is not starting up at all. It shows up in the task bar for a moment as if it's gonna startup, but then disappears again, same goes for Claudia and Catia and also for JACK RACK.

JACK keyboard gives the error: 'Could not connect to the JACK server; run jackd first?'
Claudia Launcher gives the error: 'JACK is not started! Please start it first, then re-run Claudia-Launcher again.'

I ran all the package updates in Synaptic Package Manager and ran the 'Force reset of all settings' option in the Welcome setup. I ran 'Run jackd' in the Kickoff app Launcher (start menu) but still nothing.... :/

I don't get any wiser reading the Installation guide on the KXStudio webpage and haven't found any similar problems from other users on this forum. So I really hope someone can tell me what is the what here... it would be very much appreciated!

Oh btw, I installed the KXStudio version on an SSD-drive of a Lenovo Ideapad in a partition next to the original Windows 10 system.

Pablo
Established Member
Posts: 1269
Joined: Thu Apr 17, 2008 9:57 pm

Re: Cadence not running at all after fresh KXStudio install

Postby Pablo » Thu Apr 20, 2017 2:01 pm

Type

Code: Select all

cadence


and press Enter in a terminal window. An error message should appear in the terminal which will help to resolve the issue.

samuelzen
Posts: 1
Joined: Sun Sep 27, 2015 3:20 am

Re: Cadence not running at all after fresh KXStudio install

Postby samuelzen » Mon Jul 03, 2017 3:15 pm

Hello, I also have a similar issue. After a recent update, cadence no long works in Linuxmint 18.1 XFCE 64bit. It doesn't start at all. When I try to launch it in the terminal I get a "Segmentation fault" error. I am not sure if this is helpful, but I have attached the output of strace with the cadence command.

Thanks,
Sam
You do not have the required permissions to view the files attached to this post.

User avatar
falkTX
Established Member
Posts: 6646
Joined: Sat Jan 09, 2010 3:04 pm

Re: Cadence not running at all after fresh KXStudio install

Postby falkTX » Mon Jul 03, 2017 8:10 pm

From the logs I see something is wrong with sip/pyqt.
Make sure you don't have pending updates (use apt-get, not mint's tool).

Blinkd
Posts: 1
Joined: Sun Sep 17, 2017 3:25 am

Re: Cadence not running at all after fresh KXStudio install

Postby Blinkd » Sun Sep 17, 2017 3:41 am

Does this count as a necro? :-P

First of all, thanks falkTX for all your hard work and for your awesome repo and tools. Cadence, Catia, and your repo will always be on any system I run.

Anyways, I encountered this problem just now: immediate segmentation faults when trying to run Cadence.

I was trying to get something to work yesterday that required PyQt5 for Python3, which I installed using pip3. Uninstalling using pip3 wasn't possible, but manually deleting the PyQt5 module ("rm -r PyQt5" in /usr/lib/python3/dist-packages) fixed the segmentation faults.

Thanks again, and I hope this helps.


Return to “KXStudio Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests