Page 1 of 2

cadence and pulseaudio not working well

Posted: Sun Feb 19, 2017 4:28 pm
by sysrqer
I have run in to a problem with cadence and pulseaudio. If I run just pulseaudio when I log in everything is as it should be. However, if I set cadence to start on login (using the option inside cadence) then something odd happens with pulseaudio, in the plasma volume widget there is only jack-sink listed as a playback device, my hdmi device is not listed. If I stop jack from within cadence then the widget now shows Dummy Output.

The only working way I've found is, when jack is running, stop pulseaudio from within cadence, stop jack, run pulseaudio from a terminal, start jack. Doing this I get the jack-sink and the hdmi devices showing. So there seems to be a difference between cadence starting pulseaudio and me starting pulseaudio.

Anyone know what might be happening here?

Re: cadence and pulseaudio not working well

Posted: Mon Feb 20, 2017 2:38 pm
by sysrqer
I tested this with a new user and the same thing happens so it doesn't seem to be a rogue config file causing this.

Looking in to which jack packages I have I found this:

Code: Select all

Installed    jackd-5.all (installed:ubuntu-xenial-universe)
Installed    jackd2-2:1.9.11~20161209-1~kxstudio5v5.amd64 (installed:lp-ppa-kxstudio-debian-gcc5-xenial-main)
Installed    libjack-jackd2-0-2:1.9.11~20161209-1~kxstudio5v5.amd64 (installed:lp-ppa-kxstudio-debian-gcc5-xenial-main)
Installed    libjack-jackd2-0-2:1.9.11~20161209-1~kxstudio5v5.i386 (installed:lp-ppa-kxstudio-debian-gcc5-xenial-main)
Should I have the jackd-5 installed?

Re: cadence and pulseaudio not working well

Posted: Fri Mar 24, 2017 1:39 am
by sysrqer
I can't be the only one experiencing this?

Re: cadence and pulseaudio not working well

Posted: Tue Dec 24, 2019 12:31 am
by b.horn99
hey sysrqer, I'm running into the same problem! Did you figure it out?
Thanks

Re: cadence and pulseaudio not working well

Posted: Tue Dec 24, 2019 9:10 am
by sysrqer
b.horn99 wrote:hey sysrqer, I'm running into the same problem! Did you figure it out?
Thanks

Hey, no I didn't find a solution. As far as I can tell this is intended behaviour, or at least not considered a bug, so I gave up. I use qjackctl now instead and have had zero problems.

Re: cadence and pulseaudio not working well

Posted: Thu Dec 26, 2019 4:49 pm
by b.horn99
I use qjackctl now instead and have had zero problems.
ok thanks for the feedback, I appreciate it.
I tried to use Qjackctl before Cadence but couldn't figure it out.
My goal is to be able to choose between Jack (when I'm using my USB focusrite scarlett solo and Reaper) and the regular out of the box PulseAudio (for all the other occasion I don't need the low latency: movies, youtube...)
Is this something easy to setup in Qjackctl or it requires a special script?
Thanks man

Re: cadence and pulseaudio not working well

Posted: Fri Dec 27, 2019 10:28 am
by sysrqer
Yeah it's pretty easy to set that up. The simplest way is to keep jack running all the time and have pulseaudio bridged to jack so you don't have to keep starting and stopping jack. The latest git version of qjackctl has a more intuitive connection manager similar to Catia and Patchage.

I think this should work automatically but you may need to install the pulseaudio-module-jack package. I don't think I've done anything special to make it work but if you have trouble then let us know and we can get it working for you I'm sure.

Re: cadence and pulseaudio not working well

Posted: Sun Dec 29, 2019 5:37 pm
by b.horn99
Ok so I did (my first time using GitHub, tried different things but nothing worked) :
~/$ git clone https://github.com/rncbc/qjackctl.git
Installation
------------

The installation procedure follows the standard for source distributions:

./configure [--prefix=/usr/local]
make
I did
~/Downloads/qjackctl-0.6.1$ ./configure --prefix=/myusername/bin (bin should be good right?)
but after:
~/Downloads/qjackctl-0.6.1$ make
make: *** No targets specified and no makefile found. Stop.
~/Downloads/qjackctl-0.6.1$ ls
aclocal.m4 CMakeLists.txt INSTALL qjackctl.pro TODO
AUTHORS config.log Makefile.git qjackctl.spec.in TRANSLATORS
autogen.sh configure Makefile.in README
build configure.ac qjackctl.1 README.cmake
ChangeLog COPYING qjackctl.fr.1 src
:roll:

Re: cadence and pulseaudio not working well

Posted: Sun Dec 29, 2019 7:36 pm
by rghvdberg
b.horn99 wrote:Ok so I did (my first time using GitHub, tried different things but nothing worked) :
~/$ git clone https://github.com/rncbc/qjackctl.git
Installation
------------

The installation procedure follows the standard for source distributions:

./configure [--prefix=/usr/local]
make
I did
~/Downloads/qjackctl-0.6.1$ ./configure --prefix=/myusername/bin (bin should be good right?)
but after:
~/Downloads/qjackctl-0.6.1$ make
make: *** No targets specified and no makefile found. Stop.
~/Downloads/qjackctl-0.6.1$ ls
aclocal.m4 CMakeLists.txt INSTALL qjackctl.pro TODO
AUTHORS config.log Makefile.git qjackctl.spec.in TRANSLATORS
autogen.sh configure Makefile.in README
build configure.ac qjackctl.1 README.cmake
ChangeLog COPYING qjackctl.fr.1 src
:roll:
Why are you compiling qjackctl? It's in every Linux distro that I know of.

Re: cadence and pulseaudio not working well

Posted: Sun Dec 29, 2019 8:01 pm
by b.horn99
I'm using Mint Cinnamon and in the software manager the most recent version is 0.4.5...
The latest git version of qjackctl has a more intuitive connection manager similar to Catia and Patchage.
I'm trying to install the latest

Re: cadence and pulseaudio not working well

Posted: Sun Dec 29, 2019 8:25 pm
by sysrqer
There is a ppa for the latest git version of you are running a debian based distro - https://launchpad.net/~rncbc/+archive/ubuntu/bionic

Not sure why you are getting that error, usually that would mean you are executing make from the wrong directory but your prompt suggests that you were running in the right place. If you copy the url https://github.com/rncbc/qjackctl and then in a terminal run 'git clone https://github.com/rncbc/qjackctl' you should have a directory called 'qjackctl' so I'm guessing you downloaded the repo from github rather than cloning it?

Try:

Code: Select all

git clone https://github.com/rncbc/qjackctl
cd qjackctl
Then do the compile instructions.

Re: cadence and pulseaudio not working well

Posted: Sun Dec 29, 2019 11:06 pm
by b.horn99
That's right, I downloaded the repo from github because I didn't manage to compile it.
So I followed your steps:
$ sudo add-apt-repository ppa:rncbc/bionic
$ sudo apt-get update
then:
~/Downloads$ git clone https://github.com/rncbc/qjackctl
~/Downloads$ cd qjackctl
~/Downloads/qjackctl$ ./configure --prefix=/myusername/bin
bash: ./configure: No such file or directory
same with:
~/Downloads/qjackctl$ ./configure [--prefix=/myusername/bin]
bash: ./configure: No such file or directory
What am I missing...? I'm so close! :evil:

Re: cadence and pulseaudio not working well

Posted: Mon Dec 30, 2019 12:02 am
by sysrqer
If you are using the ppa then you don't need to compile it.

Just:
sudo add-apt-repository ppa:rncbc/bionic
sudo apt-get update
sudo apt install qjackctl

Perhaps you need to sudo apt upgrade if you already had it installed.

Re: cadence and pulseaudio not working well

Posted: Mon Dec 30, 2019 12:32 am
by b.horn99
That's it! Thanks man! :D :idea:
Alright, so now I'm gonna uninstall Cadence.
The simplest way is to keep jack running all the time and have pulseaudio bridged to jack so you don't have to keep starting and stopping jack
1 - So to keep jack running all the time I presume I need to click "Start JACK audio server on application startup"...
but maybe also make it start as soon I log in...?
if yes how do you do this?
Setup.png
2 - How do I have PulseAudio bridged to Jack?

Thanks

Re: cadence and pulseaudio not working well

Posted: Mon Dec 30, 2019 9:52 am
by sysrqer
Yes, you want to enable the option in qjackctl to start when opened. Then you can add qjackctl as a start up program - I haven't used Cinnamon but it should be fairly easy to do.

If you had cadence installed then you probably have the pulseaudio-module-jack package installed and it should all just work.