DSSI-VST not working with 64bit ubuntu

Unofficial support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: khz, MattKingUSA

Post Reply
spamatica
Established Member
Posts: 539
Joined: Mon Feb 08, 2010 10:38 am
Has thanked: 54 times
Been thanked: 66 times

DSSI-VST not working with 64bit ubuntu

Post by spamatica »

Hi fellas,

Been trying to get DSSI-VST working in my 64-bit install of kubuntu and it seems there is something interfering with it's function. I went on a small quest and installed a bunch of different ubuntu based OSs and it turns out that 32-bit versions are fine. Mint is also fine with 64-bit, probably because it's not based of off recent Ubuntu.

What happens is that discovery of VST plugins works fine but instantiation leads to this (to me) wierd error message being spewed out by jack over and over again:
JackEngine::XRun: client = dssi-vst was not finished, state = Triggered
JackAudioDriver::ProcessGraphAsyncMaster: Process error

To my understanding jack shouldn't really be aware of dssi-vst so I don't know how the connection has been set up. Tried with both MusE and Qtractor, same result, so I believe the host is not the source.
Anyone know if there is a work around or whereabout to dig deeper?

Regards,
Robert
MusE DAW
spamatica
Established Member
Posts: 539
Joined: Mon Feb 08, 2010 10:38 am
Has thanked: 54 times
Been thanked: 66 times

Re: DSSI-VST not working with 64bit ubuntu

Post by spamatica »

Hi,

Oh, that sounds fairly serious, I hope the libc and kernel folks are working on it.
In the meantime I'll take a look at futexes and see if I can get anywhere with that. As soon as I have time..

Thanks!
MusE DAW
lem18
Established Member
Posts: 9
Joined: Wed Nov 11, 2015 10:24 am

Re: DSSI-VST not working with 64bit ubuntu

Post by lem18 »

For what it's worth, which may eliminate the kernel as being an issue: I can't use Vestige in LMMS under Ubuntu 15.10 64bit (nor 15.04). Any time I try to load a (32bit) VST with it, the loading process stalls, and LMMS becomes unresponsive. Killing the LMMS process leaves the /usr/lib/lmms/RemoteVstPlugin.exe.so process going (but not doing anything). This same sequence of events works under Ubuntu 14.04.3 though.

I tried the Vivid (3.19.x) and now just today, the Wily (4.2.x) kernels under 14.04.3, and loading 32bit VSTs works just fine in LMMS.
Post Reply