Packages Held Back

Unofficial support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: khz, MattKingUSA

Post Reply
bazsound
Established Member
Posts: 480
Joined: Sat Aug 03, 2013 11:46 am

Packages Held Back

Post by bazsound »

Code: Select all

alex@Studio1:~$ sudo apt-get dist-upgrade
[sudo] password for alex: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libgd2-xpm libgd2-xpm:i386
0 to upgrade, 0 to newly install, 0 to remove and 2 not to upgrade.
alex@Studio1:~$ 
Ive had this going on for a whle now not sure why they are being held back

bazsound
Established Member
Posts: 480
Joined: Sat Aug 03, 2013 11:46 am

Re: Packages Held Back

Post by bazsound »

kx studio 12.04
AMD64

User avatar
raboof
Established Member
Posts: 1735
Joined: Tue Apr 08, 2008 11:58 am
Location: Deventer, NL
Contact:

Re: Packages Held Back

Post by raboof »

bazsound wrote:

Code: Select all

alex@Studio1:~$ sudo apt-get dist-upgrade
[sudo] password for alex: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libgd2-xpm libgd2-xpm:i386
0 to upgrade, 0 to newly install, 0 to remove and 2 not to upgrade.
alex@Studio1:~$ 
Ive had this going on for a whle now not sure why they are being held back
Usually when you explicitly 'apt-get install libgd2-xpm' it tells you why it won't automatically update them.

bazsound
Established Member
Posts: 480
Joined: Sat Aug 03, 2013 11:46 am

Re: Packages Held Back

Post by bazsound »

Thanks for that.

Your help brought some more helpfull information

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libgd2-xpm : Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-3ubuntu9.1 is to be installed
              Breaks: libgd2-xpm:i386 (!= 2.0.36~rc1~dfsg-6.1) but 2.0.36~rc1~dfsg-6ubuntu2 is to be installed
 libgd2-xpm:i386 : Breaks: libgd2-xpm (!= 2.0.36~rc1~dfsg-6ubuntu2) but 2.0.36~rc1~dfsg-6.1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
everything is working so its probably not critical, it might not even be anything to do with kx studio

User avatar
raboof
Established Member
Posts: 1735
Joined: Tue Apr 08, 2008 11:58 am
Location: Deventer, NL
Contact:

Re: Packages Held Back

Post by raboof »

bazsound wrote:

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libgd2-xpm : Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-3ubuntu9.1 is to be installed
              Breaks: libgd2-xpm:i386 (!= 2.0.36~rc1~dfsg-6.1) but 2.0.36~rc1~dfsg-6ubuntu2 is to be installed
 libgd2-xpm:i386 : Breaks: libgd2-xpm (!= 2.0.36~rc1~dfsg-6ubuntu2) but 2.0.36~rc1~dfsg-6.1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
everything is working so its probably not critical, it might not even be anything to do with kx studio
This might indeed not have to do with KX specifically.

What this says (if I'm not mistaken) is that the libgd2-xpm upgrade also requires a newer version of libfontconfig1, and that libgd2-xpm and libgd2-xpm:i386 must be the same version.

You could try: "apt-get install libgd2-xpm libgd2-xpm:i386 libfontconfig1" to tell it to get the latest version of all 3 of these packages. If the desirable version of libfontconfig1 doesn't appear to be available, could you show the output of "apt-cache policy libfontconfig1"? That should show an overview of all versions available from repositories on your system.

If you don't really care about libgd2, you could also just leave it be :).

bazsound
Established Member
Posts: 480
Joined: Sat Aug 03, 2013 11:46 am

Re: Packages Held Back

Post by bazsound »

Code: Select all

alex@Studio1:~$ sudo apt-get install libgd2-xpm libgd2-xpm:i386 libfontconfig1
[sudo] password for alex: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libfontconfig1 is already the newest version.
libfontconfig1 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libgd2-xpm : Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-3ubuntu9.1 is to be installed
 libgd2-xpm:i386 : Depends: libfontconfig1:i386 (>= 2.9.0) but 2.8.0-3ubuntu9.1 is to be installed
E: Unable to correct problems, you have held broken packages.
alex@Studio1:~$ apt-cache policy libfontconfig1
libfontconfig1:
Installed: 2.8.0-3ubuntu9.1
Candidate: 2.8.0-3ubuntu9.1
Version table:
*** 2.8.0-3ubuntu9.1 0
500 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
100 /var/lib/dpkg/status
2.8.0-3ubuntu9 0
500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
meh

bazsound
Established Member
Posts: 480
Joined: Sat Aug 03, 2013 11:46 am

Re: Packages Held Back

Post by bazsound »

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Version ‘2.0.36~rc1~dfsg-6.1ubuntu2’ for ‘libgd2-xpm’ was not found
E: Version ‘2.0.36~rc1~dfsg-6.1ubuntu2’ for ‘libgd2-xpm:i386’ was not found
sorry im really bored with only 3 days work this month.

are these held packages needed for anything?>

Post Reply