Cadence/JACK not starting - FIXED? Kinda?

Unofficial support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: MattKingUSA, khz

Post Reply
manic_b
Established Member
Posts: 48
Joined: Thu Aug 09, 2012 9:39 pm

Cadence/JACK not starting - FIXED? Kinda?

Post by manic_b »

Nothing obvious changed in configuration, just got up this morning and "cadence" returns:

Code: Select all

Using Tray Engine 'Qt'
ERROR:dbus.proxies:Introspect error on :1.72:/org/jackaudio/Controller: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
  File "/usr/share/cadence/src/cadence.py", line 2314, in <module>
    gui = CadenceMainW()
  File "/usr/share/cadence/src/cadence.py", line 1194, in __init__
    self.DBusReconnect()
  File "/usr/share/cadence/src/cadence.py", line 1216, in DBusReconnect
    if gDBus.jack.IsStarted():
  File "/usr/lib/python3/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python3/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python3/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Opening qjackctl, which shows this window for a while:
Image

before it opens properly. I'm able to configure and start JACK from qjackctl, but it claims to have a buffer size of 0 frames and a sample rate of 0 Hz so this isn't very meaningful...


Stuff I've tried:
  • Reinstalling cadence and jackd with apt-get
  • Logging out of KDE and into an XFCE desktop
  • Switching from recent Generic kernel to older lowlatency kernel
Last edited by manic_b on Sat Aug 02, 2014 8:21 pm, edited 1 time in total.

manic_b
Established Member
Posts: 48
Joined: Thu Aug 09, 2012 9:39 pm

Re: Cadence/JACK not starting

Post by manic_b »

I seem to have things working again, but it wasn't a great Saturday... Steps were:
  • Reinstall ALSA (not sure if this was important)
  • Code: Select all

    killall jackdbus
  • Open Cadence successfully
  • Change numbers of inputs and outputs from zero to six (for my Komplete Audio 6)
  • Close Cadence and reboot
It seems that qjackctl was powerless to set the values correctly, and Cadence was unable to open when faced with a 0-in 0-out semi-functional JACK session.

Post Reply