jack autostart fail after last cadence update [solved]

Unofficial support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: MattKingUSA, khz

User avatar
sm_mue_mi
Established Member
Posts: 15
Joined: Sun Aug 18, 2013 6:31 pm
Contact:

Re: jack autostart fail after last cadence update

Post by sm_mue_mi »

I can confirm that jack and alsa->loop->jack bridge auto-start again successfully after update to the reverted version. The only thing that does not work (and this since ubuntu update to 13.04 or 13.10 I think) is that cadence shows the correct jack status. This is already reported here http://linuxmusicians.com/viewtopic.php ... 387#p51727

Anyway, thanks for fixing. The status thing would be nice but is not the most important.

Ubuntu 14.04 amd-64
Unity

Best
Steffen

User avatar
sm_mue_mi
Established Member
Posts: 15
Joined: Sun Aug 18, 2013 6:31 pm
Contact:

Re: jack autostart fail after last cadence update

Post by sm_mue_mi »

Yeah, really nice!

after last update cadence 1:0.8.1+git20140717 with xdg autostart all is fine. At least on ubuntu 14.04 amd-64 with Unity. Autostart works AND cadence shows the right jack status.

Many thanks.

User avatar
sm_mue_mi
Established Member
Posts: 15
Joined: Sun Aug 18, 2013 6:31 pm
Contact:

Re: jack autostart fail after last cadence update [solved]

Post by sm_mue_mi »

Just one more suggestion:

Can you add NoDisplay=true to /etc/xdg/autostart/cadence-session-start.desktop?
Without this my users can remove the autostart entry completely with gnome-session-properties (which copies cadence-session-start.desktop to ~/.config/autostart and adds Hidden=true) so jack will never autostart anymore even if the users choose this in cadence. I think this will happen with the kde autostart config tool too.

User avatar
sm_mue_mi
Established Member
Posts: 15
Joined: Sun Aug 18, 2013 6:31 pm
Contact:

Re: jack autostart fail after last cadence update [solved]

Post by sm_mue_mi »

Yes. In fact I have change it on my machine and jack autostart and cadence jack status is fine. The only difference is that I see the autostart entry not in gnome-session-properties (aka "Startup applications").

This is my actual working /etc/xdg/autostart/cadence-session-start.desktop:

Code: Select all

rf@SMThinkPad:~$ cat /etc/xdg/autostart/cadence-session-start.desktop 
[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
Name=Cadence session startup
Comment=Cadence session startup
Exec=cadence-session-start --system-start
Icon=cadence
Terminal=false
GenericName=
NoDisplay=true
rf@SMThinkPad:~$ 
In Ubuntu (standard with unity) the NoDisplay key is set for all xdg autostart entries that users should not see or change. I believe (but can not confirm) that KDE behaves in the same way since this is freedesktop stuff.

User avatar
sm_mue_mi
Established Member
Posts: 15
Joined: Sun Aug 18, 2013 6:31 pm
Contact:

Re: jack autostart fail after last cadence update [solved]

Post by sm_mue_mi »

Nice. Thanks again.

habbe
Established Member
Posts: 33
Joined: Sun Dec 09, 2012 9:11 pm

Re: jack autostart fail after last cadence update [solved]

Post by habbe »

Cadence autostart does not work for me, I have Carla 1:0.8.1+git20140717, Ubuntu 14.04 (unity) and saffireLE fw-soundcard. I have to power cycle my soundcard after which "Force Restart" will start jackd. I'm bus-powering the saffireLE.

User avatar
sm_mue_mi
Established Member
Posts: 15
Joined: Sun Aug 18, 2013 6:31 pm
Contact:

Re: jack autostart fail after last cadence update [solved]

Post by sm_mue_mi »

Last cadence version is 1:0.8.1+git20140718, can you update?
Can you also check if there are other jack related autostart entries?

Someone here 'solved' th issue by creating an autostart entry in his HOMEDIR/.config/autostart but this is not the necessary.

habbe
Established Member
Posts: 33
Joined: Sun Dec 09, 2012 9:11 pm

Re: jack autostart fail after last cadence update [solved]

Post by habbe »

sm_mue_mi wrote:Last cadence version is 1:0.8.1+git20140718, can you update?
Can you also check if there are other jack related autostart entries?

Someone here 'solved' th issue by creating an autostart entry in his HOMEDIR/.config/autostart but this is not the necessary.
Updated, no other jack-related autostarts, does not work. Using the integrated soundcard via alsa backend it does work, however. So the problem is autostarting with ffado-backend.

bazsound
Established Member
Posts: 480
Joined: Sat Aug 03, 2013 11:46 am

Re: jack autostart fail after last cadence update [solved]

Post by bazsound »

Just moved to lubuntu 14.04 with kx repos

finally got things working properly with nvidia.

But jack is not auto starting. Even though the check box is ticked in cadence.

Jack can be manually started along with the alsa bridge and audio works just does not auto start :/

Post Reply