Nvidia on linux 3.8

Unofficial support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: khz, MattKingUSA

f00bar
Established Member
Posts: 83
Joined: Sun May 12, 2013 7:40 pm

Nvidia on linux 3.8

Post by f00bar »

Anyone with a Nvidia card that has upgraded and got Nvidias drivers to work. I want to know before I upgrade.

male
Established Member
Posts: 232
Joined: Tue May 22, 2012 5:45 pm

Re: Nvidia on linux 3.8

Post by male »

falkTX wrote:I have no idea either, and would welcome feedback as well.
I can backport the drivers from 13.04 if the current ones don't work.

For now, AMD and Broadcom drivers are known to be working with 3.8-lowlatency.
Are you including the 3.8 kernel in KXStudio now? What about the issues with it breaking USB audio?
Image

male
Established Member
Posts: 232
Joined: Tue May 22, 2012 5:45 pm

Re: Nvidia on linux 3.8

Post by male »

falkTX wrote:
male wrote:Are you including the 3.8 kernel in KXStudio now? What about the issues with it breaking USB audio?
Yes, I plan to do so for the next release. The 3.8 kernel is the one used in Ubuntu 13.04, I'll just backport it.
Ubuntu will also use it for the 12.04.3 update in August.

I don't know about it breaking USB Audio though, got any links/info about this?
Ubuntu bug is here: https://bugs.launchpad.net/ubuntu/+sour ... mments=all
Image

male
Established Member
Posts: 232
Joined: Tue May 22, 2012 5:45 pm

Re: Nvidia on linux 3.8

Post by male »

male wrote:
falkTX wrote:
male wrote:Are you including the 3.8 kernel in KXStudio now? What about the issues with it breaking USB audio?
Yes, I plan to do so for the next release. The 3.8 kernel is the one used in Ubuntu 13.04, I'll just backport it.
Ubuntu will also use it for the 12.04.3 update in August.

I don't know about it breaking USB Audio though, got any links/info about this?
Ubuntu bug is here: https://bugs.launchpad.net/ubuntu/+sour ... mments=all
Oh and I can confirm that 3.8 breaks my Scarlett 2i4.
Image

tatch
Established Member
Posts: 662
Joined: Fri Nov 16, 2012 3:18 pm

Re: Nvidia on linux 3.8

Post by tatch »

I use bumblebee/optimus with nvidia and it seems to be working fine for the most part, except sometimes when I boot my color profile gets ignored and can only be fixed with a reboot.

gazpacho
Established Member
Posts: 41
Joined: Wed Aug 15, 2012 1:49 am
Location: Mallorca

Re: Nvidia on linux 3.8

Post by gazpacho »

I can confirm nvidia driver working OK on two machines with recent 3.8 kernel.
One has an old card, the other has an nvidia ion chipset and is using 304.88 (according to nvidia x server settings).
The broadcom driver is unable to install on the ion netbook. Using bcmwl-kernel-source version 6.20.155.1+bdcom-0ubuntu6~precise1~ppa1 on hardware:
03:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

Looking at the failure in the log /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/make.log displays:

Code: Select all

DKMS make.log for bcmwl-6.20.155.1+bdcom for kernel 3.8.0-20-lowlatency (i686)
vie may 24 19:20:56 CEST 2013
make: se ingresa al directorio «/usr/src/linux-headers-3.8.0-20-lowlatency»
CFG80211 API is prefered for this kernel version
Using CFG80211 API
  LD      /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/built-in.o
  CC [M]  /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/shared/linux_osl.o
  CC [M]  /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_linux.o
  CC [M]  /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_iw.o
  CC [M]  /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.o
/var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.c:1578:2: aviso: inicialización desde un tipo de puntero incompatible [activado por defecto]
/var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.c:1578:2: aviso: (cerca de la inicialización de ‘wl_cfg80211_ops.set_tx_power’) [activado por defecto]
/var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.c:1579:2: aviso: inicialización desde un tipo de puntero incompatible [activado por defecto]
/var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.c:1579:2: aviso: (cerca de la inicialización de ‘wl_cfg80211_ops.get_tx_power’) [activado por defecto]
  LD [M]  /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/wl.o
  Building modules, stage 2.
CFG80211 API is prefered for this kernel version
Using CFG80211 API
  MODPOST 1 modules
FATAL: modpost: GPL-incompatible module wl.ko uses GPL-only symbol '__rcu_read_unlock'
make[1]: *** [__modpost] Error 1
make: *** [modules] Error 2
make: se sale del directorio «/usr/src/linux-headers-3.8.0-20-lowlatency»
I can boot on kernel 3.2.0-41-lowlatency-pae if I need the wireless.
Hope this is for good use. Thanks.

f00bar
Established Member
Posts: 83
Joined: Sun May 12, 2013 7:40 pm

Re: Nvidia on linux 3.8

Post by f00bar »

I use geforce gtx 630. My USB soundcard is an EDIROL UA25.

Alwaysanewb
Established Member
Posts: 232
Joined: Sat Oct 13, 2012 9:04 pm

Re: Nvidia on linux 3.8

Post by Alwaysanewb »

I think I read you have a 3.8 rt kernal prepared? I can try to install it if you want and see hojw my nvidia card does.

Alwaysanewb
Established Member
Posts: 232
Joined: Sat Oct 13, 2012 9:04 pm

Re: Nvidia on linux 3.8

Post by Alwaysanewb »

How to the Low latency kernals run compaired to the RT? I can try the 3.8 one of those if you point me in the right direction.

Alwaysanewb
Established Member
Posts: 232
Joined: Sat Oct 13, 2012 9:04 pm

Re: Nvidia on linux 3.8

Post by Alwaysanewb »

So far seems to be working better for me than the 3.2 rt I opened up ardour record a couple of tracks opened up claudia and cadence and checked everything out 0 xruns. Left everything open and got on the net logged on here. opened up system it seached for drivers. I'm running nvidia (recommended) (current) Still no xruns. I couldn't open a program before while recording with out getting xruns. Thinking about tempting fate and lowering my buffer size.


Wait.... I just opened thunderbird and checked my emails no bitches repied to my cl ad, but I still haven't gotten any xruns.

Seriously no graphics glitches or anything wierd yet and runs a lot more stable than 3.2rt.

Alwaysanewb
Established Member
Posts: 232
Joined: Sat Oct 13, 2012 9:04 pm

Re: Nvidia on linux 3.8

Post by Alwaysanewb »

Never mind it was running great woke up this morning and still seemed to be running well had to restart my computer and it past the kxstudio logo screen to a screen with a little line and wouldnt get past that. Messed with it all morning. Then tryed a reinstall.I installed ubinti 12.04.2 64bt instead of 12.04 i might of messed that up somehow too. Not running very well ardour 3 wont open up wont create a session or something like that.


I might reinstall again start from the beginning and see what happens.

danboid
Established Member
Posts: 1305
Joined: Sun Aug 26, 2012 11:28 am
Location: England

Re: Nvidia on linux 3.8

Post by danboid »

I re-installed KXStudio on my friends machine earlier, which has an embedded AMD/Radeon mobo GPU. 'Additional Drivers' successfully detected and installed fglrx on this machine with the older, 12.04.1 kernel (was in 3.2 or 3.4, I forget?) but it finds no non-free drivers for 3.8.

I know there are other ways to install fglrx (which I've not attempted yet) but I thought I'd best report this here. I'll get the the model of the GPU if required.

Anyone else tried 'Additional drivers' with Radeon under the new KX 3.8 kernel?
Are you new to Linux Audio? This manual explains how to install KXStudio, set up and use JACK, mimimize latency, lists the best Linux AV apps and much more all in a concise and easy to understand format.

http://wiki.linuxaudio.org/wiki/kxstudio_manual

ToddMWorth
Established Member
Posts: 225
Joined: Tue Oct 23, 2012 3:59 am

Re: Nvidia on linux 3.8

Post by ToddMWorth »

Fails here, on the xorg edgers driver I have always used :( :


Setting up linux-firmware (1.106~precise1~ppa1) ...
Setting up linux-lowlatency-headers-3.8.0-24 (3.8.0-24.16) ...
Setting up linux-headers-3.8.0-24-lowlatency (3.8.0-24.16) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.8.0-24-lowlatency /boot/vmlinuz-3.8.0-24-lowlatency
ERROR (dkms apport): kernel package linux-headers-3.8.0-24-lowlatency is not supported
Error! Bad return status for module build on kernel: 3.8.0-24-lowlatency (x86_64)
Consult /var/lib/dkms/nvidia-experimental-310/310.14/build/make.log for more information.



Updated to nvidia-319 ... All good :)



Slightly OT: Still see this weird error... Seems cosmetic.

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
W: Waited for dpkg --assert-multi-arch but it wasn't there - dpkgGo (10: No child processes)

luster
Established Member
Posts: 221
Joined: Mon Mar 05, 2012 10:03 pm

Re: Nvidia on linux 3.8

Post by luster »

Slightly OT: Still see this weird error... Seems cosmetic.

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
W: Waited for dpkg --assert-multi-arch but it wasn't there - dpkgGo (10: No child processes)
I've been ignoring that error for months. I asked here at the linuxmusicians forum about it since I was concerned about it, but others mentioned they had been seeing it and ignoring it.

If anyone knows more about what this message means, I'd like to hear it.


EDIT: "others" turned out to be just you, ToddMWorth. http://www.linuxmusicians.com/viewtopic ... 47&t=10909

Post Reply