CARLA doesn't load after update

Unofficial support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: khz, MattKingUSA

Post Reply
rastagallo
Established Member
Posts: 42
Joined: Tue Oct 30, 2012 11:42 am

CARLA doesn't load after update

Post by rastagallo »

Hi!
Yesterday I updated the system, but since that Carla just doesn't show up.
If i run it in a terminal, it gives me this:

Code: Select all

Traceback (most recent call last):
  File "/usr/share/cadence/src/carla.py", line 26, in <module>
    from carla_backend import *
  File "/usr/share/cadence/src/carla_backend.py", line 30, in <module>
    from shared_carla import *
ImportError: No module named shared_carla
Is there any way to run it?
Thanks for the support!

skavar
Established Member
Posts: 97
Joined: Sat Sep 15, 2012 9:21 am

Re: CARLA doesn't load after update

Post by skavar »

falkTX wrote:
I need a place to test out upcoming packages, the testing PPA exists for this.
I uploaded a non-carla cadence package (carla now stripped from Cadence code, it's a separate project), to test if the packaging was still ok.

Please purge the testing PPA:

Code: Select all

sudo apt-get install ppa-purge
sudo ppa-purge ppa:kxstudio-team/testing
Ah.. I thought testing was for community testing. Maybe you need an experimental PPA for developer testing.
In any case could you move the FFADO packages to main so I can purge the testing PPA also.

rastagallo
Established Member
Posts: 42
Joined: Tue Oct 30, 2012 11:42 am

Re: CARLA doesn't load after update

Post by rastagallo »

I've installed the test ppa because of an old problem! Now everything works, thanks!

Post Reply