Crazy problem with security update, libav

Unofficial support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: khz, MattKingUSA

wolftune
Established Member
Posts: 1305
Joined: Fri Feb 24, 2012 7:40 pm
Location: Portland, OR
Contact:

Crazy problem with security update, libav

Postby wolftune » Mon Nov 12, 2012 7:04 pm

Today, my update system says there are security updates for libav files and some multimedia player (dragonplayer?)
But when I try to upgrade it says:

Code: Select all

The following packages have been kept back:
  libav-tools libavdevice53 libavfilter2 libavformat53 libpostproc52 libswscale2
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.


If I try clicking these in Muon, it threatens to uninstall tons of things from kdenlive to ffmpeg to kxstudio stuff if I accept installing.
Aaron Wolf
Music teacher, scholar
http://wolftune.com

tux99
Established Member
Posts: 344
Joined: Fri Sep 28, 2012 10:42 am
Contact:

Re: Crazy problem with security update, libav

Postby tux99 » Mon Nov 12, 2012 7:07 pm

Maybe it would help if you say what distro you are using (and what repos you have enabled).

wolftune
Established Member
Posts: 1305
Joined: Fri Feb 24, 2012 7:40 pm
Location: Portland, OR
Contact:

Re: Crazy problem with security update, libav

Postby wolftune » Mon Nov 12, 2012 7:21 pm

I'm using the straight KXStudio DVD install 12.04
Besides the KXStudio stuff, I have some minor one-app repositories (google talk, dropbox, dinisnoise, taskcoach…), ubuntu-wine, kubuntu-backports
Aaron Wolf
Music teacher, scholar
http://wolftune.com

User avatar
English Guy
Established Member
Posts: 473
Joined: Wed Oct 17, 2012 7:28 pm
Location: England

Re: Crazy problem with security update, libav

Postby English Guy » Mon Nov 12, 2012 9:27 pm

I am getting the same problem in Bodhi, so it looks like it is a Ubuntu problem.

wolftune
Established Member
Posts: 1305
Joined: Fri Feb 24, 2012 7:40 pm
Location: Portland, OR
Contact:

Re: Crazy problem with security update, libav

Postby wolftune » Mon Nov 12, 2012 11:49 pm

confirmed, fixed. :D
Aaron Wolf
Music teacher, scholar
http://wolftune.com

ToddMWorth
Established Member
Posts: 225
Joined: Tue Oct 23, 2012 3:59 am

Re: Crazy problem with security update, libav

Postby ToddMWorth » Tue Nov 13, 2012 2:15 pm

I'm seeing this today, related to kxstudio updates... I think?

There's gotta be a tool out there that draws a graph to calculate the root of a conflict?

Code: Select all

$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  kde-window-manager kde-workspace kdebase-workspace ksysguard kxstudio-desktop-kde4
The following packages have been kept back:
  freespacenotifier kde-runtime kde-runtime-data kde-style-oxygen kde-window-manager-common kde-workspace-bin kde-workspace-data kde-workspace-kgreet-plugins kdm khelpcenter4 kinfocenter klipper kmenuedit kmix libkephal4abi1
  libkscreensaver5 libksgrd4 libksignalplotter4 libplasma-geolocation-interface4 libplasmaclock4abi3 libplasmagenericshell4 libprocesscore4abi1 libprocessui4a libsolidcontrol4abi2 libsolidcontrolifaces4abi2 libtaskmanager4abi3
  libweather-ion6 plasma-dataengines-workspace plasma-desktop plasma-scriptengine-javascript plasma-widgets-workspace systemsettings
The following packages will be upgraded:
  ffmpeg kdebase-runtime ksysguardd libav-tools libavcodec-extra-53 libavdevice-extra-53 libavfilter-extra-2 libavformat-extra-53 libavutil-extra-51 libkwinnvidiahack4 libpostproc-extra-52 libproxy1 libswscale-extra-2 recordmydesktop
14 upgraded, 0 newly installed, 5 to remove and 32 not upgraded.
Need to get 5,068 kB of archives.
After this operation, 3,713 kB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.

brummer

Re: Crazy problem with security update, libav

Postby brummer » Tue Nov 13, 2012 2:40 pm

ToddMWorth wrote:There's gotta be a tool out there that draws a graph to calculate the root of a conflict?


On debian/sid I usually do:

Code: Select all

 apt-get -o Debug::pkgProblemResolver=yes dist-upgrade

in such a case to get detailed information about what happens.

ToddMWorth
Established Member
Posts: 225
Joined: Tue Oct 23, 2012 3:59 am

Re: Crazy problem with security update, libav

Postby ToddMWorth » Tue Nov 13, 2012 2:59 pm

That got it, thanks!!

The output confirmed my suspicion about the package. I had doubted it because it was a kxstudio version... It turns out I had made a copy/paste error last night, and added the wrong PPA (kxstudio-kde49). Removed it and I'm back to normal. Thanks again :)

wolftune
Established Member
Posts: 1305
Joined: Fri Feb 24, 2012 7:40 pm
Location: Portland, OR
Contact:

Re: Crazy problem with security update, libav

Postby wolftune » Tue Nov 13, 2012 5:11 pm

falkTX wrote:The kxstudio-kde49 PPA is just for those that want KDE 4.9 on 12.04 systems (I think the PPA description says so...).


Oh! I didn't realize this existed! Should I use this and remove the Kubuntu backports?
Aaron Wolf
Music teacher, scholar
http://wolftune.com

wolftune
Established Member
Posts: 1305
Joined: Fri Feb 24, 2012 7:40 pm
Location: Portland, OR
Contact:

Re: Crazy problem with security update, libav

Postby wolftune » Tue Nov 13, 2012 5:44 pm

Ok, thanks!
Aaron Wolf
Music teacher, scholar
http://wolftune.com


Return to “KXStudio Discussion”

Who is online

Users browsing this forum: No registered users and 3 guests