How to make Pulse stop treating 8 outputs as 7.1 surround?

Official support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: falkTX, khz, MattKingUSA

wolftune
Establlshed Member
Posts: 1283
Joined: Fri Feb 24, 2012 7:40 pm
Location: Portland, OR
Contact:

How to make Pulse stop treating 8 outputs as 7.1 surround?

Postby wolftune » Mon May 14, 2018 12:44 am

[move this if it's bigger than KXStudio please]

Even when just bridged to Jack via the bridge setting in Cadence, Pulse treats 8-channel output devices as 7.1 surround and thus the actual stereo outputs are missing a lot of the signal (particularly the low-end put out to the non-existent subwoofer). Is there a way to turn this off and force Pulse bridge to see only 2 stereo outputs?
Aaron Wolf
Music teacher, scholar
http://wolftune.com

User avatar
falkTX
Establlshed Member
Posts: 6645
Joined: Sat Jan 09, 2010 3:04 pm

Re: How to make Pulse stop treating 8 outputs as 7.1 surround?

Postby falkTX » Mon May 14, 2018 8:44 am

It is not directly supported yet.
but it is a matter of adding "channels=2" in the right place.
Open /usr/share/cadence/pulse2jack/play+rec.pa and add that "channels=2" at the end of the lines with with "load-module module-jack-..."

wolftune
Establlshed Member
Posts: 1283
Joined: Fri Feb 24, 2012 7:40 pm
Location: Portland, OR
Contact:

Re: How to make Pulse stop treating 8 outputs as 7.1 surround?

Postby wolftune » Mon May 14, 2018 3:07 pm

Thanks! So, since this is part of Cadence, I'm assuming this will be lost each time you update Cadence until the setting is officially supported?
Aaron Wolf
Music teacher, scholar
http://wolftune.com

User avatar
nikgnomicradio
Establlshed Member
Posts: 34
Joined: Wed Feb 07, 2018 9:31 pm
Contact:

Re: How to make Pulse stop treating 8 outputs as 7.1 surround?

Postby nikgnomicradio » Mon May 14, 2018 9:13 pm

Pulseaudio is designed for surround sound and doesn't cope well with multi-channel stereo

suggest try going to Pulseaudio Volume Control configuration tab

Code: Select all

pavucontrol -t 5

change device option to "analog stereo playback" (or "analog stereo duplex" if you need recording input)

If still not getting the bass response
edit ./etc/pulse/daemon.conf and remove semi-colon commenting out command

Code: Select all

enable-lfe-remixing = no


Alternatively, disable automatic detection of audio devices in Pulseaudio
Comment out this section of /etc/pulse/default.pa with "#" at start of line:

Code: Select all

# .ifexists module-udev-detect.so
#load-module module-udev-detect
#.else
#load-module module-detect
#.endif


then add commands to load devices in Pulseaudio with:

Code: Select all

load-module module-alsa-sink device=hw:<device>,<sub-device>

<device> = audio device number or name
<sub-device> = sub-device number

use similar command for adding recording source(s)

If you want Pulseaudio customisations to be retained after updates, copy Pulseaudio configuration files to home folder

Code: Select all

cp /etc/pulse/default.pa ~/.config/pulse/default.pa
cp /etc/pulse/daemon.conf ~/.config/pulse/daemon.conf
Last edited by nikgnomicradio on Tue May 15, 2018 5:48 am, edited 2 times in total.

wolftune
Establlshed Member
Posts: 1283
Joined: Fri Feb 24, 2012 7:40 pm
Location: Portland, OR
Contact:

Re: How to make Pulse stop treating 8 outputs as 7.1 surround?

Postby wolftune » Mon May 14, 2018 9:24 pm

Wow, what a detailed reply. But it sounds like falktx's much shorter fix would do it, no?

I should clarify that I don't use Pulse directly, I only use it through the bridge to Jack in Cadence.

If you want Pulseaudio customisations to be retained after updates, copy Pulseaudio configuration files to home folder


Independently of the fix details, this is new to me! I can keep various root customizations this way in general through updates??

Can I *only* mark the changes there and have those changes amended to whatever other updates might come? I wouldn't want to force a static config and overwrite updates that I didn't intend to change…
Aaron Wolf
Music teacher, scholar
http://wolftune.com

User avatar
nikgnomicradio
Establlshed Member
Posts: 34
Joined: Wed Feb 07, 2018 9:31 pm
Contact:

Re: How to make Pulse stop treating 8 outputs as 7.1 surround?

Postby nikgnomicradio » Tue May 15, 2018 12:38 am

wolftune wrote:I should clarify that I don't use Pulse directly, I only use it through the bridge to Jack in Cadence.

Apologies. I assumed from previous posts you might be using Pulseaudio+ALSA for audio playback without JACK
None of what I suggested is needed if only using Pulseaudio to JACK bridge

I had problems with Pulseaudio sometimes trying to use detected ALSA device and not route via JACK.
If the device was in use by JACK, the application couldn't route sound correctly and would stall
changing detected devices to 'off' in pavucontrol and only way for sound to get in and out of Pulseaudio was through JACK
was not a regular problem on my system, but disabling devices stopped any problem

Pulseaudio man pages was where I found out about copying Pulseaudio configuration files to home folder
configuration files at /etc/pulse/ remain in original state. custom configuration in /.config/pulse/ overrides original configuration, it does not merge the two files
If Pulseaudio configuration has a problem (user-error in home folder configuration or after an update) just delete the home folder files and restart Pulseaudio and it will be back on default settings

wolftune
Establlshed Member
Posts: 1283
Joined: Fri Feb 24, 2012 7:40 pm
Location: Portland, OR
Contact:

Re: How to make Pulse stop treating 8 outputs as 7.1 surround?

Postby wolftune » Tue May 15, 2018 3:57 am

falkTX wrote:It is not directly supported yet.
but it is a matter of adding "channels=2" in the right place.
Open /usr/share/cadence/pulse2jack/play+rec.pa and add that "channels=2" at the end of the lines with with "load-module module-jack-..."


okay, apparently a line on it's own being "channels=2" is not right. The bridge won't start that way. It was specifically on the line with "load-module module-jack-sink" (and not jack-source).

That worked at least on my current setup with 4-channels that used to create 4-channel surround otherwise, but I'm not back with the 8-channel output to see about that, though it should work the same.

The 2 channels are still called "front-right" and "front-left" leaving me to hope that it isn't doing the splitting but just not connecting the others. But hopefully all good…

I just want to know if this will get unset with updates. Obviously, this being a Cadence option officially will be great.
Aaron Wolf
Music teacher, scholar
http://wolftune.com

User avatar
falkTX
Establlshed Member
Posts: 6645
Joined: Sat Jan 09, 2010 3:04 pm

Re: How to make Pulse stop treating 8 outputs as 7.1 surround?

Postby falkTX » Tue May 15, 2018 6:05 am

wolftune wrote:I just want to know if this will get unset with updates. Obviously, this being a Cadence option officially will be great.

That is correct, but it is a planned Cadence option yes.
Someone already made a PR for it :)
Though it is made in a way that I dont like too much (it is either stereo or non-stereo, duplicating files).
Anyway, it will make the feature appear faster.

At the moment, priority is getting a KX alpha ISO to boot.
And I hope to make a small bugfix release for carla.
For cadence, I will go through most requests all at one, at some point.

User avatar
thetotalchaos
Establlshed Member
Posts: 125
Joined: Mon Sep 29, 2014 8:29 pm
Contact:

Re: How to make Pulse stop treating 8 outputs as 7.1 surround?

Postby thetotalchaos » Wed May 16, 2018 9:39 pm

I made this issue, as a bug report / feature request some time ago.
https://github.com/falkTX/Cadence/issues/185

Still hoping for a Cadence 1.0 :wink:
Check out my latest music album The Butterfly Effect
https://soundcloud.com/biser-angelov/sets/the-butterfly-effect


Return to “KXStudio Discussion”

Who is online

Users browsing this forum: No registered users and 22 guests