Page 1 of 1

HDMI audio issues on Android

Posted: Wed Mar 07, 2018 12:17 pm
by davefollmers
Hello,

I'm new to this forum and I'm unable to find any issues on the forum that is similar to mine.I bought the C2 alone with the Android emmc and started using it over HDMI to my TV.However within a short period, the audio stopped working and would never work again.I have tried the latest image 3 times and it happened again and again. I'm unable to trace the trigger.Yesterday as I was watching a movie, the sound suddenly went off and never came back again.Different apps such as Spotify might output the audio but it breaks/stutter.I've tried rebooting, turning off power, and everything I could but I cannot find a way to solve it unless I flash again.What could be the issue?

Please help

I didn't find the right solution from the internet.

References:
https://forum.odroid.com/viewtopic.php?t=27913
Animated Explainer Video

Thanks

Re: HDMI audio issues on Android

Posted: Wed Mar 07, 2018 4:04 pm
by milk
"However within a short period, the audio stopped working and would never work again." / "I have tried the latest image 3 times and it happened again and again."

those two sentences are confusing together - how can it (the audio breaking) happen again, if it never worked again after the first time it stopped working?



...i'm curious as to why you have referenced something that looks like a spam link? Animated Explainer Video? come across as some kind of SEO ploy.

further, why are you "dave" here and "andrew" on the odroid forum? if you /are/ the same person with the same problem, why post here after getting answers and saying there "After removing the jumper, I have not faced this issue yet so far. " then not posting again.

Re: HDMI audio issues on Android

Posted: Mon Dec 17, 2018 7:16 pm
by nateliv
This issue has been discussed in thread link below. I would also search around in your TV settings to see if there is a setting to let the TV know that you are using an HDMI for cable for audio. I know my Time Warner DVR cable box has a setting that needs to be set on HDMI.

Of the 22 user reviews I don't see a review on Amazon yet where this cable has worked with the Charge. Doesn't mean it won't but if someone has had success with that cable brand using their Charge then it might isolate your issue to your TV setting or your TV brand might be incompatible with that brand of cable.

You could always buy the Dell branded Monster HDMI micro to HDMI 6 foot cable off Amazon for $89! That's a pretty amazing price isn't it?

It could also be a cable compatibility issue because many other posters have no audio issue through their TV. Not all HDMI cables are alike. I ordered one from Monoprice.com for like $6 with shipping. They make good cables. Many sites sell the cable for $14.99.
Mine has not arrived yet, so I can't test it for compatibility.