Page 1 of 1

[Solved] Cadence greyed out Device/Interface

Posted: Fri Nov 22, 2019 10:59 am
by pabulum

I'm using Arch with i3 on a Dell Latitude with a single jack (in and out) and I have an IK Multimedia iRig 2.

I added myself to the audio and realtime groups and installed Cadence, jack2, Guitarix and pavucontrol.

My Device/Interface setting is greyed in Cadence and I get this error :

Code: Select all

Using Tray Engine 'Qt'
JackSettingsW::saveServerSettings() - Invalid clock-source value 'dbus.UInt32(0, variant_level=1)'
Traceback (most recent call last):
  File "/usr/share/cadence/src/", line 762, in slot_checkDriverSelection
  File "/usr/share/cadence/src/", line 476, in saveDriverSettings
    value = dbus.UInt32(int(self.ui.obj_driver_capture.currentText()))
ValueError: invalid literal for int() with base 10: 'dbus.UInt32(2, variant_level=1)'
In the end I don't have any sound registered by Guitarix.

Should I refund my iRig 2 to buy an iRig HD 2 ?

Thank you for your help.

Re: Cadence greyed out Device/Interface

Posted: Fri Nov 22, 2019 2:42 pm
by merlyn
You can see if the device is recognised by ALSA with :

Code: Select all

aplay -l
That will list available soundcards.

Re: Cadence greyed out Device/Interface

Posted: Fri Nov 22, 2019 7:00 pm
by thetotalchaos
It looks to me that your audio device is firewire. You should try to tune it from the firewire tab. Try to install alsa-tools as well. Check if you have alsa-plugins + alsa-firmware.
Thankfully you have Arch Wiki, which is a great repository of knowledge.

PS: Cadence is a very tricky app, so make sure that your audio is properly configured and working

Re: Cadence greyed out Device/Interface

Posted: Sat Nov 23, 2019 7:37 am
by Joermungand
The iRig has nothing to do with that. It simply outputs audio to the laptop’s internal sound card. So, whatever issues pop up, they are related to the latter. However, when I checked my Cadence settings, the interface was acting weird, almost like yours. I installed cadence-git from AUR ( and everything went back to normal. I suggest you try the same.

Re: Cadence greyed out Device/Interface

Posted: Wed Nov 27, 2019 2:23 pm
by pabulum
Thank you for your answers.
I solved it by uninstalling cadence and jack2 and installing qjackctl and jack.
I also had to check input and output boxes in guitarix.