[Solved] Cadence greyed out Device/Interface

What other apps and distros do you use to round out your studio?

Moderators: MattKingUSA, khz

Post Reply
pabulum
Posts: 2
Joined: Fri Nov 22, 2019 10:33 am

[Solved] Cadence greyed out Device/Interface

Post by pabulum »

Hello,

I'm using Arch with i3 on a Dell Latitude with a single jack (in and out) and I have an IK Multimedia iRig 2.

I added myself to the audio and realtime groups and installed Cadence, jack2, Guitarix and pavucontrol.

My Device/Interface setting is greyed in Cadence and I get this error :

Code: Select all

Using Tray Engine 'Qt'
JackSettingsW::saveServerSettings() - Invalid clock-source value 'dbus.UInt32(0, variant_level=1)'
Traceback (most recent call last):
  File "/usr/share/cadence/src/jacksettings.py", line 762, in slot_checkDriverSelection
    self.saveDriverSettings(False)
  File "/usr/share/cadence/src/jacksettings.py", line 476, in saveDriverSettings
    value = dbus.UInt32(int(self.ui.obj_driver_capture.currentText()))
ValueError: invalid literal for int() with base 10: 'dbus.UInt32(2, variant_level=1)'
2019-11-22-110139_1920x1080_scrot.jpg
In the end I don't have any sound registered by Guitarix.

Should I refund my iRig 2 to buy an iRig HD 2 ?

Thank you for your help.
You do not have the required permissions to view the files attached to this post.
Last edited by pabulum on Wed Nov 27, 2019 2:24 pm, edited 1 time in total.

merlyn
Established Member
Posts: 693
Joined: Thu Oct 11, 2018 4:13 pm

Re: Cadence greyed out Device/Interface

Post by merlyn »

You can see if the device is recognised by ALSA with :

Code: Select all

aplay -l
That will list available soundcards.

User avatar
thetotalchaos
Established Member
Posts: 183
Joined: Mon Sep 29, 2014 8:29 pm
Contact:

Re: Cadence greyed out Device/Interface

Post by thetotalchaos »

It looks to me that your audio device is firewire. You should try to tune it from the firewire tab. Try to install alsa-tools as well. Check if you have alsa-plugins + alsa-firmware.
Thankfully you have Arch Wiki, which is a great repository of knowledge.

PS: Cadence is a very tricky app, so make sure that your audio is properly configured and working
Check out my latest music album The girl with the stars in her eyes
https://totalchaos-music.bandcamp.com/a ... n-her-eyes

Joermungand
Established Member
Posts: 276
Joined: Wed Oct 24, 2012 5:19 pm

Re: Cadence greyed out Device/Interface

Post by Joermungand »

The iRig has nothing to do with that. It simply outputs audio to the laptop’s internal sound card. So, whatever issues pop up, they are related to the latter. However, when I checked my Cadence settings, the interface was acting weird, almost like yours. I installed cadence-git from AUR (https://aur.archlinux.org/packages/cadence-git) and everything went back to normal. I suggest you try the same.

pabulum
Posts: 2
Joined: Fri Nov 22, 2019 10:33 am

Re: Cadence greyed out Device/Interface

Post by pabulum »

Thank you for your answers.
I solved it by uninstalling cadence and jack2 and installing qjackctl and jack.
I also had to check input and output boxes in guitarix.

Post Reply