Scarlett 18i20 gen 2 won't run above 48kHz

What other apps and distros do you use to round out your studio?

Moderators: khz, MattKingUSA

Jorin
Established Member
Posts: 8
Joined: Fri Apr 12, 2019 5:44 pm

Scarlett 18i20 gen 2 won't run above 48kHz

Postby Jorin » Sun Aug 11, 2019 11:15 pm

Hello! I'm trying to work my setup and though I had success with a 2i4 in the past, my 18i20 is giving me trouble.

When turning my sample rate above 48kHz, i.e. 88.2kHz at minimum, I get everything playing at half speed and distorting terribly, so there seems to be some mismatch there with the interface staying at 44.1kHz, or whatever is happening.

I've tried the following:
  • Buffer/period settings -- don't seem to matter at all
  • USB 2 and 3: same results on both
  • Different PC: tried on two PCs running Manjaro / kernel 4.19 and one running Xubuntu 4.4
  • Different OS: works as intended on Windows 7 Edit: correction, it can be set to 88.2kHz or more, but Windows defaults the volume to 0 so I guess it doesn't work there. I'll be contacting Focusrite support. Edit 2: updated software, it works with 88.2kHz and 96kHz now, but not higher. This is supposed to put the interface in a somewhat different mode that restricts some features afaik, and I don't have any need to go that high so I'm not going to pursue it. As such I think it's safe to say that there's an issue that can be fixed on Linux to get up to 96kHz.
  • On-board settings: you can set some on-board settings in the Focusrite Control program on Windows. It doesn't seem to make a difference.

Here is some debugging information: https://gist.github.com/jorins/12779bcb ... f7b0e6a6d1
metal bassist

User avatar
AlexTheBassist
Established Member
Posts: 308
Joined: Mon May 19, 2014 3:44 am
Location: Russia, Moscow

Re: Scarlett 18i20 gen 2 won't run above 48kHz

Postby AlexTheBassist » Tue Aug 13, 2019 5:53 pm

First of all, you bought a professional audio card. You should be at least informed about what they do, and how the DAC/ADC behaves. Your intent to use higher sample rates is pointless; you can't improve audio quality in any way by pushing Nyquist frequency far above the hearing threshold. 48K is more than enough. The things that matter are S/N ratio and bit depth. But, it still doesn't matter if it's “deeper” than 24 bits: that's a whopping 16 million 777 thousand 216 of amplitude values stored in each sample. To get to the point where more than 24 bits matter, we need to use deadly high sound pressure levels just to subtly hear the effect. All of this 48 bits/384 KHz is plainly a marketing bullshit.

Second, the sample rate choice. All modern sound cards have a base clock frequency at 48KHz or multiplies of it. Other frequencies often lead to performance issues on any OS, like going out of sync with the host (usually indicated in JACK as “xruns”), so using a 48-based sample rate (96 if you really want to waste your disk space for nothing) is more reliable.

Third, “debugging information” you provided is useless to solve your issue. Even JACK logs would be a lot more valuable than your boot logs which say nothing about what happens when you actually start an audio server and start recording. We also need your IRQ settings and such in order to investigate the problem.
Being creative does not imply being lazy, stupid, or illiterate.

Working in Harrison Mixbus and Ardour on KDE Neon + KXStudio.


Return to “Linux Distributions & Other Software”

Who is online

Users browsing this forum: No registered users and 2 guests