Jack failing to start (previously working)

What other apps and distros do you use to round out your studio?

Moderators: khz, MattKingUSA

Post Reply
Philotomy
Established Member
Posts: 26
Joined: Sun Apr 02, 2017 9:47 am

Jack failing to start (previously working)

Post by Philotomy »

I've been running Jack using Cadence for a long time with no issues, but suddenly I'm getting an error when trying to start Jack. Running Arch and using a Scarlett 18i8. Config can be seen below:

Image
Image

After attempting to start Jack, the following shows up in the logs. (Also, after this error the Scarlett disappears from the list of sound/audio devices in the Gnome Settings app.)

Image

The error messages can be seen in the screenshot above, but I'll include them below (so they'll be part of the forum text search/index):

Code: Select all

Sat Nov 21 11:20:09 2020: ERROR: JackPosixProcessSync::LockedTimedWait error usec = 5000000 err = Connection timed out
Sat Nov 21 11:20:09 2020: ERROR: Driver is not running
Sat Nov 21 11:20:09 2020: ERROR: Cannot open client name = dbusapi
Sat Nov 21 11:20:09 2020: ERROR: failed to create dbusapi jack client
Sat Nov 21 11:20:09 2020: ERROR: Unknown request 4294967295
Sat Nov 21 11:20:09 2020: ERROR: CheckSize error size = 0 Size() = 12
Sat Nov 21 11:20:09 2020: ERROR: CheckRead error
Sat Nov 21 11:20:13 2020: ERROR: ALSA: prepare error for playback on "hw:USB,0" (Broken pipe)
Sat Nov 21 11:20:13 2020: ERROR: JackAudioDriver::ProcessSync: read error, stopping...
Sat Nov 21 11:20:15 2020: ERROR: control open "hw:USB" (No such device)
Sat Nov 21 11:20:15 2020: ERROR: control open "hw:USB" (No such device)
To be honest, I'm not even sure where to begin troubleshooting. When I first set up Jack I remember it being something of a trial to get it working, but it's been working fine for a long time -- until now. Any assistance or guidance is appreciated.
My recordings on SoundCloud
Distro: Arch, DAW: Bitwig, Interface: Scarlett 18i8 Gen 2

Philotomy
Established Member
Posts: 26
Joined: Sun Apr 02, 2017 9:47 am

Re: Jack failing to start (previously working)

Post by Philotomy »

Well, I've found that if I disable the Focusrite Scarlett Gen 2 Mixer Driver, Jack starts and works normally. If the Mixer Driver is enabled, Jack is failing with the errors listed above. I also found it doesn't matter how I start Jack: using qjackctl, using jack_control, and using cadence all give the same (error) result when the mixer driver is enabled. I guess I'll post over in the Gen 2 Mixer Driver thread with this info.
My recordings on SoundCloud
Distro: Arch, DAW: Bitwig, Interface: Scarlett 18i8 Gen 2

Post Reply