Background noise when MIDI controllers are plugged

Optimize your system for ultimate performance.

Moderators: khz, MattKingUSA

Post Reply
tuzzo
Established Member
Posts: 26
Joined: Tue Feb 26, 2013 4:39 pm

Background noise when MIDI controllers are plugged

Post by tuzzo »

Hello!
Recently i had troubles with a Hercules DJ controller. I thought it was broken because whenever i used the MIDI controls i couldn't hear any sound from my speakers except an annoying noise.
Today i plugged an AKAI MIDI controller after a long time, and this is giving me the same problem. So i am starting to think that it's not a device related issue.
In other words, whenever i connect a midi controller, i start hearing a background noise and if i play an audio file i only hear crackles.
Some hardware specs:

Code: Select all

Linux HP8440P 4.15.0-76-lowlatency #86-Ubuntu SMP PREEMPT Fri Jan 17 18:08:33 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

H/W path         Device      Class          Description
=======================================================
                             system         HP EliteBook 8440p
/0/0                         processor      Intel(R) Core(TM) i7 CPU       M 620  @ 2.67GHz
/0/4                         memory         8GiB System Memory
/0/100/1/0.1                 multimedia     High Definition Audio Controller
/0/100/1b                    multimedia     5 Series/3400 Series Chipset High Definition Audio
/0/100/1d/1/1/1              multimedia     Lexicon Alpha
As you can see I'm using a USB sound card.
Jack configuration:

Code: Select all

Mon Mar 16 19:41:44 2020: Starting jack server...
Mon Mar 16 19:41:44 2020: JACK server starting in realtime mode with priority 10
Mon Mar 16 19:41:44 2020: self-connect-mode is "Don't restrict self connect requests"
Mon Mar 16 19:41:44 2020: Acquired audio card Audio1
Mon Mar 16 19:41:44 2020: creating alsa driver ... hw:Alpha,0|hw:Alpha,0|256|2|44100|0|0|hwmon|hwmeter|-|32bit
Mon Mar 16 19:41:44 2020: configuring for 44100Hz, period = 256 frames (5.8 ms), buffer = 2 periods
Mon Mar 16 19:41:44 2020: ALSA: final selected sample format for capture: 24bit little-endian in 3bytes format
Mon Mar 16 19:41:44 2020: ALSA: use 2 periods for capture
Mon Mar 16 19:41:44 2020: ALSA: final selected sample format for playback: 24bit little-endian in 3bytes format
Mon Mar 16 19:41:44 2020: ALSA: use 2 periods for playback
Mon Mar 16 19:41:44 2020: graph reorder: new port 'system:capture_1'
Mon Mar 16 19:41:44 2020: New client 'system' with PID 0
Mon Mar 16 19:41:44 2020: graph reorder: new port 'system:capture_2'
Mon Mar 16 19:41:44 2020: graph reorder: new port 'system:playback_1'
Mon Mar 16 19:41:44 2020: graph reorder: new port 'system:playback_2'
Mon Mar 16 19:41:44 2020: New client 'a2j' with PID 1504
Thank you in advance for your help!


Last bumped by tuzzo on Thu Apr 02, 2020 1:07 pm.
Post Reply