6 channel playback to 2 channel stereo in a US800 tascam

Optimize your system for ultimate performance.

Moderators: MattKingUSA, khz

Post Reply
muzikermammoth
Established Member
Posts: 18
Joined: Sun Jun 09, 2019 6:10 pm

6 channel playback to 2 channel stereo in a US800 tascam

Post by muzikermammoth »

I'm using a tascam us-800. In pulseaudio, the jack module is loaded up with channels=6. The audio output is in stereo.

Right now any audio that runs through pulseaudio generates periodic crackles. I tested jack only output using mplayer -ao jack <sample> & mplayer -ao pulse <sample>. And the pulseaudio output is noticeably louder. This leads me to think the crackles could be due to some setting by pulseaudio.

I also noticed the stereo output sounds distinctly panned left right. Should there be some kind of downmixer to stereo somewhere?

muzikermammoth
Established Member
Posts: 18
Joined: Sun Jun 09, 2019 6:10 pm

Re: 6 channel playback to 2 channel stereo in a US800 tascam

Post by muzikermammoth »

Slight pebkac right there. To solve some other issue i had the headphones put through a stereo to mono adaptor. So left and right separation works.

The crackles though are still there, and the soundcard occasionally disappears from usb

muzikermammoth
Established Member
Posts: 18
Joined: Sun Jun 09, 2019 6:10 pm

Re: 6 channel playback to 2 channel stereo in a US800 tascam

Post by muzikermammoth »

In the log file, there's a retire_capture_urb: <num> callbacks suppressed . Not sure what this really means for a usb device, so any help to stop this would be great

Post Reply