Standard test needed to benchmark XRUNs

Optimize your system for ultimate performance.

Moderators: MattKingUSA, khz

User avatar
lilith
Established Member
Posts: 1382
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: Standard test needed to benchmark XRUNs

Post by lilith »

Checked again for the priorites and now my soundcard appears as [irq/31-snd_hda_] and [irq/33-snd_hda_].

https://paste.debian.net/1081383/

edit: Hmm. This must be something else as when I play a track in Reaper the interrupts of these processes are not increasing as checked with

Code: Select all

cat /proc/interrupts

merlyn
Established Member
Posts: 660
Joined: Thu Oct 11, 2018 4:13 pm

Re: Standard test needed to benchmark XRUNs

Post by merlyn »

As far as I know the soundcard should be the highest, then JACK. Also should the graphics have RT priority?

User avatar
lilith
Established Member
Posts: 1382
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: Standard test needed to benchmark XRUNs

Post by lilith »

merlyn wrote:As far as I know the soundcard should be the highest, then JACK. Also should the graphics have RT priority?
Ok. then this would be problem no. 1. Where do you see graphic stuff with RT priority?

merlyn
Established Member
Posts: 660
Joined: Thu Oct 11, 2018 4:13 pm

Re: Standard test needed to benchmark XRUNs

Post by merlyn »

Your graphics is i915?

Code: Select all

root       336   336     2  90     50 [irq/32-i915] 

User avatar
lilith
Established Member
Posts: 1382
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: Standard test needed to benchmark XRUNs

Post by lilith »

Ups.. Yes :shock: Why is that? That would explain a lot I guess :mrgreen: But is it a problem as RT priority is only 50%?

Jack Winter
Established Member
Posts: 381
Joined: Sun May 28, 2017 3:52 pm

Re: Standard test needed to benchmark XRUNs

Post by Jack Winter »

merlyn wrote:Your graphics is i915?

Code: Select all

root       336   336     2  90     50 [irq/32-i915] 
the irq/* threads normally run at priority 50.
Reaper/KDE/Archlinux. i7-2600k/16GB + i7-4700HQ/16GB, RME Multiface/Babyface, Behringer X32, WA273-EQ, 2 x WA-412, ADL-600, Tegeler TRC, etc 8) For REAPER on Linux information: https://wiki.cockos.com/wiki/index.php/REAPER_for_Linux

merlyn
Established Member
Posts: 660
Joined: Thu Oct 11, 2018 4:13 pm

Re: Standard test needed to benchmark XRUNs

Post by merlyn »

You've got a USB soundcard though, so snd_hda is the internal soundcard. The USB irqs are xhci and ehci I think.

User avatar
lilith
Established Member
Posts: 1382
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: Standard test needed to benchmark XRUNs

Post by lilith »

Yes, the ZOOM R8 is

Code: Select all

root       107   107     2 137     97 [irq/26-xhci_hcd]
JAckWinter helped me on IRC and I set the priority higher to 97 compared to Jack (95). This didn´ t help much, but I think now I found the bug.
I used an older version of Reaper from last year and with this the project plays fine and even browsing does not cause xruns. I went back then to the new version and the problem came back. Back again to the old and it´ s gone. I´ m pretty sure there´ s a change in Reaper that is causing it. I make now one final test with the new version.

Yup: Problem is back again.

This is with the old Reaper version (5.94) while Reaper is playing the most demanding part of the track and chromium open. Before first xruns came at ~20-30% already.

Samplerate is 48000Hz
Buffersize is 524
Buffer/Periods 3
jack running with realtime priority 95
Xrun 1 at DSP load 89.32% use 9.70ms from 10.92ms jack cycle time

Thanks for all your help! Hope I didn´ t waste your time too much :?

merlyn
Established Member
Posts: 660
Joined: Thu Oct 11, 2018 4:13 pm

Re: Standard test needed to benchmark XRUNs

Post by merlyn »

You're welcome.

Eh ... 524 isn't a multiple of 48.

User avatar
lilith
Established Member
Posts: 1382
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: Standard test needed to benchmark XRUNs

Post by lilith »

merlyn wrote:You're welcome.

Eh ... 524 isn't a multiple of 48.
Ouch you are right. Will change it again to 528.

User avatar
lilith
Established Member
Posts: 1382
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: Standard test needed to benchmark XRUNs

Post by lilith »

Concerning the soundcard priority stuff it's well described here imo:

https://www.mixxx.org/wiki/doku.php/adj ... io_latency

User avatar
lilith
Established Member
Posts: 1382
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: Standard test needed to benchmark XRUNs

Post by lilith »

Hi @tramp

since today I'm getting segmentation fault when starting the xruncounter script. Maybe it's due to an update of Debian 10(?)

Code: Select all

marco@marco:~/src$ ./xruncounter 

******************** SYSTEM CHECK *********************

Segmentation fault

In the journal I have these messages:

Code: Select all

Mär 07 19:59:36 marco kernel: xruncounter[1343]: segfault at 0 ip 00007f947fdb85d7 sp 00007ffd30fbafa8 error 4 in libc-2.28.so[7f947fd3a
Mär 07 19:59:36 marco kernel: Code: 0f 7f 27 f3 0f 7f 6f 10 f3 0f 7f 77 20 48 83 c6 30 48 83 c7 30 4c 8d 1d 4b c8 0d 00 49 63 0c 93 49 8
Mär 07 19:59:58 marco systemd[1]: systemd-hostnamed.service: Succeeded.
Mär 07 20:00:12 marco kernel: xruncounter[1359]: segfault at 0 ip 00007f5b85dc25d7 sp 00007ffc5b4cc758 error 4 in libc-2.28.so[7f5b85d44
Mär 07 20:00:12 marco kernel: Code: 0f 7f 27 f3 0f 7f 6f 10 f3 0f 7f 77 20 48 83 c6 30 48 83 c7 30 4c 8d 1d 4b c8 0d 00 49 63 0c 93 49 8
Last edited by lilith on Sun Mar 08, 2020 2:04 pm, edited 1 time in total.

User avatar
lilith
Established Member
Posts: 1382
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: Standard test needed to benchmark XRUNs

Post by lilith »

----- edit ----

User avatar
lilith
Established Member
Posts: 1382
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: Standard test needed to benchmark XRUNs

Post by lilith »

lilith wrote:
Sat Mar 07, 2020 7:02 pm
Hi @tramp

since today I'm getting segmentation fault when starting the xruncounter script. Maybe it's due to an update of Debian 10(?)

Code: Select all

marco@marco:~/src$ ./xruncounter 

******************** SYSTEM CHECK *********************

Segmentation fault

In the journal I have these messages:

Code: Select all

Mär 07 19:59:36 marco kernel: xruncounter[1343]: segfault at 0 ip 00007f947fdb85d7 sp 00007ffd30fbafa8 error 4 in libc-2.28.so[7f947fd3a
Mär 07 19:59:36 marco kernel: Code: 0f 7f 27 f3 0f 7f 6f 10 f3 0f 7f 77 20 48 83 c6 30 48 83 c7 30 4c 8d 1d 4b c8 0d 00 49 63 0c 93 49 8
Mär 07 19:59:58 marco systemd[1]: systemd-hostnamed.service: Succeeded.
Mär 07 20:00:12 marco kernel: xruncounter[1359]: segfault at 0 ip 00007f5b85dc25d7 sp 00007ffc5b4cc758 error 4 in libc-2.28.so[7f5b85d44
Mär 07 20:00:12 marco kernel: Code: 0f 7f 27 f3 0f 7f 6f 10 f3 0f 7f 77 20 48 83 c6 30 48 83 c7 30 4c 8d 1d 4b c8 0d 00 49 63 0c 93 49 8
I installed the KXStudio Default settings script and now it's working again. Don't know why though.

User avatar
lilith
Established Member
Posts: 1382
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: Standard test needed to benchmark XRUNs

Post by lilith »

I have a more general question. Would it be possible to increase the rate for DSP load in the xruncounterscript. When only using xruncounter it takes very long to reach 90% or so.

Typically I start Renoise or any other DAW to get a DSP load of already ~50% and then start xruncounter. Does this make sense? Typically Renoise has threads running with priority of 95 while xruncounter is running with 75. Is this problematic?

Post Reply