Page 1 of 1

Having trouble with Jack & WineASIO (64 bit)

Posted: Thu Nov 01, 2018 1:55 am
by Death
Update: Jack is all setup now so no issues there! It's just WineASIO I need help with setting up.

Hey all. It's been quite a while since I last logged in here. But I once again find myself using Linux for audio work and am having problems :wink:

Anyway, after trying out a load of Linux native DAWs, I've decided to continue using FL Studio. I'm fine with using Linux plugins but there's just no DAW like FL Studio (LMMS doesn't do it for me). I've managed to install FL Studio 20 (x64) in Wine via PlayOnLinux. My next step was to get the WineASIO x64 driver up and running. POL only offers the 32 bit version of WineASIO so I had to manually install the 64 bit version. I followed a guide to do it ( ... -wineasio/) and it all worked out as far as I can tell.

Next I tried following a guide to get WineASIO x64 into my FLS installation in POL, but I didn't have any luck there.

I also read that you need to be able to setup Jack in a way so that your regular system sounds are coming out of it for WineASIO to work. I can't figure out how to set that up though. I've followed guides involving using 'qjackctl' and 'Cadence', but it never works. Although I did manage to get sound out of Reaper via Jack.

So basically, I'm not sure how to setup Jack properly but I mainly need help with getting my install of FL Studio to use the 64 bit version of WineASIO. Can anyone help out with this?

Btw, I'm running Linux Mint 19 x64 with the 4.15.0-38 low latency kernel and my soundcard is a Focusrite 2i4.


Re: Having trouble with Jack & WineASIO (64 bit)

Posted: Tue Nov 06, 2018 10:37 pm
by Death

Re: Having trouble with Jack & WineASIO (64 bit)

Posted: Tue Nov 06, 2018 10:46 pm
by sysrqer
I can't help that much on the wineasio side, I've used it and got it working before but I don't remember how it works now. If you need to get jack running then maybe use something that is jack native like ardour just so you know that part is working and to eliminate issues with wineasio.

What it sounds like you're describing is bridging. Open cadence and on the bottom right you have various bridges. Not sure how wineasio fits into that though, I thought it went to jack.

Re: Having trouble with Jack & WineASIO (64 bit)

Posted: Thu Nov 08, 2018 11:49 pm
by Death
I just had a go with Ardour 5 and can get sound out of it fine when Jack is running. So it seems to work as far as I can tell. I just can't get system sounds to come out of it. I've tried messing with bridging and other options in Cadence also. But that's ok. I'm sure I'll figure out how to set it up in the end so I'm not too worried. It's really just the Wine ASIO I'm stuck with :(

Edit: Somehow Jack started working properly and I've got system sounds coming out of it now. So that problem is now sorted at least! Just WineASIO to deal with..

On a side note, Ardour seems alright since I last used it years ago. The interface is much more pleasing to look at than I previously remember it and it seems to be kitted out with some useful options and stuff now. I also used Harrison Mixbus v3 around the same time I last used Ardour. It was a joy to mix in with the built in EQ and saturation on each channel (big fan of that!). Thing is, neither of the two were fun to use midi with. FL Studio is just the master when it comes to midi/step sequencer/patterns/piano roll. Those are the things I miss so bad about it when I try other DAW's and that's why I can't ditch it. Shame..