Trying to get midi working

Optimize your system for ultimate performance.

Moderators: khz, MattKingUSA

User avatar
schivmeister
Established Member
Posts: 95
Joined: Sat Apr 12, 2008 9:28 am
Location: Singapore
Contact:

Postby schivmeister » Sun Apr 20, 2008 2:34 pm

You could try the tool irqbalance and do the following:

Code: Select all

sudo irqbalance


Contrary to the standard --oneshot option which practically does nothing on my system since it applies only once, running it directly as superuser proves fruitful. Make sure the following outputs false:

Code: Select all

[ "$(zgrep CONFIG_IRQBALANCE=y /proc/config)" ] && echo "true" || echo "false"


You can get an xrun-free system without SCHED_FIFO (Realtime), just that you would have to live with loose settings. I'm pretty sure -p512 -n3 does alright, since we raise the buffer even when not needed (not an USB device). 3 periods/buffer appear to be the only sane way to get sane response from onboard audio chips like mine, so discrete cards like yours would do much better.

Jean
Established Member
Posts: 12
Joined: Wed Apr 16, 2008 4:47 pm
Location: Groningen

Postby Jean » Mon Apr 21, 2008 6:54 am

schivmeister wrote:You can get an xrun-free system without SCHED_FIFO (Realtime)


Yes I'm gonna explore that first.

On the irq issue, first I'm gonna play with the hardware.

Thanks.


Return to “System Tuning and Configuration”

Who is online

Users browsing this forum: No registered users and 1 guest