Alsamixer - All levels to zero after reboot

Optimize your system for ultimate performance.

Moderators: khz, MattKingUSA

User avatar
Scary Hallo
Established Member
Posts: 276
Joined: Fri Oct 23, 2009 2:21 pm
Location: Germany / Pforzheim
Contact:

Alsamixer - All levels to zero after reboot

Postby Scary Hallo » Thu Nov 01, 2012 11:34 pm

Hello,
I had no sound on my spekers, so I checked alsamixer and all levels where zero. I ajusted them and all was fine. - Until the next reboot. - After reboot every fader is down to zero again.
Any idea?
:?:

User avatar
English Guy
Established Member
Posts: 472
Joined: Wed Oct 17, 2012 7:28 pm
Location: England

Re: Alsamixer - All levels to zero after reboot

Postby English Guy » Fri Nov 02, 2012 12:11 am

Hi

From the command line use the alsactl command to save the alsamixer state. On my ('buntu based) system you need to be root so I use:

Code: Select all

sudo alsactl store

User avatar
Scary Hallo
Established Member
Posts: 276
Joined: Fri Oct 23, 2009 2:21 pm
Location: Germany / Pforzheim
Contact:

Re: Alsamixer - All levels to zero after reboot

Postby Scary Hallo » Mon Nov 05, 2012 7:44 am

I have tried that. But doesn't work :(
But now I have other problems with my computer. (Hardware) I have to work on this later.

Pablo
Established Member
Posts: 1269
Joined: Thu Apr 17, 2008 9:57 pm

Re: Alsamixer - All levels to zero after reboot

Postby Pablo » Mon Nov 05, 2012 12:21 pm

Try storing the alsamixer configuration to a file in your home directory, without sudo. So, after fixing alsamixer, do a:

alsactl store -f ~/my_asound.state (name the file as you wish)

Restart the computer and try:

alsactl restore -f ~/my_asound.state

If this works, make the last command execute automatically at login.

User avatar
Scary Hallo
Established Member
Posts: 276
Joined: Fri Oct 23, 2009 2:21 pm
Location: Germany / Pforzheim
Contact:

Re: Alsamixer - All levels to zero after reboot

Postby Scary Hallo » Mon Nov 12, 2012 2:34 pm

Hi Pablo,

sorry for the delay - i had other problems (graphics-card)

Your sugestion works brilliant, if I do it maualy. But as put

Code: Select all

 restore -f ~/.config/asound.state

in a script and included it in System Settings -> Autostart my system hangs on reoot.
I'm on Kubuntu 12.04 with KXStudio.

Any sugestions?
:?: :?: :?:

Pablo
Established Member
Posts: 1269
Joined: Thu Apr 17, 2008 9:57 pm

Re: Alsamixer - All levels to zero after reboot

Postby Pablo » Mon Nov 12, 2012 6:16 pm

Code: Select all

 restore -f ~/.config/asound.state

Any sugestions?


You mean

Code: Select all

alsactl restore -f ~/.config/asound.state


Maybe, make it wait a bit?

Code: Select all

sleep 10 && alsactl restore -f ~/.config/asound.state

User avatar
Scary Hallo
Established Member
Posts: 276
Joined: Fri Oct 23, 2009 2:21 pm
Location: Germany / Pforzheim
Contact:

Re: Alsamixer - All levels to zero after reboot

Postby Scary Hallo » Tue Nov 13, 2012 8:01 am

Sorry,
sure I meant

Code: Select all

alsactl restore -f ~/.config/asound.state
(wrong copy and paste).
My question is, in which file I should write that command?

Pablo
Established Member
Posts: 1269
Joined: Thu Apr 17, 2008 9:57 pm

Re: Alsamixer - All levels to zero after reboot

Postby Pablo » Tue Nov 13, 2012 5:46 pm

My question is, in which file I should write that command?


I am sorry, I don't use KDE. Maybe, search the internet for "KDE autostart".

Cheers! Pablo

User avatar
Scary Hallo
Established Member
Posts: 276
Joined: Fri Oct 23, 2009 2:21 pm
Location: Germany / Pforzheim
Contact:

Re: Alsamixer - All levels to zero after reboot

Postby Scary Hallo » Tue Nov 13, 2012 11:38 pm

Ok I put the skript in the .kde/Autostart folder. But them my system hangs on reboot. The skcipt looks like this:

Code: Select all

#!/bin/bash

# restore alsamixe settings
sleep 10 && alsactl restore -f ~/.config/asound.state

:?:

User avatar
English Guy
Established Member
Posts: 472
Joined: Wed Oct 17, 2012 7:28 pm
Location: England

Re: Alsamixer - All levels to zero after reboot

Postby English Guy » Wed Nov 14, 2012 12:52 am

Scary Hallo wrote:Ok I put the skript in the .kde/Autostart folder. But them my system hangs on reboot. The skcipt looks like this:

Code: Select all

#!/bin/bash

# restore alsamixe settings
sleep 10 && alsactl restore -f ~/.config/asound.state

:?:


Just a thought. Have you tried running this from a terminal to see if it throws up any error messages?

User avatar
Scary Hallo
Established Member
Posts: 276
Joined: Fri Oct 23, 2009 2:21 pm
Location: Germany / Pforzheim
Contact:

Re: Alsamixer - All levels to zero after reboot

Postby Scary Hallo » Wed Nov 14, 2012 4:47 pm

Okay......
It was my fault. The script was not set to be executable.
Now it's working.

:)

Thanks Pablo
Thanks English Guy


Return to “System Tuning and Configuration”

Who is online

Users browsing this forum: No registered users and 3 guests