getting lots of xruns while sitting idle

Optimize your system for ultimate performance.

Moderators: khz, MattKingUSA

Post Reply
User avatar
ZestieBumwhig
Established Member
Posts: 66
Joined: Fri May 20, 2016 4:56 pm

getting lots of xruns while sitting idle

Post by ZestieBumwhig »

I apologize for asking for the same advice most every time I post. But you can't step in the same river twice.

I got a used desktop with decent specs, I think, for 2013. But I can't get audio/Jack as smooth as my similarly-aged laptop. As the title suggests, I can start accumulating xruns while doing nothing; and if I AM doing something, they are likely to be audible glitches.

This desktop has a low-level nVidia graphics card; I'm wondering how much of my problem stems from that, and if it's worth buying a used AMD card at these blockchain-crazed prices.

realTimeConfigQuickScan is happy with my setup. Based on xruncounter, these settings perform pretty well:

Code: Select all

Samplerate is 48000Hz 
Buffersize is 192 
Buffer/Periods  2
But in real life, I get these arbitrary xruns.

I'm running AVLinux-MXE, so I assume Jack is all correct. I have trouble understanding the RealTime permissions, but I'm guessing that's not my issue. Here's some of that info, because that's typically the first thing someone will ask...

I do know I'm in "audio," and audio has RT permission.

Code: Select all

$ groups ahpn
ahpn : ahpn lp dialout cdrom floppy sudo audio dip video plugdev users input netdev lpadmin scanner sambashare

Code: Select all

$ ulimit -r -l
real-time priority              (-r) 90
max locked memory       (kbytes, -l) unlimited

Code: Select all

$ cat /etc/security/limits.conf
@audio - rtprio 90       # maximum realtime priority
@audio - memlock unlimited  # maximum locked-in-memory address space (KB)
I don't understand this at all, but here goes. I see lots of pulseaudio with what I understand to be decent RT priorities, but all of my Jack settings seem to be pretty low. Looking this up, though, I'm probably reading this info wrong.

Code: Select all

$ ps -eLo rtprio,cls,pid,pri,nice,cmd | grep "FF" | sort -r
     5  FF  4110  45   - a2jmidid -e
    10  FF  3985  50   - /usr/bin/jackdbus auto
Similar situation with both Liquorix and RT kernels. SuperCollider won't run with Nouveau. Probably I just need to get rid of this damn nVidia graphics card.
User avatar
GMaq
Established Member
Posts: 2124
Joined: Fri Sep 25, 2009 1:42 pm
Has thanked: 154 times
Been thanked: 110 times

Re: getting lots of xruns while sitting idle

Post by GMaq »

Hi,

Are you using WiFi on the Desktop? Does it have Broadcom WiFi by chance?
User avatar
thetotalchaos
Established Member
Posts: 189
Joined: Mon Sep 29, 2014 8:29 pm
Contact:

Re: getting lots of xruns while sitting idle

Post by thetotalchaos »

ZestieBumwhig wrote: Tue Nov 23, 2021 3:39 am This desktop has a low-level nVidia graphics card; I'm wondering how much of my problem stems from that....
The proprietary NVidia driver like to mess up with the RT performance. It doesn't respect user/system custom realtime values.
Same is true for the proprietary WiFi drivers
You can listen to my music at: https://totalchaos-music.bandcamp.com/

Take a journey to wonderland with The Butterfly Effect 2016
https://totalchaos-music.bandcamp.com/a ... fly-effect
User avatar
ZestieBumwhig
Established Member
Posts: 66
Joined: Fri May 20, 2016 4:56 pm

Re: getting lots of xruns while sitting idle

Post by ZestieBumwhig »

By gum, that's exactly it, @GMaq! Yes it is Broadcom; I just turned it off and ran about 45 minutes Xrun free with Reaper, Supercollider, some VSTS, etc... Thank you!

I am slightly ashamed, in my research I HAD seen wi-fi as a possible culprit, but I skipped that. I think I forgot I never ran a 50 foot ethernet cable (in my mind, desktops are always wired).

Thanks to you and @thetotalchaos.
User avatar
GMaq
Established Member
Posts: 2124
Joined: Fri Sep 25, 2009 1:42 pm
Has thanked: 154 times
Been thanked: 110 times

Re: getting lots of xruns while sitting idle

Post by GMaq »

ZestieBumwhig wrote: Wed Nov 24, 2021 1:33 am By gum, that's exactly it, @GMaq! Yes it is Broadcom; I just turned it off and ran about 45 minutes Xrun free with Reaper, Supercollider, some VSTS, etc... Thank you!

I am slightly ashamed, in my research I HAD seen wi-fi as a possible culprit, but I skipped that. I think I forgot I never ran a 50 foot ethernet cable (in my mind, desktops are always wired).

Thanks to you and @thetotalchaos.
I have a Samsung laptop with the same issue, turn off Broadcom WiFi and it's a great recording machine, switch it on and an eye twitch and irrational desire to throw it out of a window develops..
Post Reply