KXStudio 10.04.2 is out!

Discuss anything new and newsworthy! See http://planet.linuxaudio.org for more Linux Audio News!

Announcements of proprietary software may fit better in the Marketplace.

Moderators: raboof, khz, MattKingUSA

brummer

Re: KXStudio - The KDE Multimedia distro

Postby brummer » Thu Apr 15, 2010 7:39 pm

Hi falk

I couldn't found a application list for KXStudio.
Would be nice if you could add information about with applications you have included.
Did KXStudio run as live CD/Dvd also ?

Haven't the time now to download and check your new distribution, but it seems to be a great good work.

respect brummer

laba170
Established Member
Posts: 53
Joined: Fri Jul 31, 2009 5:22 pm

Re: KXStudio - The KDE Multimedia distro

Postby laba170 » Fri Apr 16, 2010 1:45 pm

I tested the live DVD yesterday. I looks promising, but running from the dvd was really slow. Nothing like AVlinux for example, which runs very well in comparison. (KDE's fault maybe?) I'll try installing it later though, to see how it really performs. :)

User avatar
Chipfryer
Established Member
Posts: 362
Joined: Tue Nov 24, 2009 12:43 pm

Re: KXStudio - The KDE Multimedia distro

Postby Chipfryer » Sun Apr 18, 2010 6:03 pm

Hi Falk.
I take it this is only for 64 bit machines at the moment then please?

User avatar
Chipfryer
Established Member
Posts: 362
Joined: Tue Nov 24, 2009 12:43 pm

Re: KXStudio - The KDE Multimedia distro

Postby Chipfryer » Sun Apr 18, 2010 9:43 pm

Thanks Falk.
It does look really good. I'll be trying it for certain.

User avatar
Zen:Core
Established Member
Posts: 36
Joined: Mon Mar 29, 2010 2:18 pm
Location: De Soto, KS

Re: KXStudio - The KDE Multimedia distro

Postby Zen:Core » Sat Apr 24, 2010 3:34 am

I've become a bit of a KDE fan (though right now I use Openbox on top of KDE). When you squash the bugs I'll definitely give it a look see. 8) The screenshots look great!
"So give me 5 shots of Whiskey to help kill the misery and the pain. You put me through. Thanks for the good times for they were the best of my life, I spent with you."

roaldz
Established Member
Posts: 28
Joined: Sat May 02, 2009 3:21 pm
Location: Almelo, Netherlands
Contact:

Re: KXStudio - The KDE Multimedia distro

Postby roaldz » Sun May 02, 2010 3:33 pm

Thank you for this falktx!

Just one problem: It boots (running in Virtualbox) and after going through the wizard, my desktop is gone, so I created the panel and widgets myself. This is not a problem, but my jack output doesn't work. The .config/jack/conf.xml file is there. How can I fix this?

Roald

munny
Established Member
Posts: 7
Joined: Thu May 06, 2010 7:44 am

Re: KXStudio - The KDE Multimedia distro

Postby munny » Thu May 06, 2010 8:07 am

Hi FalkTx,
first of all i must do compliments about your great work, KXStudio is really the distribution that i was looking for, and I hope it may have a great future.

I've installed in a desktop pc and there's no problem, all is perfect, but in my notebook i don't have audio. :(
I tried every thing i found in internet without results, i noticed that in Kmix and alsamixer i can't see PCM channel, i think the problem is related to this.
I've tried also to install a fresh Kubuntu 10.04, in this case Audio is ok, but if i try to install Jack or Jack2 (both without Pulseaudio), server start and after some seconds it freezes.

My Audio from lspci is:
Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
and alsamixer say me:
HDA Intel, Sigmatel STAC9200

Before i used Kubuntu 9.10 without problem.

I hope you can help me to use your great KXStudio!

Regardas, Munny

P.S. Sorry for my english, i'm italian

Pablo
Established Member
Posts: 1269
Joined: Thu Apr 17, 2008 9:57 pm

Re: KXStudio - The KDE Multimedia distro

Postby Pablo » Thu May 06, 2010 8:41 am

Hi, Try the following.

Edit /etc/modprobe.d/alsa-base.conf

Add the line:

Code: Select all

options snd-hda-intel model=here-the-model


First I would try model=auto

See

http://www.kernel.org/doc/Documentation ... Models.txt

HTH, Pablo

EDIT: Of course, you need to remove and reload the module, or restart the computer
Last edited by Pablo on Thu May 06, 2010 10:50 am, edited 1 time in total.

Grep
Established Member
Posts: 23
Joined: Wed Jan 07, 2009 7:32 pm
Location: Canada

Re: KXStudio - The KDE Multimedia distro

Postby Grep » Thu May 06, 2010 9:35 am

Thanks big time for all the work done FalkTX. I have tried netboot install image few days ago,on the blank drive i have formated for another distro . Not having any cds or dvd's at hand i used swiss army knife for usb installs in Linux :D http://unetbootin.sourceforge.net/ to load ISO on usb stick in less then 2 minutes and Installer kicked in and worked very well . I knew that having booted from usb changes the drive names and boot order in the Bios,and once usb stick is out ,system rebooted,grub needs tweaking . I just wanted to test installer.
Today I was about to download fresh live dvd for 64bit platform from sourceforge to test it before I atempt hard drive install ,when I have noticed that my choice always brings me to the netboot image (13mb) download link. I will check on again later and post my experience with Live dvd and Install from there.

munny
Established Member
Posts: 7
Joined: Thu May 06, 2010 7:44 am

Re: KXStudio - The KDE Multimedia distro

Postby munny » Thu May 06, 2010 10:55 am

Pablo thank you for reply, i tried your suggestion but still my notebook is without audio.
I tried first model=auto, after i tried asus, asus-laptop and other from list you linked without results, my notebook model is Asus F3F. I've Linux installed in this notebook at least 2 years always without a problem in my audio, and in kmix i see always PCM channel.
In Kubuntu Lucid Live now i see that in kmix i don't see PCM channel but in alsa mixer PCM there's and is at 100%.
Maybe should i configure something in Pulse???


For Grep: The link to 64bit from KXStudio web site is wrong, you can find 64 bit link download here:
http://sourceforge.net/projects/kxstudio/files/

munny
Established Member
Posts: 7
Joined: Thu May 06, 2010 7:44 am

Re: KXStudio - The KDE Multimedia distro

Postby munny » Thu May 06, 2010 3:17 pm

hi FalkTX,
I've already tried to search pcm channel in kmix but without luck.

Anyway i'm trying again to searching the problem and my little news are:
1) if i do rm of .asoundrc and /etc/asound.conf at reboot i see pcm channel with kmix and alsamixer with 0 Volume, i can seto to 100% but nothing change
2) In the first message i forgot to write that at login Phonon say me Device Jack doesn't work and obviusly if try to start with qjackctl doesn't go.
3) Before kdm start, i noted a message about: Alsal lib pulse.c:229(pulse_connect) Connection Refused

I hope this can help you.

munny
Established Member
Posts: 7
Joined: Thu May 06, 2010 7:44 am

Re: KXStudio - The KDE Multimedia distro

Postby munny » Thu May 06, 2010 5:37 pm

I tried again to set all permisison from KXStudio Settings, rebooted but again no audio. :(

munny
Established Member
Posts: 7
Joined: Thu May 06, 2010 7:44 am

Re: KXStudio - The KDE Multimedia distro

Postby munny » Fri May 07, 2010 2:21 pm

Yes, in Kubuntu sound is ok but for now i haven't installed pulseaudio and jack, in KXStudio sound never works, both Live and Install, and don't work also with all updates, i also add repository kubuntu-updates for kde 4.4.3 without results.
For now i've 2 partitions with kubuntu and KXStudio, i'll try to install pulseaudio and jack in kubuntu, i'll say you if it works. I leave also fresh KXStudio for help you to understand problem, if you want! ;)

Grep
Established Member
Posts: 23
Joined: Wed Jan 07, 2009 7:32 pm
Location: Canada

Re: KXStudio - The KDE Multimedia distro

Postby Grep » Sat May 08, 2010 8:25 pm

Thanks for the link munny . Iv got the 64 bit Live dvd , after install it has failed to boot logs from failed installation were sent to falkTX. Live session works but comes with pulseaudio child process zombie after settling the desktop,and on again whenever pulse is run. Getting rid of it lets Jack start again. I was able to record in live session after tweaking Jack and stopping pulse audio few times. Sound was getting distorted whenever i would switch the window or open up link in a browser while listening . After machine was sitting idle in alive session for few hours,screen refused to wake up(non responsive to mouse and keyboard) so I have turned monitor off and on to get the screen back. Some of the bugs I have encountered are known Kubuntu bugs like failing to shutdown,some are KDE related bugs like network manager window refusing to close on my taskbar etc.I will try net installer as soon as I find more time for it.

Grep
Established Member
Posts: 23
Joined: Wed Jan 07, 2009 7:32 pm
Location: Canada

Re: KXStudio - The KDE Multimedia distro

Postby Grep » Sun May 09, 2010 5:05 am

I have decided to try one more time install from Live dvd , before moving on the net installer and it worked,after removing long forgotten usb stick from the back and playing with bios settings :wink: Im writing this from KXStudio desktop.Install went smooth and I was able to get RT kernel . Everything works this time. Pulse was removed and when phonon has kicked in I choose input im using to spdif connect my cybertwin se for noiseless recordings to otherwise ancient sb live rack. Jack was restarted,buffers tweaked and in Ardour I was able to make first hard drive recording in KXStudio :D latency at 5.3 ms . Not bad for 10 years old sound card.Now testing can begin,hard drive install performs much better then Live dvd ,of course. When offered updates i went just for security ones,going back to generic kernel from RT one was out of question.
Thanks one more time for all the work you have done to get this awesome distro out.


Return to “Linux Music News”

Who is online

Users browsing this forum: No registered users and 1 guest