[ANN] LSP Plugins 1.0.24 release is available

Discuss anything new and newsworthy! See http://planet.linuxaudio.org for more Linux Audio News!

Announcements of proprietary software may fit better in the Marketplace.

Moderators: raboof, MattKingUSA, khz

User avatar
sadko4u
Established Member
Posts: 779
Joined: Mon Sep 28, 2015 9:03 pm

Re: [ANN] LSP Plugins 1.0.24 release is available

Post by sadko4u »

funkmuscle wrote:I've been running Ardour with LSP ParametricEQ (lv2) launched with valgrind for an hour now with no issues. :?
And what happens when you're adding Drumgizmo?
Also, do you run it with memcheck tool enabled?
LSP (Linux Studio Plugins) Developer and Maintainer.

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: [ANN] LSP Plugins 1.0.24 release is available

Post by funkmuscle »

sadko4u wrote:
funkmuscle wrote:I've been running Ardour with LSP ParametricEQ (lv2) launched with valgrind for an hour now with no issues. :?
And what happens when you're adding Drumgizmo?
Also, do you run it with memcheck tool enabled?
yes it was running with DrumGizmo but the memcheck enabled I'm not sure.
I ran it like this: valgrind --leak-check=full ardour5

finotti
Established Member
Posts: 378
Joined: Thu Sep 01, 2011 9:07 pm

Re: [ANN] LSP Plugins 1.0.24 release is available

Post by finotti »

Again, just in case it helps someone: now Ardour 5.9 is on the KXStudio repositories and I tried a similar set up, with a drum MIDI track using Drumgizmo. (I had also tried it with 5.8.)

I did not have any problems with the LSP plugins. Drumgizmo itself made Ardour (5.8 and 5.9) crash a few times when I tried to open its interface, but I could open the project and play it without problems. I could open and change the LSP plugin (parametric EQ -- 16 band I think) and change it without problems.

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: [ANN] LSP Plugins 1.0.24 release is available

Post by funkmuscle »

finotti wrote:Again, just in case it helps someone: now Ardour 5.9 is on the KXStudio repositories and I tried a similar set up, with a drum MIDI track using Drumgizmo. (I had also tried it with 5.8.)

I did not have any problems with the LSP plugins. Drumgizmo itself made Ardour (5.8 and 5.9) crash a few times when I tried to open its interface, but I could open the project and play it without problems. I could open and change the LSP plugin (parametric EQ -- 16 band I think) and change it without problems.
I am currently going to set up a project and instead of sending drumgizmo to bus tracks I will actually record them and then remove the DG plugin and midi track and then load up the LSP equalizers and see if that makes a difference..

User avatar
sysrqer
Established Member
Posts: 1941
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: [ANN] LSP Plugins 1.0.24 release is available

Post by sysrqer »

There seems to be something wrong when automating the wet control of the Impulse Reverb Stereo in ardour 5.9. It seems to only allow levels of certain amounts and the points it does allow are very wide apart.

User avatar
sadko4u
Established Member
Posts: 779
Joined: Mon Sep 28, 2015 9:03 pm

Re: [ANN] LSP Plugins 1.0.24 release is available

Post by sadko4u »

sysrqer wrote:There seems to be something wrong when automating the wet control of the Impulse Reverb Stereo in ardour 5.9. It seems to only allow levels of certain amounts and the points it does allow are very wide apart.
Emmm? Maybe it's Ardour-related problem? Wet is a simple gain control that can be set to any value between 0 and 100. 1 means 0dB level.
LSP (Linux Studio Plugins) Developer and Maintainer.

User avatar
sysrqer
Established Member
Posts: 1941
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: [ANN] LSP Plugins 1.0.24 release is available

Post by sysrqer »

sadko4u wrote: Emmm? Maybe it's Ardour-related problem? Wet is a simple gain control that can be set to any value between 0 and 100. 1 means 0dB level.
I'm not sure, I haven't seen this with any other plugins. It only seems to be the gain controls which do this, same with the compressor and the other impulse plugin.

User avatar
sadko4u
Established Member
Posts: 779
Joined: Mon Sep 28, 2015 9:03 pm

Re: [ANN] LSP Plugins 1.0.24 release is available

Post by sadko4u »

sysrqer wrote: I'm not sure, I haven't seen this with any other plugins. It only seems to be the gain controls which do this, same with the compressor and the other impulse plugin.
I think I should look at this and ask Ardour devs.
LSP (Linux Studio Plugins) Developer and Maintainer.

finotti
Established Member
Posts: 378
Joined: Thu Sep 01, 2011 9:07 pm

Re: [ANN] LSP Plugins 1.0.24 release is available

Post by finotti »

sysrqer wrote:There seems to be something wrong when automating the wet control of the Impulse Reverb Stereo in ardour 5.9. It seems to only allow levels of certain amounts and the points it does allow are very wide apart.
FWIW, I can confirm this. (The ir.lv2, for instance, does not have this problem.)

User avatar
forestandgarden
Established Member
Posts: 203
Joined: Wed May 24, 2017 9:18 pm
Contact:

Re: [ANN] LSP Plugins 1.0.24 release is available

Post by forestandgarden »

Emmm? Maybe it's Ardour-related problem?
Emmm, maybe that soon will be the standard educated guess considering ardour vs. lv2 plugin clashes? I've certainly seen more of these since upgrading beyond ardour3, I also see a trend to simply blacklist plugins. But I must admit that I lack the means for systematic testing, ardour changes, the plugins change, underlying libraries change, my low-end equipment changes..
What you could always do, is trying the same plugins in other hosts - e.g. qtractor, carla - in the same system, and it should be easy to see whether bugs like the gain control graduation problem persist. You could then again load more plugins & do things that put your system nearer the limit to see what crashes when&how and draw at least some conclusions from that comparison.
some of my stuff is ending up here https://clyp.it/user/i4p5dng1 , and you can love me at https://liberapay.com/aloo_shu

TraumFlug
Established Member
Posts: 16
Joined: Sat Dec 26, 2009 2:07 am

Re: [ANN] LSP Plugins 1.0.24 release is available

Post by TraumFlug »

I still experience the laggy graphics with renoise 3.1 on xubuntu 16.04.

For example the steren (non sc) limiter at first seems ok, but as soon as audio runs through the graphics get choppy, and the gui becomes very laggy in response. All plugins are affected, but it seems like the more realtime graph info is in them the stronger the problems can get. feeding silence makes it snappy again. In windowed mode (renoise's) the problem seems not as strong at first than in fullscreen mode, but will develop within a short time on my system.

I remember doing short testing 1.0.23 with ardour, and there the guis were totally fluent and reactive.

User avatar
sadko4u
Established Member
Posts: 779
Joined: Mon Sep 28, 2015 9:03 pm

Re: [ANN] LSP Plugins 1.0.24 release is available

Post by sadko4u »

I'm currently working on new implementation of widgets. Probably we'll get soon new UI for plugins.
LSP (Linux Studio Plugins) Developer and Maintainer.

Post Reply