Focusrite Scarlett 18i20 Help (please)

Discuss your workplace, instruments, amps, and any other gear.

Moderators: MattKingUSA, khz

Post Reply
marcos x
Established Member
Posts: 5
Joined: Mon Feb 03, 2014 3:41 am

Focusrite Scarlett 18i20 Help (please)

Post by marcos x »

Hello, running ubuntu 12.04 LTS on a fairly new i7 quad core with 32 GB RAM...have been on Linux of one type or another since 2006
Had a focusrite scarlett 18i6 running perfectly for past year...no issues.
Last week that 18i6 crapped out (lost one chann0el), so ran to local music vendor and got the brand new Focusrite Scarlett 18i20

From sites on the net it theoretically should have worked...NOT

Have tried many things, compiling new drivers, trying everybodies previously posted fixes. no success.

Shows up in - ls usb
Jack sees it, but gives D-bus error and won't start. pulse and alsa do not 'see' the device though...confusing to me.
any advice ?

I tried it under Windy7 and it workes flawlessly. Ubuntu still recognizes my old unit albeit with a dead channel, but will not recognize this one...obviously NOT class compliant after all.

Am halfway through a video edit and would love to be able to have sound...in every way except audio, Linux has been fantastic and every 'issue' easily fixable, but in the audio department would have to say Linux is still behind...

User avatar
GMaq
Established Member
Posts: 1670
Joined: Fri Sep 25, 2009 1:42 pm

Re: Focusrite Scarlett 18i20 Help (please)

Post by GMaq »

Hi,

If I'm not mistaken it is class compliant but requires a proprietary mixer application which causes the ALSA driver to fail.

More info here: http://wiki.linuxaudio.org/wiki/hardware_support

cowboystitching
Established Member
Posts: 47
Joined: Fri Nov 02, 2012 9:43 am

Re: Focusrite Scarlett 18i20 Help (please)

Post by cowboystitching »

Are you using qjackctl or Cadence to set up your jack connection? What sample rate are you trying to run it at?

marcos x
Established Member
Posts: 5
Joined: Mon Feb 03, 2014 3:41 am

Re: Focusrite Scarlett 18i20 Help (please)

Post by marcos x »

Still struggling, luckily could switch my studio to use windows to save me for the last project...good thing I kept my W7 up to date 'just in case' -whew!!1

Run at 44.1 for a variety of reasons, external to discussion, sampling rate is not the issue, I tried all that first of course, Ram is 32 GB and 2nd gen i7 2600 processor so not the computer, ibelieve it has to do with the 'mixer' not being discovered in alsa

Tried all the work arounds, the recomipling alsa etc... no go, am on 3.8 currently and alsa 1.0.25, even tried full new install, just in case after trying everything, and still back to square one trying everything all over again to no avail...

Got the 18i6 working last year no problem, system will just not allow the 18i20 to be used due to d:bus errors, pulse also does not even see it, jack and alsa do, but do not let it start - can't recognize drivers, socket server errors etc. i don't really need pulse right now, but eventually would be nice if it was at least usable under pulse too.

After dropping over $500 (before buying reading on the focusrite development site that it should work) was kind of disappointed.

really this device should be removed from the focusrite development team site as being 'should be working' (from site "USB Audio Interfaces) quote:

Should work: Scarlett 2i2, 2i4, 8i6, 18i6, 6i6, 18i8, 18i20, Saffire 6 USB MkII (USB audio class 2.0 compatible), Forte and iTrack Solo"

so warning to those thinking of buying this unit - avoid for time being, at least until issues are worked out.

marcos x
Established Member
Posts: 5
Joined: Mon Feb 03, 2014 3:41 am

Re: Focusrite Scarlett 18i20 Help (please)

Post by marcos x »

i.m going to re-install my old 2 channel MIA pci card I used to use, as a temporary fix. I hate going backwards and rue having to pull my tower from my custom baffled box with nicely run cable runs all zapstrapped in...but need to have a working machine, the MIA card is still a good card and easy to get working in Linux.

In every other area Linux seems to be superior to the others, but in audio it is way behind...the audio issues keep it away from greater acceptance.

cowboystitching
Established Member
Posts: 47
Joined: Fri Nov 02, 2012 9:43 am

Re: Focusrite Scarlett 18i20 Help (please)

Post by cowboystitching »

Just posted about this in my other thread.

User avatar
MattKingUSA
Moderation Services Senior Administrator
Posts: 680
Joined: Fri Mar 21, 2008 4:01 pm
Location: Choctaw Nation, OK
Contact:

Re: Focusrite Scarlett 18i20 Help (please)

Post by MattKingUSA »

The only way that I could get the scralett to work was to turn off wifi. Not sure what the relation was but it worked with wifi off.
-Matt

baconature
Established Member
Posts: 119
Joined: Wed Dec 18, 2013 9:15 pm
Location: Idaho
Contact:

Re: Focusrite Scarlett 18i20 Help (please)

Post by baconature »

Hi,
I got a scarlett 18i20 last month also. It works for me. It took two things for me to get it working. I had to realize that the unit had to be turned on before opening Jack. I also had to adjust the jack setting from the stock PC sound card to the correct input and output device. It sounds as though you would already know this though.

On my duel boot machine, I can run this hardware without problem under either KXStudio or UbuntuStudio 12.04. **edit January, 2016 - It also works with xubuntu 14.04 and KXStudio 14.04 no problems. It ain't quite plug and play but simple. end edit **

I wish I could help knowingly. If you want to further investigate my settings, just ask. I will be happy to try and help you resolve this.

regards,
Tom
Last edited by baconature on Thu Jan 21, 2016 5:30 am, edited 2 times in total.
Tom ~ Idaho USA

UbuntuStudio 18.04, Intel i5 3.30GHz 6600, Asus Q170Mc MotherBoard, 32Gb ram

My Music Site

lem8r
Established Member
Posts: 3
Joined: Tue May 13, 2014 7:35 am

Re: Focusrite Scarlett 18i20 Help (please)

Post by lem8r »

try upgrading kernel or alsa. scarlett has no mixer support in alsa drivers that's why it was ignored in older kernels/alsa. starting with some kernel version my 18i20 shows in alsa device list and can be used with jack but still without mixer support.
I've tried patches for alsa to get mixer control from here http://focusritedevelopmentteam.wordpre ... -products/
but lack of adequate mixer gui ends with resetting all internal routing and setting of 18i20 by alsa mixer

User avatar
AlexTheBassist
Established Member
Posts: 353
Joined: Mon May 19, 2014 3:44 am
Location: Russia, Moscow

Re: Focusrite Scarlett 18i20 Help (please)

Post by AlexTheBassist »

MattKingUSA wrote:The only way that I could get the scralett to work was to turn off wifi. Not sure what the relation was but it worked with wifi off.
This usually happens if you have a USB 3.0 host controller. I had the similar issue on my laptop, but in my case wi-fi just caused series of xruns. The interface worked good with wi-fi turned off, so now I just disable the wi-fi card when doing musical stuff.
Being creative does not imply being lazy, stupid, or illiterate.

Working in Harrison Mixbus and Ardour on KDE Neon + KXStudio.

djembeing
Posts: 1
Joined: Wed Mar 12, 2014 6:19 pm

Re: Focusrite Scarlett 18i20 Help (please)

Post by djembeing »

I've just began with a Scarlett 2i2 and I had the same error. It works fine if plugged in before you start Jack. You have to select the interface in jack settings. If jack gets started without the interface plugged in, it defaults to whatever other audio hardware (internal card), then the next time you try to start it tries to do the same but gets confused or something.
Basically, if you get the d-bus error, check jack's settings and make sure the scarlett is selected as the interface, restart jack. worked for me.
hope this helps.

Post Reply