Page 1 of 1

Rosegarden plugins

Posted: Sun Jun 08, 2008 3:08 pm
by funkmuscle
Hey, does anyone use Rosegarden's synth plugins or it's vst capability?
I do but I have a problem with the EDITOR button on the synth plugins.

For instance, the dssi-fluidsynth, I can't load any soundfonts. I would click on the editor button and nothing.

This Rosegarden-1.7.0. It all worked on earlier versions.

Posted: Sun Jun 08, 2008 3:48 pm
by studio32
have you installed dssi-fluidsynth etc?

Posted: Sun Jun 08, 2008 4:37 pm
by funkmuscle
everything is installed.
the plugins are there, they just don't work.

fluidsynth will launch, I click on the editor button and nothing happens. I can't load the soundfonts. I would load a vst and try to load a wav sample, nothing happens.

Posted: Sun Jun 08, 2008 5:29 pm
by brummer
did the plugins work in plain host's (jack-dssi-host, ghostess, or dssi-vst, vsthost)

are you shure that the audio connection to jack is work ?

could you play sound with extern synth's ?

here work everything with rosegarden 1.7.0 and dssi/ladspa/vst plugins.

Posted: Sun Jun 08, 2008 9:05 pm
by funkmuscle
I use vsthost to run vst as standalone all the time... I use fluidsynth with Qsynth all the time..
All that worked before I upgraded to the latest Rosegarden. In fact, when I install the older Rosegarden, everything works. 1.6.1 works, 1.7.0 plugins for synths work, the editor button doesn't.
If a synth or a vst doesn't need any files loaded with it, they work but to load the soundfonts in dssi-fluidsynth or to load an impulse response file in say, keFIR-vst, the editor button does not allow me to do so. All work on 1.6.1.
Otherwise, Rosegarden-1.7.0 rocks....

Posted: Mon Jun 09, 2008 7:54 am
by raboof

Have you brought this up on the rosegarden mailinglists/bugtracker yet? Might be worth a shot.

Posted: Wed Jun 11, 2008 4:57 pm
by schivmeister
hey funkmuscle good to see you here. I've seen your post on the Arch BBS but I'll reply here.

I don't use Rosegarden so I still have the one from [extra] which is, and it does work. I'll install the latest and check it out. I assume the problem might be distro-specific, in which case you may be missing some extra commands in the PKGBUILD. You can actually take a look at an ebuild and get some pointers.

Posted: Thu Jun 12, 2008 12:29 pm
by funkmuscle
schivmeister, the one from extra does work so you maybe right.
I think it could be distro specific that's why I was asking before doing a bugtracker at rosegarden...
I'll check the ebuild also

see ya at the proaudio repo schivmeister.