Non session manager

Support & discussion regarding DAWs and MIDI sequencers.

Moderators: MattKingUSA, khz

Post Reply
muzikermammoth
Established Member
Posts: 18
Joined: Sun Jun 09, 2019 6:10 pm

Non session manager

Post by muzikermammoth »

I've recently built a version of this, but when the i run ./non-session-manager , there's this message

Code: Select all

[non-session-manager] Error starting process: No such file or directory


And all the options are greyed out. There's an nsm process listening but the rest of it isn't working. How do i solve this?

tavasti
Established Member
Posts: 1060
Joined: Tue Feb 16, 2016 6:56 am
Location: Kangasala, Finland
Contact:

Re: Non session manager

Post by tavasti »

muzikermammoth wrote:I've recently built a version of this, but when the i run ./non-session-manager , there's this message

Code: Select all

[non-session-manager] Error starting process: No such file or directory


And all the options are greyed out. There's an nsm process listening but the rest of it isn't working. How do i solve this?
You are running it ./non-session-manager, so you haven't installed it, so maybe it won't find other non-programs from your $PATH?
Linux veteran & Novice musician

Latest track: https://www.youtube.com/watch?v=ycVrgGtrBmM
More my music https://audiu.net/users/tawaste

User avatar
studio32
Established Member
Posts: 2423
Joined: Mon Apr 07, 2008 5:09 pm

Re: Non session manager

Post by studio32 »

How did you install it? Which Linux distro?

You can start it by typing the name in your terminal or find it in your menus.

Code: Select all

$ non-session-manager
Not

Code: Select all

$./non-session-manager

muzikermammoth
Established Member
Posts: 18
Joined: Sun Jun 09, 2019 6:10 pm

Re: Non session manager

Post by muzikermammoth »

I built a version of it. But this error message has me stumped. The path should be correct as well, but i'll recheck.

muzikermammoth
Established Member
Posts: 18
Joined: Sun Jun 09, 2019 6:10 pm

Re: Non session manager

Post by muzikermammoth »

Hmm another pebkac moment. Yes it was a path issue. I was logged in from an account that wasn't running the updated path.

Thanks everyone !!!

Post Reply