Ardour crash?{SOLVED}

Support & discussion regarding DAWs and MIDI sequencers.

Moderators: MattKingUSA, khz

Post Reply
Established Member
Posts: 24
Joined: Thu Nov 29, 2018 3:38 pm

Ardour crash?{SOLVED}

Post by Aquarious12 »

Hello friends ,

My ardour started to crash frequently when i try to load more than 5 zynfusion plugins with some effect in plugin itself and in the mixer panel of the track. i did thought the problem was my ulimit memory resctriction but i did clear it by editing /etc/security/limits.conf.but my problem has not solved yet can any one tell me anything that i should do.

my configration

lenovo S100 idea
i3 processor (initial)
4gb ram
12 gb swap
4.19.2 kernal version
arch linux with only libreoffice,pro-audio,guvcview,firefox and chromium...nothing more major than this.
Last edited by Aquarious12 on Sat Sep 14, 2019 8:10 pm, edited 1 time in total.

Established Member
Posts: 546
Joined: Thu Mar 12, 2015 8:41 am

Re: Ardour crash?

Post by gimmeapill »

No idea what is going on in your case, but that's probably worth reporting:

Edit: Don't forget to read this as well, or you might end up disappointed.

User avatar
Established Member
Posts: 702
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Ardour crash?

Post by Linuxmusician01 »

For myself for future reference:
  1. Zynfusion is a paid version of Zynaddsubfx (link). I'm therefore not going to installl or support it. In my opinion you already paid the company for that. Sorry, man...
  2. It's a Linux native 64 bit VST as well as a LV2 (not Windows 32 bit etc.)
  3. Ardour supports Linux native VST's: make sure you've installed the Linix version of said plugin.
Good luck!

Established Member
Posts: 637
Joined: Thu Oct 11, 2018 4:13 pm

Re: Ardour crash?

Post by merlyn »

Aquarious12 wrote: i did thought the problem was my ulimit memory resctriction
I noticed JACK couldn't lock memory on my Arch system no matter what I had set in limits.conf or /etc/security/limits.d//99-realtime-privileges.conf. You can see if this is happening by ticking 'verbose' in Cadence or Qjackctl and looking at the log when you start JACK.

This turned out to be an issue with systemd and it was fixed when systemd was updated with pacman -Syu.

I see you have an older kernel, so you probably haven't updated for a while. It's worth trying updating Arch.

Post Reply