Plugins gone from Qtractor

Support & discussion regarding DAWs and MIDI sequencers.

Moderators: khz, MattKingUSA

thebutant
Established Member
Posts: 135
Joined: Sun Nov 18, 2012 12:59 pm

Plugins gone from Qtractor

Postby thebutant » Thu Dec 27, 2018 7:58 pm

Suddenly a lot of my plugins aren't showing up in Qtractor anymore.
This includes Calf (even Calf-git and Calf-ladspa, when I tried installing those), MDA plugins, C* plugins and maybe more.

The plugins all show up in Carla and Ardour, and seem to be working as usual. But in Qtractor they're suddenly gone. Even after rescan.

Anyone else experiencing this?
Or knowing how to fix it?

User avatar
rncbc
Established Member
Posts: 721
Joined: Mon Apr 19, 2010 12:20 pm
Contact:

Re: Plugins gone from Qtractor

Postby rncbc » Thu Dec 27, 2018 11:22 pm

have you messed around with plugin paths in View > Options... > Plugins > Paths ? note that only those paths in there, if any, are searched for plugins and nothing else (note the usual default search paths are overridden).

thebutant
Established Member
Posts: 135
Joined: Sun Nov 18, 2012 12:59 pm

Re: Plugins gone from Qtractor

Postby thebutant » Fri Dec 28, 2018 8:16 am

rncbc wrote:have you messed around with plugin paths in View > Options... > Plugins > Paths ? note that only those paths in there, if any, are searched for plugins and nothing else (note the usual default search paths are overridden).

Ah. . . Yes, I'll try. But it seems something's not quite as it should in my current Qtractor build.
Actually, after thinking about it, this might be related to the KXStudio repos.
I run Mint with KXStudio repos (and a rt-kernel).
Right before Christmas, the update to Qtractor 0.9.3 came along. And I updated. Everything's fine.
Then, just a couple of days ago, a new Qtractor update to 0.9.3 showed up, simply a new build for some reason. And then this problem occured.
So I don't know what was fixed in this new build of 0.9.3, but it seems to me something was also broken.

My partner's computer ran into to the exact same problem, so I think this build has something strange to it.

fraslo
Established Member
Posts: 20
Joined: Sun Jun 28, 2015 2:51 pm

Re: Plugins gone from Qtractor

Postby fraslo » Fri Dec 28, 2018 9:33 am

Hi,

same problem here (Mint 19.1), Calf plugins are not found anymore. LV2-Plugins are disabled in qtractor as announced.

You are not alone :-)

User avatar
rncbc
Established Member
Posts: 721
Joined: Mon Apr 19, 2010 12:20 pm
Contact:

Re: Plugins gone from Qtractor

Postby rncbc » Fri Dec 28, 2018 11:28 am

fraslo wrote:LV2-Plugins are disabled in qtractor as announced.


is this announcement shown in red on the Help > About... box?
if yes then a severely broken qtractor build is being delivered by the kxstudio repos.
sorry for that though is not my fault :)

fraslo
Established Member
Posts: 20
Joined: Sun Jun 28, 2015 2:51 pm

Re: Plugins gone from Qtractor

Postby fraslo » Fri Dec 28, 2018 11:42 am

rncbc wrote:is this announcement shown in red on the Help > About... box?


Yes, it is. Maybe this topic should be moved to the kxstudio threads?
Last edited by fraslo on Fri Dec 28, 2018 11:51 am, edited 1 time in total.

thebutant
Established Member
Posts: 135
Joined: Sun Nov 18, 2012 12:59 pm

Re: Plugins gone from Qtractor

Postby thebutant » Fri Dec 28, 2018 11:49 am

rncbc wrote:
fraslo wrote:LV2-Plugins are disabled in qtractor as announced.


is this announcement shown in red on the Help > About... box?
if yes then a severely broken qtractor build is being delivered by the kxstudio repos.
sorry for that though is not my fault :)

Yes, it does say so. With red letters: LV2 Plug-in support disabled.
And in the Options -> Plugins -> Paths there's no option for setting LV2 paths. Just LADSPA, DSSI, VST.
It seems this is out your hands, @rncbc, that it's KXStudio related.
I hope someone there will fix it soon.

User avatar
rncbc
Established Member
Posts: 721
Joined: Mon Apr 19, 2010 12:20 pm
Contact:

Re: Plugins gone from Qtractor

Postby rncbc » Fri Dec 28, 2018 12:04 pm

so please report or move this into kxstudio discussion topic, perhaps?

btw. tell kxstudio repo admins to make the next build of qtractor v0.9.3 with ./configure --enable-lv2-ui-gtk2 explicitly requiring libgtk2.0-dev and all its resp.deps. to be linked in -- this is allegedly necessary on some systems (ubuntu, debian derivatives, arch, etc. but strangely not on opensuse though) to have the Calf plugins and other Gtk2 GUIs to show up nicely without crashing qtractor on sight, even though libSUIL is being upgraded to v0.10.2 as I think was the main reason for this last repo update.

cheers && happy NYE (in advance ;))


Return to “Recorders & Sequencers”

Who is online

Users browsing this forum: No registered users and 3 guests