Progwolff Performer on Ubuntu

Support & discussion regarding DAWs and MIDI sequencers.

Moderators: khz, MattKingUSA

Post Reply
User avatar
noedig
Established Member
Posts: 161
Joined: Wed Feb 12, 2014 4:39 am
Location: South Africa

Progwolff Performer on Ubuntu

Post by noedig »

Has anyone managed to build Progwolff's Performer (https://github.com/progwolff/performer) on Ubuntu?
I get the following compaint from cmake:

Code: Select all

CMake Error at /usr/lib/x86_64-linux-gnu/cmake/Qt5/Qt5Config.cmake:26 (find_package):
  Could not find a package configuration file provided by "Qt5QuickWidgets"
  with any of the following names:

    Qt5QuickWidgetsConfig.cmake
    qt5quickwidgets-config.cmake

  Add the installation prefix of "Qt5QuickWidgets" to CMAKE_PREFIX_PATH or
  set "Qt5QuickWidgets_DIR" to a directory containing one of the above files.
  If "Qt5QuickWidgets" provides a separate development package or SDK, be
  sure it has been installed.
Call Stack (most recent call first):
  CMakeLists.txt:11 (find_package)
Does anyone know which packages need to be installed?

progwolff
Established Member
Posts: 44
Joined: Tue Sep 27, 2016 9:08 am
Location: Lübeck, Germany

Re: Progwolff Performer on Ubuntu

Post by progwolff »

Here is a list of Qt5 packages for ubuntu: http://askubuntu.com/questions/508503/w ... 5-in-14-04

The right package for you seems to be qtdeclarative5-dev

User avatar
noedig
Established Member
Posts: 161
Joined: Wed Feb 12, 2014 4:39 am
Location: South Africa

Re: Progwolff Performer on Ubuntu

Post by noedig »

Performer is proving stubborn to build (or maybe it's just me).
Firstly, Ubuntu 14 (on which KXStudio iso's and Mint 17.3 is based) doesn't seem to have the qtdeclarative5-dev package.
Now on Mint 18, only to find out that the Qt version is 5.5.1. Performer seems to require at least Qt 5.6.
I'm getting there slowly but surely (although I'm beginning to consider installing Arch for this :P )

progwolff
Established Member
Posts: 44
Joined: Tue Sep 27, 2016 9:08 am
Location: Lübeck, Germany

Re: Progwolff Performer on Ubuntu

Post by progwolff »

Wow, I didn't know Ubuntu is so far behind...

Please fetch the latest commit. It should build now with Qt 5.5.
There won't be a document viewer though, as QWebEngine is not available for Ubuntu and you probably don't want to install Okular.

Thanks for your effort!

User avatar
noedig
Established Member
Posts: 161
Joined: Wed Feb 12, 2014 4:39 am
Location: South Africa

Re: Progwolff Performer on Ubuntu

Post by noedig »

Thanks for the help. However, the compiler is now complaining about std::function:

Code: Select all

[ 39%] Building CXX object src/CMakeFiles/performer.dir/carlapatchbackend.cpp.o
/home/gideon/Desktop/performer/performer/src/carlapatchbackend.cpp: In member function ‘virtual void CarlaPatchBackend::preload()’:
/home/gideon/Desktop/performer/performer/src/carlapatchbackend.cpp:662:9: error: ‘function’ is not a member of ‘std’
         std::function<void()> exithandler =  [this]()
         ^
From searching around I gather that std::function was introduced with C++11. However, I notice CXX_FLAGS = -std=c++0x.... in the generated makefiles, so g++ should be using c++11 then if I understand correctly.

Any ideas?

progwolff
Established Member
Posts: 44
Joined: Tue Sep 27, 2016 9:08 am
Location: Lübeck, Germany

Re: Progwolff Performer on Ubuntu

Post by progwolff »

I installed KXStudio in a virtual machine.

This is how I managed to build performer with a document viewer enabled on a fresh KXStudio install: https://github.com/progwolff/performer/ ... buntu-1404

User avatar
noedig
Established Member
Posts: 161
Joined: Wed Feb 12, 2014 4:39 am
Location: South Africa

Re: Progwolff Performer on Ubuntu

Post by noedig »

Thanks Progwolff!
Sorry that you had to spoonfeed everything.

I now have it working and will play with it when I get time.

One initial snag: I didn't initially have a Documents folder in my home directory, so Performer fails to create a new Carla patch with the plus button and there is no GUI feedback. The only indication was "file does not exist..." lines in the console output. I created a Documents folder and it works now, but perhaps just something to consider.

Anyway, will post back with my success stories. Thanks again.

progwolff
Established Member
Posts: 44
Joined: Tue Sep 27, 2016 9:08 am
Location: Lübeck, Germany

Re: Progwolff Performer on Ubuntu

Post by progwolff »

noedig wrote: Sorry that you had to spoonfeed everything.
No reason to apologize. Thanks for testing! I'm happy with every issue that is reported, so I can make better software. I wouldn't have thought that it's such a problem to build Qt5 applications on KXStudio.
noedig wrote: One initial snag: I didn't initially have a Documents folder in my home directory...
Right. I noticed that too and forgot to fix it. Is fixed upstream now.

progwolff
Established Member
Posts: 44
Joined: Tue Sep 27, 2016 9:08 am
Location: Lübeck, Germany

Re: Progwolff Performer on Ubuntu

Post by progwolff »

If someone is still interested: I added a Debian package for KXStudio at https://github.com/progwolff/performer/releases
Install it with

Code: Select all

sudo dpkg -i Performer-KXStudio-1.0.1.deb
With this package you don't need Qt5 libs, but no document viewer is enabled.

If you want a document viewer to be enabled, follow the steps described above.

millenniloon
Posts: 1
Joined: Mon Apr 02, 2018 5:18 pm

Re: Progwolff Performer on Ubuntu

Post by millenniloon »

Hi, trying to install as per your instructions in README.md, but keep coming up against a problem. I'm running Linux Mint (latest) BTW.

I had to change to:

git clone https://github.com/progwolff/performer.git

as "git@github.com:progwolff/performer.git" didn't work.

cd performer (fine)

mkdir build && cd build (fine)

cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_DATADIR=/usr/share -DQt5_DIR=~/Qt5.7.0/5.7/gcc_64/lib/cmake/Qt5 -DJACK_LIBRARIES=/usr/lib/x86_64-linux-gnu/libjack.so -DJACK_INCLUDEDIR=/usr/include ..

This is where I'm coming unstuck - I get:

CMake Error at /home/aaron/Qt5.7.0/5.7/gcc_64/lib/cmake/Qt5Gui/Qt5GuiConfigExtras.cmake:9 (message):
Failed to find "GL/gl.h" in "/usr/include/libdrm".
Call Stack (most recent call first):
/home/aaron/Qt5.7.0/5.7/gcc_64/lib/cmake/Qt5Gui/Qt5GuiConfig.cmake:146 (include)
/home/aaron/Qt5.7.0/5.7/gcc_64/lib/cmake/Qt5Widgets/Qt5WidgetsConfig.cmake:87 (find_package)
/home/aaron/Qt5.7.0/5.7/gcc_64/lib/cmake/Qt5/Qt5Config.cmake:26 (find_package)
CMakeLists.txt:23 (find_package)

Bearing in mind I'm a novice Linux user, but a keen musician - what do I do now?

Thanks in advance.

progwolff
Established Member
Posts: 44
Joined: Tue Sep 27, 2016 9:08 am
Location: Lübeck, Germany

Re: Progwolff Performer on Ubuntu

Post by progwolff »

Hi millenniloon,

sorry for the late reply. Have been away from this forum for a while...
Failed to find "GL/gl.h" in "/usr/include/libdrm"
indicates that you need to install a package that ships "gl.h".
If I'm not wrong, this is "mesa-common-dev" on Ubuntu/Mint.

So, this should do the trick:

Code: Select all

sudo apt-get install mesa-common-dev
export PATH="/home/aaron/Qt5.7.0/5.7/gcc_64/bin/:$PATH"
rm -Rf /home/aaron/performer/build
cd /home/aaron/performer
mkdir build && cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_DATADIR=/usr/share -DQt5_DIR=~/Qt5.7.0/5.7/gcc_64/lib/cmake/Qt5 -DJACK_LIBRARIES=/usr/lib/x86_64-linux-gnu/libjack.so -DJACK_INCLUDEDIR=/usr/include ..
make
sudo make install
If you encounter errors like "libQt5WebEngineWidgets.so.5: cannot open shared object file" you might need to add the path to the new Qt5 libraries to your LD_LIBRARY_PATH. For this, edit the file /home/aaron/.bashrc and append the following line:

Code: Select all

export LD_LIBRARY_PATH="/home/aaron/Qt5.7.0/5.7/gcc_64/lib/:$LD_LIBRARY_PATH"
After doing this, log out, log back in and performer should run.

I'm sorry that it's such a pain to install it on Ubuntu14 / Mint /....
I have no clue why they still hold back Qt 5.7. On Arch Linux I'm using 5.10 without any problems...

If you have any further issues, please open an issue on github. I will react more quickly there.

Cheers,
Julian

Post Reply