Hydrogen stopped running (KXStudio 14.04.2) [Solved]

Support & discussion regarding DAWs and MIDI sequencers.

Moderators: MattKingUSA, khz

Post Reply
Quillz
Established Member
Posts: 12
Joined: Sat Oct 26, 2013 12:51 pm

Hydrogen stopped running (KXStudio 14.04.2) [Solved]

Post by Quillz »

Hi,

Up until this evening Hydrogen was running fine. Then I tried running it alongside Rosegarden and QSampler and it (hydrogen) crashed. Whenever I try to run it I see the splash-screen then nothing, except 1 xrun gets logged.

I'm running it in KXStudio 14.04.2 64-bit with 3.13.0-101-lowlatency kernel. I'm not sure which version of Hydrogen because I can't run it to find out.

I have uninstalled and purged and then reinstalled it (apt-get) and have the latest version according to that.

Any help would be appreciated, thanks.
Last edited by Quillz on Thu Nov 24, 2016 7:19 pm, edited 1 time in total.

User avatar
funkmuscle
Established Member
Posts: 2473
Joined: Mon Jun 02, 2008 2:30 pm

Re: Hydrogen stopped running (KXStudio 14.04.2)

Post by funkmuscle »

that was my problem on Arch and it was the gcc. Reinstalled gcc. fixed.

Quillz
Established Member
Posts: 12
Joined: Sat Oct 26, 2013 12:51 pm

Re: Hydrogen stopped running (KXStudio 14.04.2)

Post by Quillz »

Thanks for the replies :)

I've just got in from work and had time to take a look.
that was my problem on Arch and it was the gcc. Reinstalled gcc. fixed.
Okay. So I did some quick googling and figured you meant do a

Code: Select all

sudo apt-get install --reinstall gcc
. apt-get did its thang and when I attempted to run hydrogen it looked hopeful for a minute - the splash screen really looked like it was thinking about it! - and... computer said "no"
see if removing hydrogen-drumkits fixes the issue.
Similarly, I did a

Code: Select all

sudo apt-get remove hydrogen-drumkits
. apt-get did its thang and again, no go.

Both times I actually ran hydrogen from the terminal (normally use the short-cut in the apps menu) and I noticed this:

"Hydrogen 0.9.6.1 [Aug 7 2016] [http://www.hydrogen-music.org]
Copyright 2002-2008 Alessandro Cominu

Hydrogen comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details

Floating point exception"

Just for the record, I have asked this question in the Hydrogen forums and even gave it a couple of days before posting here, but it's had 50 views and no replies.

User avatar
English Guy
Established Member
Posts: 499
Joined: Wed Oct 17, 2012 7:28 pm
Location: England

Re: Hydrogen stopped running (KXStudio 14.04.2)

Post by English Guy »

Sorry if I am stating the obvious, but have you tried re installing hydrogen itself. I would also try opening a different drum file in case the one you are trying to open is corrupted. If all else fails try removing the configuration files in your home directory in case something was corrupted there when it crashed.

Quillz
Established Member
Posts: 12
Joined: Sat Oct 26, 2013 12:51 pm

Re: Hydrogen stopped running (KXStudio 14.04.2)

Post by Quillz »

Hi English Guy

I ran

Code: Select all

apt-get remove --purge hydrogen
which should remove the config files - as far as I'm aware. And then re-installed.

I have right-clicked->open-with->hydrogen on a number of *.h2songs, all to no avail.

User avatar
English Guy
Established Member
Posts: 499
Joined: Wed Oct 17, 2012 7:28 pm
Location: England

Re: Hydrogen stopped running (KXStudio 14.04.2)

Post by English Guy »

I think you will find configuration files in your home directory are not affected by the --purge option.

EDIT: You will find them at /home/my_username/.hydrogen/

I usually rename rather than delete so they can be restored if they are not the issue.
Last edited by English Guy on Wed Nov 23, 2016 7:46 pm, edited 1 time in total.

User avatar
English Guy
Established Member
Posts: 499
Joined: Wed Oct 17, 2012 7:28 pm
Location: England

Re: Hydrogen stopped running (KXStudio 14.04.2)

Post by English Guy »

I would also try running it from a terminal to see if there is any useful output.

EDIT: When you run it use the --verbose flag.

Quillz
Established Member
Posts: 12
Joined: Sat Oct 26, 2013 12:51 pm

Re: Hydrogen stopped running (KXStudio 14.04.2)

Post by Quillz »

Thanks, English Guy. I renamed the hydrogen.conf in /home/username/.hydrogen and that sorted it.

Much appreciated.

User avatar
English Guy
Established Member
Posts: 499
Joined: Wed Oct 17, 2012 7:28 pm
Location: England

Re: Hydrogen stopped running (KXStudio 14.04.2)

Post by English Guy »

Yay - result :D

Quillz
Established Member
Posts: 12
Joined: Sat Oct 26, 2013 12:51 pm

Re: Hydrogen stopped running (KXStudio 14.04.2) [Solved]

Post by Quillz »

Dear mods, I noticed other topics had a "solved" tag added to them when they'd been sorted out and I took the liberty of doing so with this one. I hope that's okay :)

glowrak guy
Established Member
Posts: 1487
Joined: Sat Jun 21, 2014 8:37 pm

Re: Hydrogen stopped running (KXStudio 14.04.2) [Solved]

Post by glowrak guy »

Some forums it's even mandatory, or at least expected, and it's good manners.
It's also nice for people to state solutions they found themselves,
after others tried helping, instead of just vanishing. Sometimes
the search engines find that answer down the road when someone is in need.
A road we all travel on.
Cheers

Post Reply