[SOLVED] LMMS, Carla and Arch64

Support & discussion regarding DAWs and MIDI sequencers.

Moderators: MattKingUSA, khz

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: LMMS, Carla and Arch64

Post by funkmuscle »

Yep the same package. Not the vst as I get the same issue with recompiling the repo version. I know weird!
Something may of changed and I now need the 32bit dependencies.

Joermungand
Established Member
Posts: 276
Joined: Wed Oct 24, 2012 5:19 pm

Re: LMMS, Carla and Arch64

Post by Joermungand »

The vst PKGBUIILD was updated yesterday (probably to reflect version 1.1.0, I wouldn’t know, never tried it) and it lists gcc-multilib under dependencies. I don’t know about the previous versions of the git package, either, as I installed multilib support right from the start, which was a few years ago. My bet is on the 32-bit libraries – but, as I said, they shouldn’t break anything.

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: LMMS, Carla and Arch64

Post by funkmuscle »

Yeah the vst versions always had those dependencies. I ran it once on my old laptop.
I even have older git 64 builds on my system and they install when I tried them.

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: LMMS, Carla and Arch64

Post by funkmuscle »

just added gcc-multilib and gcc-libs-multilib and the Git version built..
AND IT'S WORKING... :D

funny, it also installed the VeSTige plugin too. :?:

thanx Joermungand
Last edited by funkmuscle on Fri Jan 09, 2015 9:27 pm, edited 1 time in total.

Joermungand
Established Member
Posts: 276
Joined: Wed Oct 24, 2012 5:19 pm

Re: LMMS, Carla and Arch64

Post by Joermungand »

You’re welcome. I thought it would.

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: LMMS, Carla and Arch64

Post by funkmuscle »

Joermungand wrote:You’re welcome. I thought it would.
:D

bigjuergo
Established Member
Posts: 15
Joined: Thu Jan 21, 2016 11:52 am

Re: [SOLVED] LMMS, Carla and Arch64

Post by bigjuergo »

i read this thread, but i do not understand how to get the carla plugin in lmms.

i have ubuntu studio in installed lmms and carla.
both are working, but i can not see a carla plugin in lmms.

do i have to deinstall carla and lmms again and complile the 2 programms from source?

thank you for help!

bigjuergo
Established Member
Posts: 15
Joined: Thu Jan 21, 2016 11:52 am

Re: [SOLVED] LMMS, Carla and Arch64

Post by bigjuergo »

thank you for your answer falkTX.

do you mean i have to deinstall lmms and carla.

then add the kxrepositories and install carla and lmms with apt-get install?

bigjuergo
Established Member
Posts: 15
Joined: Thu Jan 21, 2016 11:52 am

Re: [SOLVED] LMMS, Carla and Arch64

Post by bigjuergo »

i run

Code: Select all

sudo apt-get update
sudo apt-get install carla-git
opend lmms but could not find the carla plugin

did i forget something?

bigjuergo
Established Member
Posts: 15
Joined: Thu Jan 21, 2016 11:52 am

Re: [SOLVED] LMMS, Carla and Arch64

Post by bigjuergo »

i run the following cmds

Code: Select all

sudo apt-get upgrade
sudo apt-get install lmms
sudo apt-get install carla
sudo apt-get install carla-git
and finally the plugins are there :D

thx a lot mr. falkTX!
You do not have the required permissions to view the files attached to this post.

Post Reply