[SOLVED] LMMS, Carla and Arch64

Support & discussion regarding DAWs and MIDI sequencers.

Moderators: MattKingUSA, khz

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

[SOLVED] LMMS, Carla and Arch64

Post by funkmuscle »

hey guys, Arch just added LMMS 1.1 to it's repo but no Carla plugin.
I'm running Carla-git because that's the only Carla available on Arch unless I use the binary from KX.
Compiling it doesn't work that's why I waited for the repo.
Am I missing something?

I can't ask at the forum at Arch because most of the dudes there are not music minded and they would send me here.
Last edited by funkmuscle on Fri Jan 09, 2015 10:02 pm, edited 1 time in total.

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: LMMS, Carla and Arch64

Post by funkmuscle »

falkTX wrote:You want the carla-lmms plugin, right?

You need to get carla-git first, then compile lmms.
got the carla-git but the compiling of lmms failed that's why I waited for the repo.
will try again falk.. thanx

Joermungand
Established Member
Posts: 276
Joined: Wed Oct 24, 2012 5:19 pm

Re: LMMS, Carla and Arch64

Post by Joermungand »

Hi,

The LMMS binary in the repo will not see Carla. So you will have to install the lmms-git version in AUR. I saw the errors posted on the AUR page, but I got none of that. I finished compiling it a couple of minutes ago – no issue here. I’m on 64-bit Arch. You might want to give it another try. And, just as falkTX said, you will have to compile and install Carla first (git version in AUR does it).

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: LMMS, Carla and Arch64

Post by funkmuscle »

I've got carla-git since way back when falk first added it to AUR but you say I need to use the lmms-git to get the carla lmms?
The LMMS binary in the repo will not see Carla. So you will have to install the lmms-git version in AUR. I saw the errors posted on the AUR page, but I got none of that. I finished compiling it a couple of minutes ago – no issue here. I’m on 64-bit Arch.
from what I'm understanding, you recompiled the repo binary and it worked?

if you got the binary to work, it failed again for me. I'm using the binary's PKGBUILD:

Code: Select all

[ 83%] Generating RemoteVstPlugin
/usr/bin/ld: i386:x86-64 architecture of input file `/usr/lib/gcc/x86_64-unknown-linux-gnu/4.9.2/../../../../lib/crti.o' is incompatible with i386 output
/usr/bin/ld: i386:x86-64 architecture of input file `/usr/lib/gcc/x86_64-unknown-linux-gnu/4.9.2/crtbeginS.o' is incompatible with i386 output
/usr/bin/ld: i386:x86-64 architecture of input file `/usr/lib/gcc/x86_64-unknown-linux-gnu/4.9.2/crtendS.o' is incompatible with i386 output
/usr/bin/ld: i386:x86-64 architecture of input file `/usr/lib/gcc/x86_64-unknown-linux-gnu/4.9.2/../../../../lib/crtn.o' is incompatible with i386 output
collect2: error: ld returned 1 exit status
winegcc: g++ failed
plugins/vst_base/CMakeFiles/vstbase.dir/build.make:53: recipe for target 'plugins/vst_base/RemoteVstPlugin' failed
make[2]: *** [plugins/vst_base/RemoteVstPlugin] Error 2
CMakeFiles/Makefile2:7825: recipe for target 'plugins/vst_base/CMakeFiles/vstbase.dir/all' failed
make[1]: *** [plugins/vst_base/CMakeFiles/vstbase.dir/all] Error 2
Makefile:137: recipe for target 'all' failed
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: LMMS, Carla and Arch64

Post by funkmuscle »

just tried the AUR version and getting that same Vst crap. failing to build.
guess I'm gonna have to use the old way.. export lmms piece to Ardour and add the carla synths from there. :(

Joermungand
Established Member
Posts: 276
Joined: Wed Oct 24, 2012 5:19 pm

Re: LMMS, Carla and Arch64

Post by Joermungand »

Curious and curiouser. I’ve just rebuilt lmms-git from the AUR, but ‘Generating RemoteVstPlugin’ happens at 29%, not at 83% here. Just an idea. Have you got the gcc-multilib (from the multilib repo) package installed? And what version of Wine do you have? I have to go now, sorry, but I’ll be back in a couple of hours, maybe we’ll manage to sort it out then.

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: LMMS, Carla and Arch64

Post by funkmuscle »

I am using the latest version of wine. Not the real time version but just the regular one from the repo. I used to have gcc-multilib
but I can't remember why I got rid of it. I think it was clashing with another software that needed to have the 64 bit version.

Joermungand
Established Member
Posts: 276
Joined: Wed Oct 24, 2012 5:19 pm

Re: LMMS, Carla and Arch64

Post by Joermungand »

You will also need package lib32-glibc from multilib. Probably more. We’ll see when I get back.

Joermungand
Established Member
Posts: 276
Joined: Wed Oct 24, 2012 5:19 pm

Re: LMMS, Carla and Arch64

Post by Joermungand »

As far as I can see from the error messages you’ve posted, this is not a problem with Wine, but one related to the absence of 32-bit building tools. Without the proper 32-bit libraries installed, LMMS will not build (at least that VST-related part, as far as I can judge from the code, which is enoguh). However, that shouldn’t be a problem, since the multilib versions that conflict with their 64-bit counterparts also provide the 64-bit libraries – so it makes no difference on the 64-bit side. Those that do not conflict can be installed along the 64-bit versions.

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: LMMS, Carla and Arch64

Post by funkmuscle »

Joermungand wrote:As far as I can see from the error messages you’ve posted, this is not a problem with Wine, but one related to the absence of 32-bit building tools. Without the proper 32-bit libraries installed, LMMS will not build (at least that VST-related part, as far as I can judge from the code, which is enoguh). However, that shouldn’t be a problem, since the multilib versions that conflict with their 64-bit counterparts also provide the 64-bit libraries – so it makes no difference on the 64-bit side. Those that do not conflict can be installed along the 64-bit versions.
I've removed everything in the pkgbuild to do with vst and I used to run the Git version until recently so I don't know what is going on.
I will try installing all the 32-bit dependencies and see if that helps. Thanks again man!

Joermungand
Established Member
Posts: 276
Joined: Wed Oct 24, 2012 5:19 pm

Re: LMMS, Carla and Arch64

Post by Joermungand »

No problem. But this:
funkmuscle wrote:I've removed everything in the pkgbuild to do with vst
makes me wonder. There’s nothing in the lmms-git PKGBUILD about VST, except for Wine as an optional dependency, which doesn’t change anything when it comes to compiling. Are you sure we’re talking about the same package (and not about lmms-vst)?

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: LMMS, Carla and Arch64

Post by funkmuscle »

Yep the same package. Not the vst as I get the same issue with recompiling the repo version. I know weird!
Something may of changed and I now need the 32bit dependencies.

Joermungand
Established Member
Posts: 276
Joined: Wed Oct 24, 2012 5:19 pm

Re: LMMS, Carla and Arch64

Post by Joermungand »

The vst PKGBUIILD was updated yesterday (probably to reflect version 1.1.0, I wouldn’t know, never tried it) and it lists gcc-multilib under dependencies. I don’t know about the previous versions of the git package, either, as I installed multilib support right from the start, which was a few years ago. My bet is on the 32-bit libraries – but, as I said, they shouldn’t break anything.

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: LMMS, Carla and Arch64

Post by funkmuscle »

Yeah the vst versions always had those dependencies. I ran it once on my old laptop.
I even have older git 64 builds on my system and they install when I tried them.

User avatar
funkmuscle
Established Member
Posts: 2474
Joined: Mon Jun 02, 2008 2:30 pm

Re: LMMS, Carla and Arch64

Post by funkmuscle »

just added gcc-multilib and gcc-libs-multilib and the Git version built..
AND IT'S WORKING... :D

funny, it also installed the VeSTige plugin too. :?:

thanx Joermungand
Last edited by funkmuscle on Fri Jan 09, 2015 9:27 pm, edited 1 time in total.

Post Reply