LMMS CPU time overload

Support & discussion regarding DAWs and MIDI sequencers.

Moderators: khz, MattKingUSA

mandragoria
Posts: 1
Joined: Tue Oct 01, 2013 9:54 pm

LMMS CPU time overload

Postby mandragoria » Tue Oct 01, 2013 10:52 pm

Hello all,

This is my first post on this site, so bear with me.
I have been using LMMS for several years now. I love the program and find it very useful.
But recently, I changed my system from Ubuntu 13.04 with gnome classic (on which LMMS functioned properly) to Ubuntu studio 12.04.2 due to some stability issues I had with 13.04. Oh my computer is an Acer AspireOne with 2GB RAM and an intelAtom processor.
Since I made the switch to Ubuntu Studio, whenever I open LMMS and open a project, the CPU usage meter lingers in the yellow-red range at all times, even when nothing is playing sound. When I do try to play sound/samples it hits the red and all sound falls out.
I'm not sure why it is using so much CPU, as I said it didn't before, and I made the switch to Ubuntu studio because of the low latency kernel that was supposed to be for things like this. Anyway, I followed the advice from some various posts and played with the buffer size/latency slider in setting which made it sound horrible, but not change the CPU usage problem. I also tried giving the exact location of the sound card because it was suggested that that may also be an issue. It made no difference. I also tried making very low quality samples that also made no difference.

This initially started with the package that was in the default repositories. And I read that it was a bug from some older version of LMMS so I got the PPA for the update as per the instructions on the LMMS website and updated to version 0.4.14-rc1.
The problem didn't change.

So I was wondering if anyone had any ideas as to what I could do. Either a way to set Ubuntu studio so it runs nothing else, perhaps there is a terminal session that I can only run LMMS from? Or would it be better to use Jack to handle the sound? Or is there a stable version of LMMS maybe?
Its very frustrating because LMMS ran fine on this very computer before and I don't know what to do....

Thank you very much in advance for any help you may give me!

User avatar
bluebell
Established Member
Posts: 1149
Joined: Sat Sep 15, 2012 11:44 am
Location: Saarland & Frankfurt, Germany

Re: LMMS CPU time overload

Postby bluebell » Sat Oct 05, 2013 8:42 am

Run top in a console window to see if it's really lmms that's eating your CPU.
Linux – MOTU UltraLite AVB – Qtractor – https://soundcloud.com/suedwestlicht

davidnimmersatt
Established Member
Posts: 7
Joined: Mon Oct 07, 2013 4:43 pm

Re: LMMS CPU time overload

Postby davidnimmersatt » Mon Oct 07, 2013 4:50 pm

Hey, I have 100% the same problem.
Jack shows this error everytime the CPU usage is too high:

Code: Select all

Mon Oct  7 18:47:52 2013: ERROR: JackEngine::XRun: client = lmms was not finished, state = Running
Mon Oct  7 18:47:52 2013: ERROR: JackAudioDriver::ProcessGraphAsyncMaster: Process error
Mon Oct  7 18:47:52 2013: ERROR: JackEngine::XRun: client = lmms was not finished, state = Running
Mon Oct  7 18:47:52 2013: ERROR: JackAudioDriver::ProcessGraphAsyncMaster: Process error
Mon Oct  7 18:48:10 2013: ERROR: JackEngine::XRun: client = lmms was not finished, state = Running
Mon Oct  7 18:48:10 2013: ERROR: JackAudioDriver::ProcessGraphAsyncMaster: Process error

Kind of annoying. I am working on 32-bit KXstudio, 3.8.0 low-latency kernel.

SR
Established Member
Posts: 218
Joined: Wed May 07, 2008 6:01 pm
Location: Houston, Tx

Re: LMMS CPU time overload

Postby SR » Mon Oct 07, 2013 6:37 pm

I don't think you want to use LMMS with JACK. Use it with alsa if at all possible.

davidnimmersatt
Established Member
Posts: 7
Joined: Mon Oct 07, 2013 4:43 pm

Re: LMMS CPU time overload

Postby davidnimmersatt » Tue Oct 08, 2013 11:45 am

Just tried it with alsa. Did'nt change much. Still too much CPU...
But yes LMMS Jack support is pretty poor, they should improve that...

gazpacho
Established Member
Posts: 41
Joined: Wed Aug 15, 2012 1:49 am
Location: Mallorca

Re: LMMS CPU time overload

Postby gazpacho » Sat Oct 19, 2013 4:01 pm

Using 0.4.15-0ubuntu1+fixed1~precise
On a:
3.8.0-30-lowlatency #22-Ubuntu SMP PREEMPT Thu Sep 5 23:25:06 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
When starting lmms with jack enabled via cadence in kxstudio, xruns start to build up by the hundreds and stoping cadence must be done in a nasty way, and later it wont start until a reboot. If I change lmms to use alsa, the next time I open it it doesnt remember the last settings, it remains trying to hook to jack and hangs. It is not only unusable, it wrecks the whole sound system. Lets see if this thread gets us users relief before uninstalling it.

Post edited after zillion trials and sour head.
To get it to work with audio and midi with alsa (no jack or cadence started, no pulseaudio active), in audio settings select alsa, then under device name I put hw:2 which is my second card. You may find the number to put after "hw:" by running:

Code: Select all

  cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xdfdd4000 irq 21
 1 [Loopback       ]: Loopback - Loopback
                      Loopback 1
 2 [Live           ]: EMU10K1 - SB Live! 5.1
                      SB Live! 5.1 (rev.7, serial:0x80641102) at 0xe800, irq 16

So in my case an old soundblaster live has number 2 . Adjust to your choice.

For the midi interface settings, I put "Alsa sequencer" and under device the word "default". Then restart lmms and things work, if it doesnt try again. You know it does because if you click on the wrench/screwdriver icon on the left of "default preset" >midi>input> you see all midi inputs. Same with outputs.
Started lmms on a terminal, lots of messages about jack errors even though no jack is in the settings :shock: . At least it works.
Now I'll try to make it work under jack (cadence). Will report if any success.

Second Post edit
I got it working with jack although strangely the jack transport play doesnt activate lmms start/stop, like they are not in sync.
To make it work with jack, change the settings in lmms without starting jack or it will hang severely. If it does hang, you see xruns by the thousands and the only way to stop havoc is using in cadence the "force restart" button or writing in a terminal the command:

Code: Select all

cadence-session-start -s

In audio settings select jack, and in the device box write: lmms
The midi settings stay the same as before, alsa and in device put: default
First I start jack with cadence. Then I start lmms and get 100 xruns. Catia patch program shows lmms "master out L1" and "master out L2" connected to system playback 1 and 2 , good. Then I load a lmms demo and get another 100 xruns. If I press play it plays well with no xruns. If I start vmpk virtual keyboard it appears as a "midi in" option and once asingned to an instrument it plays OK. Every time you load a demo you get a hundred xruns but when played it stops issuing them.
In conclusion, whats the point in enabling jack if transport doesnt work? I see lmms as a program very self contained with its own instruments and stuff, so better stay away from jack and stick to alsa for audio and midi until it gets improved. And remember to not call edit>settings with jack enabled or it will hang. Good luck.

davidnimmersatt
Established Member
Posts: 7
Joined: Mon Oct 07, 2013 4:43 pm

Re: LMMS CPU time overload

Postby davidnimmersatt » Mon Oct 28, 2013 4:18 pm

Thanks gazpacho!

I dont really know why but I fugure out lmms works fine with Alsa and a big latency. I hope LMMS will improve its jack compability in the future.

SR
Established Member
Posts: 218
Joined: Wed May 07, 2008 6:01 pm
Location: Houston, Tx

Re: LMMS CPU time overload

Postby SR » Mon Oct 28, 2013 5:21 pm

davidnimmersatt wrote:I hope LMMS will improve its jack compability in the future.


I gave up hoping for that a long time ago.

Speaking of, does anyone know whatever happened to "Unity"? Wasn't that supposed to bring us the features of LMMS in a Jack-friendly package?


Return to “Recorders & Sequencers”

Who is online

Users browsing this forum: No registered users and 1 guest