Search found 325 matches

by Tim E. Real
Fri Feb 14, 2020 3:26 am
Forum: MusE Sequencer
Topic: MusE 3.1pre4
Replies: 35
Views: 1000

Re: MusE 3.1pre4

Re the noise: It was broken last month, be me :oops: - Oops! Fix bug 765: Crackling in recorded files. Caused by 01.01.2020 commit. (Tim) Changed SndFile::write(): wrFrames = realWrite(srcChannels, src, n, liveWaveUpdate); to wrFrames = realWrite(srcChannels, src, n, wrFrames, liveWaveUpdate); It lo...
by Tim E. Real
Fri Feb 14, 2020 1:23 am
Forum: MusE Sequencer
Topic: MusE 3.1pre4
Replies: 35
Views: 1000

Re: MusE 3.1pre4

PS: MidiName is almost here for LV2. Very soon. Barring these nasty noise problem fixes... You'll be able to use AVLDrums, or use DrumGizmo and switch kits on the fly, without having to resort to clumsy MusE instrument definitions or things of that nature, and all the drum note names will be there a...
by Tim E. Real
Fri Feb 14, 2020 1:19 am
Forum: MusE Sequencer
Topic: MusE 3.1pre4
Replies: 35
Views: 1000

Re: MusE 3.1pre4

No problem. Thanks. We've narrowed it down significantly.
It's MusE's fault :shock:

And the noise affects all bounced files made in the last... we don't know yet... TBD...
by Tim E. Real
Thu Feb 13, 2020 6:57 am
Forum: MusE Sequencer
Topic: MusE 3.1pre4
Replies: 35
Views: 1000

Re: MusE 3.1pre4

@funkmuscle Hi, I hate to start a thread for this completely off-topic question: I caught your post here from a few years back about your Scarlett USB crackling. The solution was the USB port, you said. Can you describe in more detail the nature of the crackling? Intermittent? Any recognizable perio...
by Tim E. Real
Sat Feb 08, 2020 1:38 am
Forum: MusE Sequencer
Topic: Major rewrite of plugin and cache system, needs testing
Replies: 4
Views: 159

Re: Major rewrite of plugin and cache system, needs testing

Sometimes it is necessary to bump up the song file version when things change. In this case it was only some track list header info that changed, so it should be relatively benign. The important thing is that the plugin cache should cause a slow update just once, then after that starting up MusE sho...
by Tim E. Real
Tue Feb 04, 2020 1:13 am
Forum: MusE Sequencer
Topic: Major rewrite of plugin and cache system, needs testing
Replies: 4
Views: 159

Major rewrite of plugin and cache system, needs testing

Greetings! As we inch towards a final release, some issues popped up with our plugin and cache system. See git issue 763. If you were experiencing slow cache recreations every time MusE was started, due to duplicate LV2 plugin names, this likely will fix that. This required a substantial rewrite. If...
by Tim E. Real
Sun Jan 26, 2020 9:13 pm
Forum: MusE Sequencer
Topic: Message about Zita not being built - but is anyway?
Replies: 3
Views: 101

Re: Message about Zita not being built - but is anyway?

It's brand new so there's much to be done. Still you can play around with it and have some fun.

Perhaps more important is the new automatic samplerate converters when importing any wave file,
where you now have a choice of a 'live' realtime samplerate converter, or conversion on-the-spot as before.
by Tim E. Real
Sun Jan 26, 2020 5:40 pm
Forum: MusE Sequencer
Topic: Message about Zita not being built - but is anyway?
Replies: 3
Views: 101

Re: Message about Zita not being built - but is anyway?

Don't worry about Zita for now. You can safely ignore it.
Zita support still needs to be completed internally.
There is no Zita cmake option at this time but when support is completed there will be.
by Tim E. Real
Thu Jan 23, 2020 5:00 pm
Forum: MusE Sequencer
Topic: Looping doesn't work anymore?
Replies: 8
Views: 272

Re: Looping doesn't work anymore?

Hi, apologies for the lack of response, I got way side-tracked. However I did manage to test and it seemed to be OK here. Can you maybe try this testing method: I tested by making a simple part with one note at each beat, driving a synth. In addition I turned on the metronome so that the metronome s...
by Tim E. Real
Sat Jan 18, 2020 11:27 pm
Forum: MusE Sequencer
Topic: MusE 3.1pre4
Replies: 35
Views: 1000

Re: MusE 3.1pre4

Yes I think that is correct. The Omni behaviour is essentially the same as old MusE before channels routes were added. Remember the single connection button way back? At this point it could be asked what good is multi-channel support if most track types are not multi-channel? True, only one track ty...
by Tim E. Real
Sat Jan 18, 2020 8:28 pm
Forum: MusE Sequencer
Topic: MusE 3.1pre4
Replies: 35
Views: 1000

Re: MusE 3.1pre4

Further insight into Omni: There is some magic that happens with Omni in two special cases: In the case of Omni connecting a mono audio track to another track having two or more channels (ie. a stereo track): MusE will automatically split (copy) that mono signal to both of the first two channels of ...
by Tim E. Real
Sat Jan 18, 2020 7:35 pm
Forum: MusE Sequencer
Topic: MusE 3.1pre4
Replies: 35
Views: 1000

Re: MusE 3.1pre4

A brief explanation of Omni: Omni has no bearing regarding Jack routes. Omni only applies to our own track-to-track routes. That's one reason why I say QJackCtl should have no trouble with MusE. Omni is a convenient way of quickly connecting MusE tracks together 'wholesale' without having to connect...
by Tim E. Real
Sat Jan 18, 2020 6:27 pm
Forum: MusE Sequencer
Topic: MusE 3.1pre4
Replies: 35
Views: 1000

Re: MusE 3.1pre4

Hi. Just enough time for a very quick rebuttal:
MusE should have no trouble using QJackCtl or similar for making connections. Great care was taken to ensure that.
You can use either one to make your connections.
If anyone has observed trouble with using QJackCtl, please let me know. Should not be so.
by Tim E. Real
Wed Jan 15, 2020 8:41 am
Forum: MusE Sequencer
Topic: Looping doesn't work anymore?
Replies: 8
Views: 272

Re: Looping doesn't work anymore?

A fix has been applied in git master now. It has been that way for quite a while. I fixed it some time ago in another pending branch of mine (pos_ctrl_fixes). So I cherry picked two things from my branch: 1) Fix when tempo serial number is incremented. (Fixes broken looping etc.) 2) Add rounding cho...
by Tim E. Real
Tue Jan 14, 2020 6:55 am
Forum: MusE Sequencer
Topic: Looping doesn't work anymore?
Replies: 8
Views: 272

Re: Looping doesn't work anymore?

Observed. Hm, something messed up with loop points after tempo is changed. If tempo is changed by say 2X, the loop points effectively become at twice their current positions. If tempo is changed by say 0.5X, the loop points effectively become at half their current positions. Workaround for now: Afte...

Go to advanced search