Search found 1268 matches

by Pablo
Tue Feb 19, 2019 6:59 pm
Forum: System Tuning and Configuration
Topic: [SOLVED] Unknown driver "alsa": Jack/Alsa suddenly not playing nice
Replies: 25
Views: 1082

Re: Unknown driver "alsa": Jack/Alsa suddenly not playing nice

Hi Skippy, no problem!

Your system seems to be broken. I don't know why.
by Pablo
Tue Feb 19, 2019 7:36 am
Forum: System Tuning and Configuration
Topic: [SOLVED] Unknown driver "alsa": Jack/Alsa suddenly not playing nice
Replies: 25
Views: 1082

Re: Unknown driver "alsa": Jack/Alsa suddenly not playing nice

I forgot to say, if jacdkbus is running on the DSP24 card, then in desktop's sound settings (which is a pulseaudio interface) you have to choose "jack sink" as the audio output to get sound from desktop applications, such as firefox (assuming you want to use the DSP24 for that). EDIT: For ...
by Pablo
Tue Feb 19, 2019 7:28 am
Forum: System Tuning and Configuration
Topic: [SOLVED] Unknown driver "alsa": Jack/Alsa suddenly not playing nice
Replies: 25
Views: 1082

Re: Unknown driver "alsa": Jack/Alsa suddenly not playing nice

It seems that there are two jack servers trying to run, one being jackdbus and the other jackd (without dbus). To start again, close the music programs and type in a terminal the following command: killall -9 jackd jackdbus qjackctl Run the above twice so that the terminal says: jackd: no process fo...
by Pablo
Mon Jan 14, 2019 9:53 pm
Forum: Computer Related Hardware
Topic: JACK capturing onboard mic
Replies: 10
Views: 1113

Re: JACK capturing onboard mic

I was originally trying to use a Scarlett 2i2 USB input (selecting it as the Input Device), and trying to trace the godawful whine from that led me to the above minimal configuration. The odd thing is that I tried the 2i2 a couple of days ago, and I can't remember the whine being there then. In the...
by Pablo
Sun Dec 02, 2018 10:21 pm
Forum: Computer Related Hardware
Topic: Scarlett 6i6 & Linux/Ardour
Replies: 11
Views: 1676

Re: Scarlett 6i6 & Linux/Ardour

My only question now revolves around the lack of sound for an additional track, until the transport rolls. This doesn't seem right to me, as it makes it difficult to set the input level relative to existing tracks. Perhaps a different preset (direct routing?) in the 6i6 will behave as I expect it t...
by Pablo
Fri Aug 24, 2018 8:48 am
Forum: System Tuning and Configuration
Topic: Very large value suggested by jack_iodelay
Replies: 3
Views: 765

Re: Very large value suggested by jack_iodelay

If I remember correctly, the original jack_delay didn't even show the "extra loopback latency" information nor the suggestion of using some number of frames for -I and -O arguments, so that might be just a false indication, but it is strange. Still, you can calculate the extra loopback lat...
by Pablo
Mon Jul 16, 2018 4:15 pm
Forum: System Tuning and Configuration
Topic: [SOLVED] audio crackling in duplex mode
Replies: 43
Views: 4460

Re: [SOLVED] audio crackling in duplex mode

I am also very glad you got it working! :D Very good solution!
by Pablo
Fri Jul 13, 2018 6:09 am
Forum: System Tuning and Configuration
Topic: [SOLVED] audio crackling in duplex mode
Replies: 43
Views: 4460

Re: audio crackling in duplex mode

That would be a negative, I get the following: $ zita-j2a -d hw:SB Can't open ALSA playback device 'hw:SB'. I guess that pulseaudio owns the hw:SB and it doesn't allow zita-j2a to grab it. However, it should allow jackdbus to grab it, I hope. So, I suggest you try the following: with pulseaudio run...
by Pablo
Thu Jul 12, 2018 10:57 pm
Forum: System Tuning and Configuration
Topic: [SOLVED] audio crackling in duplex mode
Replies: 43
Views: 4460

Re: audio crackling in duplex mode

since zita-j2a and alsa_out both work correctly when pulseaudio is not installed, is there a pacmd or pactl command that is equivalent to either zita-j2a -d hw:SB or alsa_out -d hw:SB.


pacmd and pactl are pulseaudio utilities so they can't be used if pulseaudio is not up and running.
by Pablo
Thu Jul 12, 2018 10:48 pm
Forum: System Tuning and Configuration
Topic: [SOLVED] audio crackling in duplex mode
Replies: 43
Views: 4460

Re: audio crackling in duplex mode

Misc tab --enable d-bus interface checked --enable jack d-bus interface checked --stop jack audio server on app exit checked I have the same settings. zita-j2a -d hw:SB -c 6 -r 48000 & (this works when pulse is not installed) OK. When pulse is installed zita-j2a does not load Sigh. So I remove ...
by Pablo
Thu Jul 12, 2018 7:26 pm
Forum: System Tuning and Configuration
Topic: [SOLVED] audio crackling in duplex mode
Replies: 43
Views: 4460

Re: audio crackling in duplex mode

I thought you got it working at some point... I also thought that you don't want to suspend pulseaudio. The pasuspender prefix was a trick that some people used to resort to when pulseaudio and jack didn't get along with each other, but I assume you have an up to date system. It could be that things...
by Pablo
Wed Jul 11, 2018 8:50 pm
Forum: System Tuning and Configuration
Topic: [SOLVED] audio crackling in duplex mode
Replies: 43
Views: 4460

Re: audio crackling in duplex mode

however, when I quick qjackctl which also stopped jack2dbus I have no sound. I open pavucontrol and under output devices the only entry is "Dummy output", and under the input tab I have nothing. I am trying to understand all of this. I kill pulseaudio, jack is not started. pablo@Asus:~$ k...
by Pablo
Wed Jul 11, 2018 2:55 pm
Forum: System Tuning and Configuration
Topic: [SOLVED] audio crackling in duplex mode
Replies: 43
Views: 4460

Re: audio crackling in duplex mode

My guess wasn't right because hw:SB,0 is, effectively, an analog playback device. So it's all right :D Configuring the output of pulseaudio to the jack sink means that pulse's output audio signal can be connected to jack-audio writable clients, including the zita-j2a ports, which means the SB card i...
by Pablo
Mon Jul 09, 2018 8:10 pm
Forum: System Tuning and Configuration
Topic: [SOLVED] audio crackling in duplex mode
Replies: 43
Views: 4460

Re: audio crackling in duplex mode

hw:SB is equivalent to hw:SB,0 (card SB, device #0) but are you sure that hw:SB,0 is a playback device, in alsa's terms? To make sure, use this informative command: arecord -l && aplay -l zita-j2a doesn't work and I suspect it is because hw:SB,0 could be a capture only device. Does it appear...
by Pablo
Mon Jul 09, 2018 2:30 pm
Forum: System Tuning and Configuration
Topic: [SOLVED] audio crackling in duplex mode
Replies: 43
Views: 4460

Re: audio crackling in duplex mode

I think that it makes more sense for your use case if you use jack with the USB card (capture-only mode seems more adequate if the audio outputs are not in use) and the pulseaudio jack sink for the SB and I will try to explain the reason why. I assume that the SB live has an internal mixer which als...

Go to advanced search