Samson Carbon 49 on Ubuntu

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

Samson Carbon 49 on Ubuntu

Postby flagos » Tue Nov 13, 2012 3:58 pm

Hi to all. Anyone made to work Samson Carbon 49 midi controller with Ubuntu? (via jack or any other way?)

Thanks in advance!
flagos
Establlshed Member
 
Posts: 10
Joined: Sat Nov 03, 2012 11:56 pm

Re: Samson Carbon 49 on Ubuntu

Postby varpa » Tue Nov 13, 2012 9:12 pm

This is a standard midi device using USB, so it will show up as an Alsa midi device (since USB devices use Alsa). Hence, the keyboard should show up in the "Alsa" tab of QJackCtl (see http://www.rncbc.org/drupal/node/76) or with the command line "aplaymidi -l". You can use command "a2jmidid -e" to create connections between Alsa and Jack midi (device will show up under a2j in QJackCtl "Jack" tab. Using QJackCtl (or similar like ladish, Klaudia, etc) you can connect the keyboard to other Jack applications like synths.
varpa
Establlshed Member
 
Posts: 304
Joined: Fri Feb 25, 2011 6:40 pm

Re: Samson Carbon 49 on Ubuntu

Postby flagos » Thu Dec 20, 2012 3:30 pm

Varpa, thanks for your answer. I've been trying with your advice but with no luck.

Either connecting the Carbon 49 via USB or via the MIDI in port of my Audiophile 2496 card, the command aplaymidi -l gives:

Port Client name Port name
14:0 Midi Through Midi Through Port-0
20:0 M Audio Audiophile 24/96 M Audio Audiophile 24/96 MIDI
128:0 TiMidity TiMidity port 0
128:1 TiMidity TiMidity port 1
128:2 TiMidity TiMidity port 2
128:3 TiMidity TiMidity port 3

And, if the Carbon 49 is connected via USB port, any key pressed on it, fire keyboard events in ubuntu, activating menus and shortcuts in the active window.

Do you have an idea what could be happening?

Thanks very much!
flagos
Establlshed Member
 
Posts: 10
Joined: Sat Nov 03, 2012 11:56 pm

Re: Samson Carbon 49 on Ubuntu

Postby AutoStatic » Thu Dec 20, 2012 4:29 pm

flagos wrote:And, if the Carbon 49 is connected via USB port, any key pressed on it, fire keyboard events in ubuntu, activating menus and shortcuts in the active window.
Then it doesn't send out MIDI over USB, but that's weird. You're sure you don't have anything running that maps MIDI messages to keystrokes? And what do you want to control with the Carbon 49?
User avatar
AutoStatic
Establlshed Member
 
Posts: 1665
Joined: Wed Dec 09, 2009 5:26 pm
Location: Beverwijk, The Netherlands

Re: Samson Carbon 49 on Ubuntu

Postby flagos » Mon Dec 24, 2012 2:39 am

AutoStatic:

The Carbon 49 manual says: "MIDI: MIDI over USB, 5-Pin MIDI OUT" so supposedly, it should send MIDI over usb.

About the other. I think I don't have anything installed mapping MIDI to keystrokes. Anyway I don't know how to check that. I have Ubuntu 11.10 pretty default installed, with:

Audacity, Clementine, GStreamer for ffmpeg, GStreamer for AAC, GSTreamer for MMS, Ardour, Jkmeter, Hydrogen, QJackCtl, ZynAddSubFX, xjadeo and Yoshimi.

Any ideas?

Thanks!
flagos
Establlshed Member
 
Posts: 10
Joined: Sat Nov 03, 2012 11:56 pm

Re: Samson Carbon 49 on Ubuntu

Postby Pablo » Mon Dec 24, 2012 10:59 am

"aplaymidi -l" prints a list of possible output ports. But the Carbon 49 only sends MIDI, so, from the POV of the computer, is a possible *input* port.

Take a look at:

arecordmidi -l
Pablo
Establlshed Member
 
Posts: 1017
Joined: Thu Apr 17, 2008 9:57 pm

Re: Samson Carbon 49 on Ubuntu

Postby flagos » Mon Dec 24, 2012 4:28 pm

Pablo, thanks for your help!

Either, connecting the Carbon 49 via usb, or via the MAudio Audiophile 2496 MIDI-in, I have the same result for "arecordmidi -l":

Port Client name Port name
14:0 Midi Through Midi Through Port-0
16:0 M Audio Audiophile 24/96 M Audio Audiophile 24/96 MIDI

BUT, I've just installed KMidiMon, and if I enable the "M Audio Audiophile 24/96" input in Connections, I can see the MIDI messages as I press keys in the Carbon 49. So, maybe I need some kind of connection between the Audiophile card MIDI ports and ALSA??

Any help?

Thanks!!!
flagos
Establlshed Member
 
Posts: 10
Joined: Sat Nov 03, 2012 11:56 pm

Re: Samson Carbon 49 on Ubuntu

Postby Pablo » Wed Dec 26, 2012 7:17 pm

Weird, when you connect it via usb, does it appear in the terminal output of "cat /proc/asound/cards" ?

Anyway, assuming it works via the MIDI cable, what you need is an app that converts the MIDI notes coming from your MIDI keyboard to audio, i.e., a soft synth. From the programs you mentioned, zynaddsubfx. Or hydrogen, or qsynth with a soundfont loaded, just to name a few that you can easily install from the software center.

You will also need the jack audio server. Tipically, you set up and start jack via qjackctl (Jack Control). You can make alsa MIDI connections in the alsa tab of qjackctl. In the audio tab, connect the ouput ports of the synth to the "system: playblacks". This is to play live. There are other possiblities.

Cheers, Pablo
Pablo
Establlshed Member
 
Posts: 1017
Joined: Thu Apr 17, 2008 9:57 pm

Re: Samson Carbon 49 on Ubuntu

Postby ezergal » Wed Oct 02, 2013 3:47 pm

Hi, i have the same issue here, though i managed to connect it through jack connections... still i am unable to rout it to ardour, and when i achieve to have zynadd with sound ardour doesn't (and the other way around)... any hint?
ezergal
 
Posts: 3
Joined: Wed Oct 02, 2013 3:37 pm

Re: Samson Carbon 49 on Ubuntu

Postby flagos » Thu Oct 03, 2013 8:21 pm

I managed to make it to work connecting Carbon 49 via midi (not usb) using my sound card midi in connection. I have to launch QJackCtrl and connect there the sound card midi out to (in my case) Hexter midi in, and the audio Hexter output to the system out. (You could save this settings using the patchbay feature).

Having all that set, if I open ardour I can record right from Hexter setting the proper input in an Ardour channel.

Hope this helps.
flagos
Establlshed Member
 
Posts: 10
Joined: Sat Nov 03, 2012 11:56 pm

Re: Samson Carbon 49 on Ubuntu

Postby gallecito » Sat Oct 19, 2013 5:27 pm

I have a Samson Carbon 61 and had exactly the same problem... after almost giving up and returning the keyboard I had an idea: look for pointer devices and deactivate the one S Carbon is using. It works after you out the following commands in the terminal and you switch off and on the keyboard:

Determine the device id (the device name should be something with touchpad or glidepoint)
xinput list

{Mine comes at "15" as "James Lam SAMSON Carbon61"

Disable it (e.g. here the device id is 15)
xinput set-prop 15 "Device Enabled" 0

You may run the command during session startup

I think we should tell Ubuntu about this bug.

Bes regards
gallecito
 
Posts: 1
Joined: Sat Oct 19, 2013 5:22 pm

Re: Samson Carbon 49 on Ubuntu

Postby lgarrido » Fri Aug 15, 2014 9:22 pm

For the sake of posterity, a problem like this on a Samson Carbon 61 has been found to be caused by faulty firmware. Be sure you update it to the latest version which fixes this issue.
lgarrido
 
Posts: 1
Joined: Fri Aug 15, 2014 8:46 pm


Return to Computer Related Hardware

Who is online

Users browsing this forum: No registered users and 3 guests